no /media directory in Ubuntu 12.04 ?

Asked by Teunis Ott on 2012-10-08

I run Ubuntu 12.04 . I connected an old (~2007) USB hard drive. The partitions on that drive automatically
became visible (one separate window for each partition).
(names of the partitions are NJIT3 , NJIT4 , etc, a few are described only by size).
Those windows show the files etc inside the respective partitions.
Format is VFAT.

I can not find out how to comfortably access these partitions.

Used to be I could see them as
/media/NJIT1
/media/NJIT2
etc (I think I was still running RedHat at the time).
(and then read, write, copy, etc as any file or directory.)

But my computer does not have a /media directory. It HAS a /mnt directory, but that one is empty.

HELP

Teunis J. Ott
<email address hidden>

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-10-08
Last query:
2012-10-08
Last reply:
2012-10-08

Mount them using nautilus and run:

mount

You will see the mount points of each partition.

Teunis Ott (teun) said : #2

Can you expand on "Mount them using nautilus"?

I typed "nautilus" in my home directory. It created a window which shows
the contents of my home directory, plus on the left side the partitions in
the USB drive (with roughly the names I had given them in 2007:
NJIT3 , NJIT4 , etc. only the numbers have changed).

How can I mount these directories?
(with or without nautilus).

Where do I run "mount" ? In my home directory?

What I want is have them visible as

<directoryname>/NJIT1
<directoryname>/NJIT2
etc.
(or other numbers than 1 , 2 , ... .)

Another question remains: does Ubuntu have a /media directory?
I used to use RedHat.

Best, Teun.

On 10/08/2012 10:21 AM, actionparsnip wrote:
> Your question #210672 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/210672
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> Mount them using nautilus and run:
>
> mount
>
> You will see the mount points of each partition.
>

Just get access as you normally do, or is this the issue?

Teunis Ott (teun) said : #4

Problem solved.

I typed "mount" in my home directory, that seems to have created
the /media directory AND mounted the partitions there.

teun@Lucas:/$ cd media
teun@Lucas:/media$ ls -lt
total 100
drwxr-xr-x 2 root root 4096 Jun 8 12:05 cdrom
drwxr-xr-x 3 root root 4096 Oct 28 2007
eb406759-2cac-45c5-9460-52d76f335425
drwxr-xr-x 3 root root 4096 Oct 28 2007
ae1080b2-e566-49b9-9122-6937aefdacce
drwx------ 101 teun teun 16384 Dec 31 1969 NJIT3
drwx------ 2 teun teun 16384 Dec 31 1969 NJIT4
drwx------ 2 teun teun 16384 Dec 31 1969 NJIT5
drwx------ 2 teun teun 16384 Dec 31 1969 NJIT6
drwx------ 2 teun teun 16384 Dec 31 1969 NJIT7
drwx------ 3 teun teun 8192 Dec 31 1969 NJIT8
teun@Lucas:/media$

Though I do not understand where the dates (Dec 31 1969) come from.

Many Thanks, Teun Ott.

On 10/08/2012 10:21 AM, actionparsnip wrote:
> Your question #210672 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/210672
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> Mount them using nautilus and run:
>
> mount
>
> You will see the mount points of each partition.
>

Teunis Ott (teun) said : #5

See my previous Email: Problem solved.

There was no /media directory. Now there is. ???

Your reference to nautilus was superfluous and confusing.

I did "mount" in my home directory.
I assume this amounts to an automount , which I had tried,
but with argument "NJIT*". (did not work.)

Best, Teun.

On 10/08/2012 10:56 AM, actionparsnip wrote:
> Your question #210672 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/210672
>
> Status: Open => Needs information
>
> actionparsnip requested more information:
> Just get access as you normally do, or is this the issue?
>

Please mark as solved if it is so. Thanks

Teunis Ott (teun) said : #7

Problem solved.

The documentation can use some improvement.

According to my observations, the directory /media did not exist but was created when I executed
the "mount" command (without options). I will observe whether it will continue to exist after I unmount.

The correct procedure is:

Connect USB exernal hard drive to USB port.
Observe the computer sees it: a window is created for every partition.
execute "mount", without options. (Just type mount, followed by carriage return. E.g. in home directory.)

---

I have a left over remark:

"fdisk -l" recognized /dev/sdg1 , which is "the whole disk". Documentation should say not to worry that
"mount" will mount that "device". (The other "devices" from the USB disk were
sdg5 , ... , sdg12 . These together cover almost the whole disk.

Teun Ott.