Natty Boot Problem

Asked by Iqbal on 2012-09-29

Hi,
I have HP Probook. It came with pre-installed SUSE 11.
I installed Natty on the laptop. During Installation, I chose second option of installing ubuntu on the entire disk.

Problem:

At booting time, the menu for choosing kernel or recovery mode comes up thereafter screen goes blank. If I press Alt+F2 and enter userid and password then $ prompt comes up. I have to force shut down.

I again boot, then it boots up.

Please provide the solution.

Following is the output of fdisk -l:

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x00021125

Device Boot Start End Blocks Id System
/dev/sda1 * 1 60549 486354944 83 Linux
/dev/sda2 60549 60802 2028545 5 Extended
Partition 2 does not start on physical sector boundary.
/dev/sda5 60549 60802 2028544 82 Linux swap / Solaris

Following are the lines of dmesg:

[ 2.157616] sd 0:0:0:0: [sda] 976773168 512-byte logical blocks: (500 GB/465 GiB)
[ 2.157618] sd 0:0:0:0: [sda] 4096-byte physical blocks
[ 2.157643] sd 0:0:0:0: Attached scsi generic sg0 type 0
[ 2.157648] sd 0:0:0:0: [sda] Write Protect is off
[ 2.157649] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[ 2.157660] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[ 2.219153] sda: sda1 sda2 < sda5 >
[ 2.219480] sd 0:0:0:0: [sda] Attached SCSI disk
[ 3.150525] EXT4-fs (sda1): INFO: recovery required on readonly filesystem
[ 3.150528] EXT4-fs (sda1): write access will be enabled during recovery
[ 3.228768] EXT4-fs (sda1): recovery complete
[ 3.229346] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[ 10.979105] Adding 2028540k swap on /dev/sda5. Priority:-1 extents:1 across:2028540k
[ 11.301310] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
[ 12.148125] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
[ 14.311495] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
Iqbal
Solved:
2012-10-05
Last query:
2012-10-05
Last reply:
2012-09-29
N1ck 7h0m4d4k15 (nicktux) said : #1

Hi ,

why you want to install natty (ubuntu 11.04) ? natty it will EOL in a few days. No more support .

https://wiki.ubuntu.com/Releases

My suggestion is to try the newest LTS (Long Term Support) version Ubuntu 12.04.1

Support until April 2017

Thanks

Add the boot option:

nomodeset

I assume you are using some Intel GPU thing.

Iqbal (naqvi-iqbal2001) said : #3

Hi,
Regarding post #1, I do not find ubuntu hash of 12.04.1 on the page
https://help.ubuntu.com/community/UbuntuHashes. So I did not install 12.04. Otherwise I would like to install 12.04.

Regarding post #2, I shall do it then inform.

Iqbal (naqvi-iqbal2001) said : #4

Hi,
I set the option nomodeset and booted, the graphics quality deteriorated. Then I removed the option.

The grub menu shows 2 kernels 2.6.38-8 and 2.6.38-16. If I choose 2.6.38-8 then it boots otherwise blank screen comes up. In black screen, if i press Alt+f2 then a cursor blinks and nothing happens and I have to shutdown by pressing power button.

Sasa Paporovic (melchiaros) said : #5

Hi Iqbal,

may be you find this usefull:

http://cdimage.ubuntu.com/releases/

there are all releases for Ubuntu with their hash files up to SHA256,

especially for the latest precise:

http://cdimage.ubuntu.com/releases/precise/release/

Also usefull is the firefox extension downthemall to do automatically hash checking during download.

You are also very welcome to use:

http://cdimage.ubuntu.com/releases/quantal/beta-2/

or:

http://cdimage.ubuntu.com/daily-live/current/

which is the current development version Ubuntu 12.10, which is going towards the finish line.

greetings

melchiaros

Iqbal (naqvi-iqbal2001) said : #6

Hi,
I got the hash of ubuntu 12.04 and installed.
While installing I defined my own partitions.

This solved my problem also.

Thank you, melchiaros

Iqbal