Cannot access Fedora Formatted hard drives

Asked by Fernando Pathan on 2012-09-26

Hi everyone

First of all, let me specify that I am a noob in regard to Linux commands, but I can find my way around, if carefully explained.
Recently I changed from Fedora 14 to Ubuntu Desktop 12.04, but now I cannot access all my previous hard drives.

When mounted (through Disk Utility) and trying to access them, I get "You do not have the nessecery permission to the contents of (hard drive name).

When I check on the permission tab I see Owner: 500 -user #500

I read while searching around that Ubuntu gives the admin a privilage of 1000 whereas Fedora gives 500.

Is there a way to work around that? And what should I do? I cannot reformat the drives as it contains informations.

They are all formated either on EXT3 or EXT4.

Thanks

PS: I tried chown and chmod, but I pretty much sure I'm doing something wrong here.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
Warren Hill
Solved:
2012-09-27
Last query:
2012-09-27
Last reply:
2012-09-26

You can use mounting options to make it owned by your user and should help

Best Warren Hill (warren-hill) said : #2

The first thing we need to know that we can see all the drives and where they are mounted in the system to do this open a terminal CTRL+ALT+T and enter the following commands.

sudo fdisk -l; mount | grep ^'/dev'

You should get an output similar to this
~$ sudo fdisk -l; mount | grep ^'/dev'

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x0006d954

   Device Boot Start End Blocks Id System
/dev/sda1 * 2048 616957951 308477952 83 Linux
/dev/sda2 616959998 625141759 4090881 5 Extended
Partition 2 does not start on physical sector boundary.
/dev/sda5 616960000 625141759 4090880 82 Linux swap / Solaris

Disk /dev/sdc: 8004 MB, 8004304896 bytes
35 heads, 21 sectors/track, 21269 cylinders, total 15633408 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot Start End Blocks Id System
/dev/sdc1 32 15633407 7816688 b W95 FAT32
/dev/sda1 on / type ext4 (rw,errors=remount-ro)
/dev/sdc1 on /media/C70D-45B5 type vfat (rw,nosuid,nodev,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,flush,uhelper=udisks)

you can then use mount to mount and partitions that are not mounted

Once done you can use the file manager to access your data,

Note: you may need to be root for this in which case the command is

gksu nautilus

either from the run box (ALT-F2) or in a terminal

If you run the command in a terminal do not close the terminal window until you have finished in the file manager.

Thank you Warren Hill,

That did the trick!!! :)

Thanks Warren Hill, that solved my question.