First time login and the file system is Read Only

Asked by Tim Pickard on 2012-09-25

Last night I loaded Ubuntu Server 12.04.1 LTS (64bit) on a Xenserver, using a cloned template and internet installation. The instructions I followed were supposed to load it in PV mode not HVM. I chose various features, LAMP, Kubuntu, and a couple others. Not much since I'm just trying to start off with a Web Server with GUI. (Can't remember the URL for the instructions I followed and I have to follow instructions since I am a newbie with Linux. Tried Googling it again and I think I found them, but can't access that URL from work.)(But for the instalation: http://archive.ubuntu.com/...)

It seemed to go great, even saw something about it getting an IPv6 address through my tunnelbroker setup. Logged on with the user account and it won't start the desktop GUI when I run that command, has to be the root user. Tried the root user using sudo and it wants to start, but pukes with a Read Only error. I think the directory was /tmp, I don't remember the filename it wanted to create (that was 1am last night when I gave up for the night).

Am I messing up with how I'm using Startx and sudo, so that it is trying to start in the wrong directory or has something locked down the file system during the installation?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
Tim Pickard
Solved:
2012-09-25
Last query:
2012-09-25
Last reply:
2012-09-25

press CTRL+ALT+F1 and login there, you can now run:

sudo mount -o remount,rw /

Then press CTRL+ALT+F7 and log in there.

Tim Pickard (timothy-pickard) said : #2

That returned the following error:
[60891.015639] EXT4-fs error (device xvda1): ext4_remount:4534: Abort forced by user
mount: cannot remount block device /dev/xvda1 read-write, is write-protected

When first logging on I get this:
Unable to setup logging. [Errno 30] Read-only file system: '/var/log/landscape/sysinfo.log'
run-parts: /etc/update-motd.d/50-landscape-sysinfo exited with return code 1
/usr/lib/update-notifier/update-motd-updates-available: 49: /usr/lib/update-notifier/update-motd-updates-available: cannot create /var/lib/update-notifier/updates-available: Read-only file system
run-parts: /etc/update-motd.d/90-updates-available exited with return code 2
/usr/lib/update-manager/release-upgrade-motd: 39: /usr/lib/update-manager/release-upgrade-motd: cannot create /var/lib/update-notifier/release-upgrade-available: Read-only file system
/usr/lib/update-notifier/update-motd-fsck-at-reboot: 28: /usr/lib/update-notifier/update-motd-fsck-at-reboot: cannot create /var/lib/update-notifier/fsck-at-reboot: Read-only file system
run-parts: /etc/update-motd.d/98-fsck-at-reboot exited with return code 2
Welcome to Ubuntu 12.04.1 LTS (GNU/Linux 3.2.0-31-generic x86_64)

 * Documentation: https://help.ubuntu.com/

  System information as of Tue Sep 25 00:37:36 EDT 2012

  System load: 0.47 Memory usage: 7% Processes: 94
  Usage of /: 12.4% of 38.88GB Swap usage: 0% Users logged in: 0

  => There is 1 zombie process.

  Graph this data and manage this system at https://landscape.canonical.com/

The programs included with the Ubuntu system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Ubuntu comes with ABSOLUTELY NO WARRANTY, to the extent permitted by
applicable law.

Tim Pickard (timothy-pickard) said : #3

Used the old standby for a new install that pukes. Wipe and Reload. Added only one package during the install (LAMP) and the desktop is installing from the CLI now.

Thanks for trying.