fsck freezes in recovery mode

Asked by Someone on 2012-08-28

When I try to run 'grub update', 'clean', 'dpkg' or 'fsck' or 'enable networking' from recovery mode in grub, fsck runs:
fsck from util-linux 2.20.1
/dev/sda9: clean, 199539/6250496 files, 2107721/25000192 blocks
then in the next line, the locator blinks but nothing happens (and I must reset my system). I even left it for about 3 hours but nothing happened.
But when I run fsck from 'root' option in recovery menu, it doesn't freeze and shows the text above and finishes working.
I accessed the recovery menu by 'ubuntu, with Linux 3.2.0-27-generic (recovery mode)' and also tried previous versions (3.2.0-26 and 23) but still have this problem.
I use kubuntu 12.04 LTS and version of grub is 1.99-21ubuntu3.1.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Last query:
2012-08-28
Last reply:
2013-01-16
Someone (amirms76) said : #1

I observed this when I tried to update grub from recovery mode after unsuccessful installation of debian 6.0 into /dev/sda10 (It failed because it couldn't install grub or the other boot menu (I can't remember its name))

Have you tested your RAM?

Someone (amirms76) said : #3

Yes, I'm sure it has no problems

Someone (amirms76) said : #4

I use x64 version of kubuntu

Is it a SATA drive? You could set the SATA to IDE mode

Someone (amirms76) said : #6

Well I think it's SATA but note that I didn't have this problem about a month ago.

Someone (amirms76) said : #7

I checked SATA configurtation. It was set to IDE.

Could try the ultimate boot cd, it has the tools from the main HDD manufacturers and you can test the drive at a very low level. Takes a while so run it overnight

Graeme Hewson (ghewson) said : #9

It seems it's a bug; I've just added a link to bug 1061239.

Can you help with this problem?

Provide an answer of your own, or ask Someone for more information if necessary.

To post a message you must log in.