Root failure after Ubuntu 10.04 to 12.04 upgrade

Asked by Andrew Squibb on 2012-08-26

I have been running Ubuntu 10.04 LTS since its release, on a Dell Inspiron laptop. The hard drive is partitioned, with Windows Vista still installed (though not used for years and only kept as a back-up in case of compatibility problems). I tried yesterday to upgrade to Ubuntu 12.04 via the update manager.

The upgrade appeared successful, but after rebooting the system as instructed to complete the upgrade, an Ubuntu screen appeared with the error message "Disc drive for / is not ready yet or not present", with the options to wait, press S to skip or M to manually recover.

This screen did not change after leaving the computer for several hours. After switching off and restarting, the same message appeared. I found the skip option gave a similar message about the disc drive for /tmp: Skipping this as well gave a black screen showing just a flashing cursor.

Switching off and starting again, then selecting manual recovery led to a screen showing:

Root filesystem check failed.
A maintenance shell will now be started.
CONTROL-D will terminate this shell and reboot the system.
root@andrew-laptop:~#

Discussions of similar problems on the Ubuntu forums recommended making sure the disc drive was mounted in read-write configuration by running mount -n -o remount,rw /, followed by dpkg --configure -a to finish the upgrade properly. Trying to manually recover following that method has given me the following:

Root filesystem check failed.
A maintenance shell will now be started.
CONTROL-D will terminate this shell and reboot the system.
root@andrew-laptop:~# mount -n -o remount,rw /
root@andrew-laptop:~# dpkg --configure -a
dpkg: error: parsing file '/var/lib/dpkg/status' near line 4740 package 'lexmark-inkjet-09-driver':
 blank line in value of field 'Description'
root@andrew-laptop:~#

I have tonight downloaded Ubuntu 12.04 from the Ubuntu website to CD (using a borrowed laptop), to re-install from scratch. However, my computer is now attempting to boot 10.04 from the hard disc (with the results above) even when booting from CD is selected.

Windows Vista does still appear to start up successfully from the hard disk, when selected.

I would appreciate any help you can give to solve this - my laptop is effectively unusable at present.

Many thanks in advance.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Last query:
2012-08-26
Last reply:
2012-08-26
Vlad (sudofication) said : #1

You might have a bad CD. Have you tried it on another computer?

Have you tried these: https://help.ubuntu.com/community/LiveCdRecovery

Seems you have done a bad install cd so please be sure to:

- download the iso file using torrent protocol to have a good error correction on download
- the torrent protocol usually made a good download of the .iso file but BE SURE to check the md5sum of the downloaded .iso file
- burn it on a cd at lower speed you can do and with data verify on

Bill Hammond (gellmu) said : #3

I had a very similar experience on 27 Aug 2012 with the LTS upgrade from 10.04.4 to 12.04.1. I'm still trying to complete this upgrade (rather than giving up with a CD installation).

Two of us have reported that the upgrade seems to go well, reaching a point where the user is asked to reboot whereupon the system won't come up properly. Yes, there is a recovery shell, but that is beyond the ability of the target audience. I don't know exactly why the system does not come up. Possibly it has something to do with grub. For me this was resolved when later I was able to take the upgrade further, and at that point the system came up normally except for (1) no X11 (but all ttys), (2) it still self-identifies as "lucid" though most installed packages are "precise", and (3) the kernel is still from lucid. The upgrade stall seemed to have to do with erroneous dependency requirements involving xserver-xorg-video* and gvfs*. I got past that by using dpkg to install (from /var/cache) three libs that the xserver-xorg things wanted, but then later those libs and the offending xserver-xorg things were automatically removed. (I posted details at askubuntu.)

Currently, I'm hung up with dependency issues for python-minimal. (I never went for python2.7 under lucid.)

The LTS upgrade sequence from lucid to precise needs more work.

Can you help with this problem?

Provide an answer of your own, or ask Andrew Squibb for more information if necessary.

To post a message you must log in.