Enable executing linux binaries on FAT32/NTFS portable media

Asked by Nekomaster on 2012-08-13

This problem has been driving me away from Ubuntu since executing files on portable media was disabled.

Could someone please help me with running linux binaries on FAT32/NTFS portable media, as nothing I've tried to get linux binaries to run has worked aside from the painful task of manually mounting devices in FSTAB (which is a bad idea for removable media since they won't work after they've been remove and plugged back in)

I need to be able to run linux applications on portable media like flash drives because I move between my desktop and netbook frequently, and I occasionally migrate to other computers around me.

I hope something can be done about this, I really want to get away from Windows and back to Linux

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
Nekomaster
Solved:
2012-08-14
Last query:
2012-08-14
Last reply:
2012-08-13

You need to mount the whole partition executable, NTFS and FAT cannot hold Linux ACLs.

If you are wanting to run the Windows apps from your Windows partition using Wine in a dual boot situation, it won't work.

Nekomaster (nekomaster-max) said : #2

I've tried mounting my flash drives, that doesnt end well when you remove and reinsert the drive (Ubuntu won't remount it when its been mounted in FSTAB)

If you manually mount it with the option:

exec

It will make ALL files executable. You can now run the app.

Nekomaster (nekomaster-max) said : #4

I've tried mounting it like that before, but like I said, if I mount it in FSTAB it wont remount properly and give me an error.

I don't know how you mount things through terminal. Is there perhaps a script that I can use to mount portable media with the exec command?

Did you add the exec option on the line in fstab?

Nekomaster (nekomaster-max) said : #6

I believe I did when I tried mounting in FSTAB. either that or I tried its equivalent (I think -rwx or something). My problem is though that FSTAB mounting prevents remounting properly

Can you give the output of:

sudo fdisk -l; echo; lsb_release -a; echo; cat /etc/fstab

Thanks

Nekomaster (nekomaster-max) said : #8

Ok sorry for taking up your time, I found a solution to my problems. I created a rule in udev to mount devices with the ntfs-3g driver instead of the old ntfs driver and allowing me to execute files normally. Now I can use Xubuntu 12.04 without problems ;)

As long as you get the gold it's fine :D

Don't worry. Glad you were also looking for your own solution while asking, most people just let the forums do all the work.