Problem mounting iPod Touch in Ubuntu 10.04

Asked by riccardo on 2012-08-07

Hi, I use a macbook pro 3.1 with Ubuntu 10.04 as single
boot; I have also added the ppa:pmcenery/ppa to have the last updated library to use ipod and co., and upgraded the whole system.

I have some trouble trying to mount my iPod Touch because Nautilus does
not auto-mount it. I tried to manually mount it using ifuse:

r@mbp:~$ sudo mkdir /media/ipod
r@mbp:~$ sudo ifuse /media/ipod/

When I tried to open the ipod icon on the desktop I have: Access was
denied!

So, to browse the ipod I have to use:

r@mbp:~$ gksudo nautilus

Doing this I can not oped ipod in rhythmbox. I also tried to change the
permission of the mounting point:

r@mbp:~$ sudo chmod 777 /media/ipod

but nothing changes. I also tried to use ifuse without sudo but I have
this error:

r@mbp:~$ ifuse /media/ipod
GNUTLS ERROR: A TLS packet with unexpected length was received.

Do you have any further suggestion??

Best
Riccardo

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
riccardo
Solved:
2012-08-08
Last query:
2012-08-08
Last reply:
2012-08-07

Have you tried a Precise liveCD? The newer OS and kernel may help

riccardo (ricca) said : #2

I haven't tried the Precise liveCD because, for working reasons, I need to use Lucid.

riccardo (ricca) said : #3

I found the solution:

If you receive this error message when trying to mount with Ifuse

GNUTLS ERROR: A TLS packet with unexpected length was received

You need to pair the phone with your pc to do this enter this command

idevicepair unpair

Your Iphone or other Idevice will automatically try to re-pair you can then unplug it and plug it back in and it should mount correctly.

The whole post is here:
http://askubuntu.com/questions/27141/nothing-happens-when-i-connect-my-iphone-3g-to-my-laptop

Best