Mount file system

Asked by arnupharb on 2012-07-30

after i format HDD to ext4 file system i cant put any file to my HDD
but in NTF i can do it

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Last query:
2012-08-06
Last reply:
2012-08-06

Did you chown the mount point to your user?

arnupharb (arnupharb-master) said : #2

it already mount every partition
what is root?

Sam_ (and-sam) said : #3

.... and did you make yourself the owner of the filesystem, usually there is a question on fs dialog window.

If you recursively chown the mount point to your user, it will have full access. The Ext4 will hold correct file permissions.

Root is the highest account in Linux, Unix and BSD

arnupharb (arnupharb-master) said : #5

plese tell me how to do it

Sam_ (and-sam) said : #6

If you're able to use 'sudo' then you can get temporarily advanced permissions in order to do administrative tasks.

The mountpoint can be an UUID or just a title like plumtree, usually it's /media/<my_partition>.

The option would be:
sudo chown -R user:group /path/of/mountpoint

## Usually user and group are the username.

Basically a mountpoint can be any place you want.
e.g.
/mnt/data
/data
/media/data
/home/user/data

Please note references.
https://help.ubuntu.com/community/Mount
https://help.ubuntu.com/community/Fstab
https://help.ubuntu.com/community/MoveMountpointHowto

arnupharb (arnupharb-master) said : #7

it too technic i dont understand

Sam_ (and-sam) said : #8

Please open a terminal: ctrl+alt+t
Enter each line one by one and press [Enter]-key:
id
sudo fdisk -l
sudo blkid
mount
ls -al /media

Please post all output here. Thanks.

arnupharb (arnupharb-master) said : #9

maszter@maszter-System-Product-Name:~$ id
uid=1000(maszter) gid=1000(maszter) groups=1000(maszter),4(adm),20(dialout),24(cdrom),46(plugdev),116(lpadmin),118(admin),124(sambashare)
maszter@maszter-System-Product-Name:~$ sudo fdisk -l
[sudo] password for maszter:

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000bb95b

   Device Boot Start End Blocks Id System
/dev/sda1 * 2048 122097663 61047808 83 Linux
/dev/sda2 122099710 488396799 183148545 5 Extended
/dev/sda5 122099712 244195327 61047808 83 Linux
/dev/sda6 244197376 366292991 61047808 83 Linux
/dev/sda7 366295040 488396799 61050880 83 Linux
maszter@maszter-System-Product-Name:~$ sudo blkid
/dev/sda1: UUID="7d47b567-791c-4f6a-86de-ef75eb0b4b46" TYPE="ext4"
/dev/sda5: UUID="d2477715-f9d7-406b-8a14-bb63d4d74e9c" TYPE="ext4"
/dev/sda6: UUID="b88a3a69-ad59-4a6f-85f7-b25305ca54c0" TYPE="ext4"
/dev/sda7: UUID="d4c35819-7bc2-4b04-bc4b-5e423dc89988" TYPE="ext4"
maszter@maszter-System-Product-Name:~$ mount
/dev/sda1 on / type ext4 (rw,errors=remount-ro,commit=0)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/maszter/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=maszter)
/dev/sr1 on /media/Bluebirds type iso9660 (ro,nosuid,nodev,uid=1000,gid=1000,iocharset=utf8,mode=0400,dmode=0500,uhelper=udisks)
maszter@maszter-System-Product-Name:~$ ls -al /media
total 14
drwxr-xr-x 4 root root 4096 2012-07-31 06:38 .
drwxr-xr-x 25 root root 4096 2012-07-28 00:36 ..
dr-x------ 1 maszter maszter 2048 2009-04-29 16:02 Bluebirds
lrwxrwxrwx 1 root root 7 2012-07-26 17:09 floppy -> floppy0
drwxr-xr-x 2 root root 4096 2012-07-26 17:09 floppy0
maszter@maszter-System-Product-Name:~$

Sam_ (and-sam) said : #10

Thank you. Please tell which partition you'd like to access.

In the meantime I'll take this one as example.
/dev/sda5: UUID="d2477715-f9d7-406b-8a14-bb63d4d74e9c" TYPE="ext4"

First create a mountpoint.
Create an entry in fstab if you want the partition be mounted on system start.
Change the owner recursive.

## Example for /sda5. (Please replace 'blueberry' as you wish and without quotes)

sudo mkdir /media/blueberry

sudo cp /etc/fstab /etc/fstab-orig

gksudo gedit /etc/fstab

## This is an example entry.

# /dev/sda5
UUID=d2477715-f9d7-406b-8a14-bb63d4d74e9c /media/blueberry ext4 defaults 0 2

When finished save the file and refresh to introduce new mountpoints:
sudo mount -a

sudo chown -R maszter:maszter /media/<blueberry>

Open Nautilus (file manager), go to /media/<blueberry> and test if user maszter has access.

arnupharb (arnupharb-master) said : #11

how to enable super user option

arnupharb (arnupharb-master) said : #12

Apogize but could you tell me easier way to do it please

Sam_ (and-sam) said : #13

> how to enable super user option

Try *sudo* (without stars).

Which partition you'd like to access to put files on it?

arnupharb (arnupharb-master) said : #14

all partitions

Seems you are only unable to access sda6 and sda7

is that correct?

arnupharb (arnupharb-master) said : #16

yes

Then run:

sudo mkdir /media/sda6
sudo mkdir /media/sda7
sudo mount /dev/sda6 /media/sda6 -o rw,user
sudo mount /dev/sda7 /media/sda7 -o rw,user

You should now be able to access the data from the /media folder

HTH

Can you help with this problem?

Provide an answer of your own, or ask arnupharb for more information if necessary.

To post a message you must log in.