Changing Permissions for Drobo mounted volumes

Asked by Steven Scott on 2012-05-29

I have my Drobo S connected and working fine when I boot Ubuntu 12.04 LTS (desktop). However, the file permissions are set for my user only, with no access for the group or everyone. I want to change the permissions, but the chmod 777 does not work. I do not have the drives listed in the fstab as they simply load when they are conneccted. USB or FireWire will load the drivers.

I am trying to scan media with Plex Media Server, and I have added the plex user to my group with gpasswd, but can not change the permissions for the group to see the drive.

There is currently not an entry in fstab for the Drobo drives. Any help would be appreciated.

/dev/sdc1 on /media/Drobo type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
/dev/sdb1 on /media/Drobo-Movies type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
/dev/sdd1 on /media/Drobo-TV type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)

ls -l /media
drwx------ 1 me me 28672 May 3 07:43 Drobo
drwx------ 1 me me 8192 May 26 16:48 Drobo-Movies
drwx------ 1 me me 8192 May 27 12:21 Drobo-TV

Question information

English Edit question
Ubuntu util-linux Edit question
No assignee Edit question
Last query:
Last reply:

You don't need 777 and it's massively unsecure.

If you add add a line to /etc/fstab using the UUID of the partition, you can set the access you prefer.

Wyatt Smith (wyatt-smith) said : #2

As far as permissions go, it is somewhat dependent on the filesystem you are using. For example, ntfs and fat filesytems do not contain *nix type permissions. For these filesystems, the permissions are set at the time they are mounted.

To set the permissions at the time of mounting you will need to make edits to /etc/fstab file. You can set owner with UID and group with GID mount options. Please review community document regarding /etc/fstab. Pay attention to the examples they provide.

Can you help with this problem?

Provide an answer of your own, or ask Steven Scott for more information if necessary.

To post a message you must log in.