You are not privileged to mount the volume... for removable flash drive

Asked by Victor on 2007-12-12

"You are not privileged to mount the volume" that's what I get when flash is attached.

Mount from command line works
sudo mount -o uid=1000,utf8 /dev/sdg1 /media/fl
but it's rather inconvenient

How does automount works and what should be done to get it back?

Ubuntu: Hardy dev branch

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
Olivier
Solved:
2007-12-12
Last query:
2007-12-12
Last reply:
2007-12-12
Best Olivier (olivier-lacroix) said : #1

Hi, there are currently automounting bugs in hardy. If you search for it in the bug section in launchpad, you will find several entries.

You may try to use the "pmount" command as a workaround.

pmount /dev/sdX

will mount /dev/sdX for you with the right rights

Victor (vmato) said : #2

Thanks Olivier, that solved my question.

graingert (tagrain) said : #3

You need to remove the card's data in /etc/fstab

You can use Partition Editor (GParted) then choose your flash drive then you can check /dev/sdxxx with right click and select check

cleopete (david-thepaperhouse) said : #5

Thanks graingert, that's the only thing that worked for me. Over the last few releases I've just come to understand, I will lose my thumb drives in Ubuntu...sooner or later. This is the first time I haven't had to reinstall, yet. Thank you so much!

Graeme Harrison (prof-post) said : #6

Yes, this whole issue of mounts and having to manually force mounts is a very sorry state of affairs. It is one of the major pitfalls an average user might come across, and for all of us doing a lot of promo to get Ubuntu used as a basis for major educational roll-outs, it is the type of frustrating irritation that ought just go away. Wireless is the other major one.. but that is to do with IP of others, so harder. But I'd suggest the best thing is:
1. FIX THE BUG; and
2. If when attempting to mount a volume there is a problem, esp NTFS or FAT32 volumes, do the FORCED MOUNT... and if puritans raise any objection, give the user a menu selection choice to A. Force a load, or B. Deal with it themselves, and after timeout of 10secs, THEN force the load if no user response objecting. The reason is that there may not be a user at the keyboard.
Too much of Linux assumes EXT3 vols, yet for dual-boot, one needs to have NTFS vols, and Ubuntu gets it about 96% correct when dealing with NTFS volumes, so let's just fix the last 4%.
Graeme Harrison (prof at-symbol post.harvard.edu)

george (george-chiper) said : #7

Ubuntu is getting annoying for me. It's fun in the beginning to play a little bit with the command line, and you copy paste some commands and tings work. But this error
 Cannot mount volume. You are not privileged to mount the volume 'BRAIN'. where brain is my usb stick.
I have no mood and no time now to try all kinds of abracadabra formulas. Ubuntu is promising a smooth user experience. I had this problem in December it was damn annoying now I have it again. Whre is the long promised smooth experience. It's like 2 years of blobbing around and now if I would have the hardware configuration I would even go to vista. In the and is working with ubuntu you have no warranty look with a simple error it's 2 mounths since i discovered it. I don;t want anymore magic command lines. I just want it to work. What is the update manager for. And mostly where is my f... memory stick when I need it.

puddonhead (puddonhead) said : #8

I had the same issue. This is what worked for me in Jaunty:
1. Comment out the "problem entries" from /etc/fstab by placing a hash (#) before them... e.g. if you were having problems mounting /dev/hdb1 - comment out the entry for /dev/hdb1 from fstab. Repeat for all mount volumes which were giving you trouble.
2. Reboot.
3. Manually mount by clicking Places -> "Volume Label".
4. Manually mounting a volume will create a file /media/.hal-mtab .. This file will have all the information required for mounting - but in a slightly different format than /etc/fstab. e.g. if .hal-mtab has and entry "/dev/sda2 1000 0 ntfs-3g nosuid,nodev,uhelper=hal,locale=en_US.UTF-8,exec /media/Win_XP", then the /etc/fstab entry needs to be "/dev/sda2 /media/Win_XP ntfs-3g nosuid,nodev,uhelper=hal,locale=en_US.UTF-8,exec 1000 0"
5. Do the appropriate rearrangements and create new entries in /etc/fstab. Please be careful to ONLY rearrange fields from .hal-mtab to the appropriate fstab format... DO NOT change any entries from this file.
6. Reboot.
7. Voila - all your volumes should be auto-mounted now.

Suddenly got the message after years of normal use.Pmount didn't work. Re-boot had no effect. Tried the flash drive (fat32) in winxp & it works as normal. Retried in Hardy and it's back to normal there as well, so error seems to stem from the drive & not fstab. Probably caused by pulling drive without unmounting when in Hardy. If you are dual booting its so easy it's worth trying.