I cannot access my second hard drive

Asked by Mary Matthews on 2012-05-14

A couple of weeks ago I upgraded to 12.04 and used this second hard drive without any problems. Then in the last 3 days when i try to access it I get this message:
Error mounting: mount: wrong fs type, bad option, bad superblock on /dev/sdb,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail or so
The drive contains documents, pictures etc and is really my backup system.
It is displayed in my home folder.
Your help would be appreciated
Mary

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
Mary Matthews
Solved:
2012-05-15
Last query:
2012-05-15
Last reply:
2012-05-15
Wyatt Smith (wyatt-smith) said : #1

To get a better picture of whats going on, we will need some more information. For starters please tell the output of the following commands in terminal.

sudo fdisk -lu ; sudo blkid ; cat /etc/fstab ; id

Barry Drake (b-drake) said : #2

You could also run the Disk Utility and carry out the SMART tests on that drive.

Mary Matthews (m-f-matthews) said : #3

mary@mary-GA-MA770-UD3:~$ sudo fdisk -lu
[sudo] password for mary:

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000f2018

   Device Boot Start End Blocks Id System
/dev/sda1 * 2048 1949333503 974665728 83 Linux
/dev/sda2 1949335550 1953523711 2094081 5 Extended
/dev/sda5 1949335552 1953523711 2094080 82 Linux swap / Solaris

Disk /dev/sdb: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders, total 156301488 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Disk /dev/sdb doesn't contain a valid partition table
mary@mary-GA-MA770-UD3:~$ sudo blkid
/dev/sda1: UUID="0b09d25e-4310-4390-9e7b-cae2e85e5594" TYPE="ext4"
/dev/sda5: UUID="b4bbc0ff-f8ca-4bbd-bc3d-a5f95f5e607d" TYPE="swap"
/dev/sdb: UUID="5cf8d9d6-fad2-4d28-af94-cf04a1886b41" SEC_TYPE="ext2" TYPE="ext3"
mary@mary-GA-MA770-UD3:~$ cat/etc/fstab
bash: cat/etc/fstab: No such file or directory
mary@mary-GA-MA770-UD3:~$ id
uid=1000(mary) gid=1000(mary) groups=1000(mary),4(adm),20(dialout),24(cdrom),46(plugdev),116(lpadmin),118(admin),124(sambashare)
mary@mary-GA-MA770-UD3:~$

Barry Drake (b-drake) said : #4

Disk /dev/sdb doesn't contain a valid partition table means that the disk has been trashed somehow. I dn't know of any way to get the data back, nor can I suggest how this could have happened unless there is a hardware fault on the drive. Sorry. This problem does not have anything to do with your upgrade.

Try:

sudo mkdir /media/fix
sudo mount -o sb=8193 /dev/sdb1 /media/fix

Sounds like you haven't been unmounting the partition properly when you finish with the device and just rip out the device without telling the OS first.

Wyatt Smith (wyatt-smith) said : #6

Hopefully you will be able to mount the drive with Andrews suggestion of using the backup superblock.

Other things to consider...

Check the SMART status of the drive to finding out if it is failing. If the disk if failing then obviously you should consider replacing it. Smartmontools is a a command line utility that can check the SMART status.
http://blog.shadypixel.com/monitoring-hard-drive-health-on-linux-with-smartmontools/

If there is critical data on it there are some linux tools such as testdisk which can help recover lost partitions, but this should only be used by experience users. It this disk does not contain any critical data and is still is good working condition, you may consider repartition and format it.

Mary Matthews (m-f-matthews) said : #7

Thank you all for your advice. I tried the disk utility and did the self test, which it failed. various problems were mentioned including old age. It is 6 or 7 years old and was originally an external hard drive which I added as an extra internal hard drive when I built this computer a year ago. The data on it wasn't vital so I have formatted and can now mount it. It is still failing the self test. (I do hate it when machines get the better of me!!)
Thank you, Mary

Mary Matthews (m-f-matthews) said : #8

Problem solved

Barry Drake (b-drake) said : #9

The general advice is that when sector relocations start to occur, you know the drive is in danger of sudden death, so don't ues it for anything important. I have one with 94 relocated sectors, and it easily passes the SMART test, but I never put anything important on it.