Cannot move file to trash, do you want to delete immediately?

Asked by SACHIN on 2012-05-09

I am using UBUNTU 12.04 with window 7 on dual boot. When I delete any file from NTFS partition. I get the message "Cannot move file to trash, do you want to delete immediately?". What could be the reason and what is the solution?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
Wyatt Smith
Solved:
2012-05-10
Last query:
2012-05-10
Last reply:
2012-05-09
Best Wyatt Smith (wyatt-smith) said : #1

Check that you have ownership and permission of the trash folder in the root directory of the ntfs partition. The trash folder is a hidden folder that starts with a . and ends with the user id. This allows a separate trash for each user that uses the system.

A typical trash folder would be
.Trash-1000

If for some reason you do not have ownership or write permission, files will be deleted immediately rather than being moved there. To fix this you will need to take ownership and enable write permission.

Daniel Cheung (daniel-2345) said : #2

This happen to me also. I research a lot on web because it was fine before also. I did a lot of thing and they did not work. And suddenlt, one day it worked again. I realize that Trash is mounted so I don't clean all the things in Trash in my computer

SACHIN (sacme) said : #3

Thanks Wyatt Smith, that solved my question.