chmod not changing

Asked by Stephen Toney on 2007-12-04

Hi everyone!

Using gutsy, I logon as root, go to a specific directory and enter

chmod -R -v a=rwx *.*

and the verbose mode says it is changing permissions for each file to 0777 (rwxrwxrwx).
However, the permissions are not actually changed. Using ls -l shows them the same as before.

The drive is FAT32 shared with Windows.

I realize I might be making a syntax error, but why would it tell me it was changing permissions?

Many thanks in advance for any suggestions.

Stephen

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
neHru
Solved:
2007-12-04
Last query:
2007-12-04
Last reply:
2007-12-04
neHru (leon-omfg) said : #1

Euhm, fat32 doesnt understand file permissions in POSIX style, like the chmod you want to do, so it wont make any difference.

Best neHru (leon-omfg) said : #2

Btw, if you do want to write to the fat32 drive, try mounting it using the following from the fstab, or putting the below in a mount command, if you know how...

/<device> /<mountpoint> vfat iocharset=utf8,umask=000 0 0

This will make all the files root:root with rwxrwxrwx.

Stephen Toney (toney) said : #3

Thanks! I knew that the permissions didn't have any effect in Windows, but I thought they could still be set for Linux use on a FAT32 drive. I'll use the fstab setting instead.

But why would chmod tell me it was changing the permissions if it can't? Seems like a flaw, since it leads to confusion such as mine.

Many thanks.
Stephen