Ghost drive in Devices.

Asked by steve taylor on 2012-01-28

I have two drives /dev/sda1 40GB and /dev/sdb1 80GB, swap, extended.

/dev/sda1 was/is 'C' drive where Grub is sitting, the rest of the drive is empty though xp was there and is ntfs.

It's set to mount at boot and does just fine.
I have files I want to store in there sometime.

fstab entry is:
UUID=4E6009E96009D91B /media/New_Volume ntfs-3g users,user,owner 0 0

But in Home folder, Devices list I have:

New Volume with mount point /media/New_Volume 'mounted'
Floppy Drive
New_Volume with mount point New_Volume

The thing is, that last entry does not exist or more likely is a duplicate but I can't find a reference anywhere.
fstab, mtab, Gparted,Boot Repair, disc utility etc

If I try to mount it I am told that it's already mounted by another device, which may well be true.
So I guess there are some cross wires somewhere.

Can anyone suggest where else I might look for this 'double entry' so I can # it from registering?

OS Ubuntu Unity all up to date

All Red Faced :)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
Doug McMahon
Solved:
2012-01-30
Last query:
2012-01-30
Last reply:
2012-01-29

i don't suggest you mount anything to /meda itself but use a subdirectory instead. ubuntu automounts things to subfolders in /media so you giving it junky ntfs to work with may cause issues.

steve taylor (stevemail) said : #2

Thanks actionparsnip,

Hmm, this could be one of those leave well alone things as I can see other routes leading towards re-formatting to Fat and re-installing Grub or some such. I was rather hoping just edit out a reference.

Though it does make me wonder what would happen if I cut out the fstab entry:
UUID=4E6009E96009D91B /media/New_Volume ntfs-3g users,user,owner 0 0

Would the second reference remain..........somewhere?

Hmm, again.

steve taylor (stevemail) said : #3

Ideas?

You will need to run:

sudo mkdir /media/New_Volume

To make the folder to mount to.

steve taylor (stevemail) said : #5

Dear actionparsnip,

my hands have gone all sweaty.
My Boot is over there, not sure if I am going to compromise something on start up.

sequence:

delete fstab entry.
sudo mkdir /media/New_Volume
Re-Mount drive

back where I started?
My brain hurts

BIOS reads 'C' for Grub, Grub loads /dev/sdb1 'OS ubuntu', fstab loads 'C' ( /dev/sda1 )mounted at /media/New_Volume
Possibly, is it, maybe mounted at start up anyway?

I am sure you got better things to worry about.

Many thanks actionparsnip

Best Doug McMahon (mc3man) said : #6

You guys may want to take a look at this bug, a bit old but similar concerning automounting ntfs volumes thru fstab.
comment 7 shows preferred way to do in fstab
https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/442130

Myself would Not use an fstab entry Nor Create a mountpoint. When wanting to access the drive would just click on it in nautilus & let it get mounted to /media/volume_label

steve taylor (stevemail) said : #7

Got that Doug McMahon,

Impressive memory. I think I understand the gist of the fixy and will give it a go.

Also noted: Myself would Not use an fstab entry Nor Create a mountpoint. When wanting to access the drive would just click on it in nautilus & let it get mounted to /media/volume_label.

Many thanks :)

steve taylor (stevemail) said : #8

Ok so that did it!

fstab edited

from: UUID=4E6009E96009D91B /media/New_Volume ntfs-3g users,user,owner 0 0
    To: /dev/disk/by-uuid/4E6009E96009D91B /media/New_Volume ntfs-3g rw,auto,users,user 0 0

Now I only have the one entry in Devices menu which comes up as New Volume with mount point media/New_Volume.
Tweaked permissions a bit but it all seems to work fine, nothing is complaining.

Can't say I understand why fstab and mtab have this problem or if the issue will return with the next build
so I'll keep this fixy on file.

Many thanks and chocolates all round.

I'll mark it as solved

steve taylor (stevemail) said : #9

Thanks Doug McMahon, that solved my question.