NTFS Auto Mount Ubuntu 11.10 Oneiric Ocelot

Asked by James Thorrold on 2011-10-20

Hi!

I have just recently upgraded to 11.10 from 11.04 (clean install of 11.10). On 11.04 I modified the fstab file to auto mount my NTFS partitions on boot - this worked fine, no problems at all.

However, now I have upgraded, the exact same fstab file no longer works. The partitions are mounted but I do not have permission to access them (root can however). Also, they are mounted read-only - despite the 'rw' option in the fstab file.

Below is my fstab file:

# /etc/fstab: static file system information.
#
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
UUID=a5c847be-9f0c-43ea-aea4-f2b2e9b36e30 / ext4 errors=remount-ro 0 1
UUID=fc68cb06-10f4-4cc0-ba11-611feff12444 none swap sw 0 0

# NTFS partitions
UUID=B260CF0260CECC73 /media/WinXP auto auto,user,exec,rw,sync 0 0
UUID=72A4F9B2A4F978C5 /media/Win7 auto auto,user,exec,rw,sync 0 0
UUID=01CA2350BEDD2400 /media/LocalDisk auto auto,user,exec,rw,sync 0 0

I haven't changed this file since my upgrade, so am unsure why they aren't accessible from my user account.
The following command: sudo mount -a gives me 3 warnings, one for each partition:

mount: warning: /media/WinXP seems to be mounted read-only.
mount: warning: /media/Win7 seems to be mounted read-only.
mount: warning: /media/LocalDisk seems to be mounted read-only.

I have tried remounting etc, but still get the same results. I've tried everything I could find, has there been any change since 11.04?

thanks,

James

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
Chris
Solved:
2011-10-21
Last query:
2011-10-21
Last reply:
2011-10-21
Chris (fabricator4) said : #1

Try:

UUID=B260CF0260CECC73 /media/WinXP ntfs defaults, locale-en_US.utf8 0 0

Chris

James Thorrold (jthorrold) said : #2

Thanks for the quick reply Chris.

Unfortunately, I get the following error with yours:

mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail or so

I tried changing 'ntfs' back to default for the fs type but still get the same error. I ran the command: dmesg | tail and got this output:

[ 7436.247793] NTFS volume version 3.1.
[11432.405002] NTFS-fs error (device sdb1): parse_options(): Unrecognized mount option locale-en_us.utf8.

it doesn't seem to like the locale option.

I'm not sure what else I can try - any other suggestions would be great

Best Chris (fabricator4) said : #3

OK, I got it from the Ubuntu help files:

https://help.ubuntu.com/community/AutomaticallyMountPartitions

It must be outdated. Just try:

UUID=B260CF0260CECC73 /media/WinXP ntfs-3g defaults, 0 0

Chris

James Thorrold (jthorrold) said : #4

thanks again Chris but I get the error:

mount: unknown filesystem type 'ntfs-3g'

If I replace 'ntfs-3g' with 'auto' it mounts the partition, but again - only read-only.

James Thorrold (jthorrold) said : #5

Thanks Chris, that solved my question.

James Thorrold (jthorrold) said : #6

It's ok, your last solution did work Chris. I didn't have the NTFS driver for fuse installed (ntfs-3g). Installed it from Software Centre and it now works fine.

Thanks again!

Chris (fabricator4) said : #7

You might want to report that as a bug against the updater. ntfs-3g is installed by default on a clean install of 11.10, and it should still be present after an update as well. Glad you got it working.

Chris

Furyk Karede (bgfuryk) said : #8

Chris,
ditto for me, same issue, same solution, Thank you

ntfs-3g was NOT installed on a clean Ubuntu 11.10 x64 installation. (I've had a lot of issues with 11.10, but so far on this clean install everything is working fine except my second monitor. considering when I was using both monitors after the first reboot I could not even log back into ubuntu without using recovery mode, I'm happy with only 1...)

interesting issue though, I have a bind mount so that both myself and a standard user account have "the same" Music folder; however they get an error that they don't have permission to access the folder. The user ID is not a member of the group that the drive was mounted with (gid), but the bind mount sets the gid to the user's group (1001). I'll probably just change the original gid to something else and make us both members so I don't have to change the gid on the bind... current I have other things mounting with the gid on the initial mount I don't want the other user to have access to. no big deal...

Chris (fabricator4) said : #9

finndo:

My clean install of 11.10 does have ntfs-3g install, but I have absolutely NO ntfs partitions :-))
It is however the 32bit desktop release.

You might want to start another thread with your dual monitor problem. Xorg should be able to handle two monitors. Xorg.conf which is supposed to be deprecated is still vital to sorting out monitor and resolutions problems. If they ever got rid of it completely I'd have to stop using my KVM switch, as it's the only way I can control monitors and resolutions. Usually the problem is that the second monitor is on a second card which is not being initialised for some reason

Chris

Chris (fabricator4) said : #10
Nilufer (nilufernilar-gmail) said : #12

Thanks Chris.
I usually do not upgrade between major ubuntu versions. Instead I reinstall and mounts my home partition to /home.
Reason is, I have encountered some problems in the past through upgrades. I don't remember the issues but my instinct says not to upgrade :).

In my fresh install of 11.10, the auto mount worked fine and its read-write. I was able to do all without any problem.
Since two days I'm having the same problem as James. Same scenario and same messages. The only change I did as to my memory was installing KDE Partition Manager with a plugin for NTFS support. I did through Ubuntu Software Center.

As you said I modified /etc/fstab and changed the ntfs to ntfs-3g. Then installed the package ntfs-3g. It started to work.
I'm not sure whether default installation had ntfs-3g. If not, there should have been another way Ubuntu using by default in the fresh installation for rw ntfs partitions.
Also I'm not sure whether KDEPM had to do anything with it.