Partitions are not listing

Asked by Iqbal

My home folder (the encrypted home folder) is /dev/sda7. I was trying to mount this partition. This (/home) folder was encrypted during installation of ubuntu 11.04 by checking a box. I got Input/Output error. I could not mount this partition. I have 4 partitions as follows

In addition to above four partitions (500 GB HDD), there are three NTFS partitions also. Windows vista is installed on /dev/sda1.

When I used fdisk -l command it does not list any of the partitons. Earlier, fdisk -l used to list all partitions. I used GParted, it also did not show any partition.

I tried to copy /dev/sda7 to backup the image using dd command (dd if=/dev/sda7 /mnt/backup_sda7), it showed zero bytes copied. I was trying to save this file on external hard drive,mounted on /mnt.

I tried to run fsck -f /dev/sda7, it did not run. It was saying that there is some problem with super-block. I tried to restore super-block by using e2fsck -b block-number /dev/sda7 - no success. I got the error "Could this be a zero length partition.".

During all the above processes, i was getting the error "a disk is having health problems."

How to list (see) all the partitions?
How to rectify disk errors?

Question information

English Edit question
Ubuntu util-linux Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
delance (olivier-delance) said :

"a disk is having health problems." probably means hard drive has hardware problem and could die soon. You should make a whole copy of disk on another healthy one and work from it.

Revision history for this message
Iqbal (naqvi-iqbal2001) said :

My /home folder is encrypted in ubuntu 11.04. I can not mount it. It gives input/output error. Sometimes it gives super-block read error. I tired to restore super-block using e2fsck -b block-number /dev/sda7, but it does not succeed.

I booted from live cd and mounted /home partition and issued command ecryptfs-recover-passphrase
it gave the following output:
Select cipher:
 1) aes: blocksize = 16; min keysize = 16; max keysize = 32 (not loaded)
 2) blowfish: blocksize = 16; min keysize = 16; max keysize = 56 (not loaded)
 3) des3_ede: blocksize = 8; min keysize = 24; max keysize = 24 (not loaded)
 4) cast6: blocksize = 16; min keysize = 16; max keysize = 32 (not loaded)
 5) cast5: blocksize = 8; min keysize = 5; max keysize = 16 (not loaded)
Selection [aes]: Error attempting to evaluate mount options: [-5] Input/output error
Check your system logs for details on why this happened.
Try updating your ecryptfs-utils package, and/or
submit a bug report on

What does it mean? How to move ahead from this point?

Revision history for this message
delance (olivier-delance) said :

Sorry, I don't know how to manage encrypted partition.
Could you boot on Ubuntu media, choose "Try" and then System->Administration->Disk Utilities and have a look at SMART diagnostics.

Revision history for this message
Launchpad Janitor (janitor) said :

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Revision history for this message
Iqbal (naqvi-iqbal2001) said :

When I boot from LiveCD (Natty) and run fdisk, it lists all partitions. If I run fsck and then run fdisk- then no pasrtition is listed untill I reboot.

Revision history for this message
delance (olivier-delance) said :

It's not a normal behavior:
  fdisk read partition table
  fsck works inside a partition and should not modify partition table
Your question is old, and will catch eyes of nobody.
You should open a new question or try another forum like or

Could you confirm that:
  1-you open a live session
  2-you open a terminal
  3-fdisk return partition table
  4-in same terminal, you run fsck
  5-in same terminal, fdisk fails now to read partition table
If you can reproduce it, raise a bug against util-linux

Can you help with this problem?

Provide an answer of your own, or ask Iqbal for more information if necessary.

To post a message you must log in.