No detecta el pendrive en Ubuntu 10.10

Asked by Rafael Casar on 2011-02-20

Tengo Ubuntu 10.10 instalado en un portátil Medion Micromaxx MIM2080 con 4 puertos USB. Cuando enchufo un pendrive, no me lo reconoce en ninguno de los puertos. La luz del pendrive se enciende momentáneamente, y se apaga definitivamente.

Question information

Language:
Spanish Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
Rafael Casar
Solved:
2011-02-26
Last query:
2011-02-26
Last reply:
2011-02-25
delance (olivier-delance) said : #1

After having plugged USB stick and waiting 10s, could you run command "lsusb" to see if pendrive is seen on USB bus.

The first times I run command "lsusb", I don't see the pendrive. Only when I run this command several times, the pendrive starts lighting and then it is seen on USB bus. The problem is that if I don't execute the command "lsusb", my pendrive never starts.

delance (olivier-delance) said : #3

"lsusb" is not supposed to enumerate actively USB bus, but only to report what devices where detected. So I presume that the PC was slow to detect and identify your USB key. Could you provide USB key identifier (like 9999:9999) as it's a very gook key word to search in Google.
After could you run command:
    ls -l /media
to see if device is mounted. Sometimes device is mounted, but GUI doesn't display it.

No, the USB key is not recognized. As you can see, this is the output to the command "cat /etc/fstab" with the USB key plugged. It doesn't appear the /dev/sdb partition.

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
/dev/sda1 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=fc6b7575-4afb-4776-a9b2-6de4212dfde8 none swap sw 0 0

Could someone help me with this problem?

delance (olivier-delance) said : #6

Could you try:
   - to plug another USB device on this PC
   - to plug this USB key on another PC
If you have problem only with this USB key on this PC, the only solution I see is to raise a bug.

I have tried with more USB devices and always the same problem. However, when I run the command "lsusb" two o three times with the device plugged, it is recognized and works fine. So I consider this question solved. Thank you very much.