10.04 can't boot unattended if non-critical disks aren't working

Asked by Steve Newcomb on 2010-09-14

A new feature of 10.04 desktop is that the boot process stops (goes interactive) if a disk mentioned in /etc/fstab isn't available. This is a bad thing for me. USB disks fail. USB disks are used for backups, and must be NOT be mounted in /media, which is what happens when I don't list them in /etc/fstab. I'm often out of town, and yet I need access to my computer even after a long power failure forces it to stop and reboot. Alas, if one of my non-critical disks is in trouble or has been disconnected, the machine won't boot. Instead it stops to ask someone (who isn't there) whether to ignore the fact that a disk isn't available. So I have 2 questions:

(1) How does one get the boot process to continue on when non-critical disks listed in /etc/fstab aren't working right, have been unplugged, etc. This wasn't a problem until 10.04, as far as I know. It's a real problem for me.

(2) How does one prevent disks that are connected to the machine at boot time from being mounted in /media?

I could, of course, write an elaborate script and call it in /etc/rc.local. It would be a horrible solution, though. It would have to wait around and see what gets mounted in /media and unmount it, and then mount it in the right place. Surely there's a more rational way to do this!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu util-linux Edit question
Assignee:
No assignee Edit question
Solved by:
Philip Muškovac
Solved:
2010-09-14
Last query:
2010-09-14
Last reply:
2010-09-14

Have you tried the noauto option? I think thats what you need.

Steve Newcomb (srn-coolheads) said : #2

Thanks actionparsnip for this idea. Actually, no, it doesn't solve my problem. I *do* want the disks to be automounted at boot if they can be mounted. I just don't want unattended booting to fail because they can't be automounted.

Steve Newcomb (srn-coolheads) said : #4

Thanks Philip Muškovac, that solved my question.

Steve Newcomb (srn-coolheads) said : #5

The problem was solved by invoking the nobootwait mount option in the relevant filesystem listings in fstab. Easy, and just exactly the kind of fix I was looking for.