AMD64 Karmic won't auto mount floppy media

Asked by Poppa Smurf

Hi everyone, I'm new to this so bear with me. A friend & I have similar builds, both now running AMD64 Ubuntu V9.10 & both are not reading our floppies. ie we have floppy icons under "Places" which if we click on, with floppy in drive, the FDD LED comes on for short time, then goes off, they appear to try a read but nothing else happens.
 If I go to "Places", "Computer", right click "Floppy Drive", click "Mount", LED lights briefly, Error Message Window comes up "Unable To Mount Location - No Media In The Drive", but there is!
 Both of our FDDs & floppies work fine with BIOS & DOS environments & removable USB flash drives auto mount in Karmic with no problems.
 I have read all I can find in the answers & tried most all suggestions but I still can't access a floppy using Nautilus as User.
 I can Mount a floppy disk through Root Terminal using "Mount /media/floppy0" & access its' contents using Nautilus as Root & then Unmount the floppy but I greatly dislike this messy & dangerous solution.
 I know FDDs are going to be obsolete eventually but at present some of us still have things we want to do using floppies.
Can anyone throw some new light on this issue?
Thanks, Poppa Smurf.

Question information

English Edit question
Ubuntu util-linux Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

gksudo gedit /etc/modules

add the word:


to the bottom and press enter on the end. This will make the system load the floppy module at boot.

Can you give the output of:

gedit /etc/fstab


Revision history for this message
Poppa Smurf (adc-multiline) said :

Thanks for your help. I have done the fstab & modules, here's what they are at present.

# /etc/fstab: static file system information.
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / was on /dev/sda1 during installation
UUID=1dc4d0f7-c486-4887-a904-5478842672a7 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=ec0dc19d-d32e-4a0a-8385-d05dfc5cf584 none swap sw 0 0
/dev/scd1 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

# /etc/modules: kernel modules to load at boot time.
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.


It appears that the FDD is mounted ok, otherwise they'd not be an icon but the issue is reading & mounting the media in the FDD - it that right?

Revision history for this message
Sam_ (and-sam) said :
Revision history for this message
Poppa Smurf (adc-multiline) said :

 I'm not sure of the protocol with following up questions & bugs but I've been reading through the links that Sam posted & if I read correct, bug #441835 is dealing with this issue.
 My mate & I are going to live with this problem & stick with 9.10, its' been a great evolution. Fortunately, I have kept an old PC with W2K (cringe) for emergency situations, so I can handle most of our needs like dealing with BIOS upgrade files & get them onto a floppy. Our BIOS flash tool doesn't see USB drives but is happy with a good old floppies.
I will keeping watching developments & trust someone will come up with a proper solution in future updates for Karmic.
Thanks again fellas.

Revision history for this message
John (iseasygoing) said :

Read the 442835 on the FLOPPY issues with 9.10 I think the developers just flat out left FLOPPY out of 9.10 They must have had small notebooks in mind as there is no provision for internal Floppy in the 9.10 O.S. Can't fix it if it don't exist! In time CD will have problems in 9.10
For what its worth FLOPPY works fine in 8.04 LTS and 9.04 I think they might be making the same mistake with 10.04, hope not. Desktops and Laptops still use FLOPPY and CD. While we use 64 bit machines we suspect this problem exits in 32 bit versions as well.

Revision history for this message
Poppa Smurf (adc-multiline) said :

Thanks to another contributor, I have successfully mounted internal floppies using the following command in a terminal screen & files drag & drop ok with nautilus.

devkit-disks --mount /dev/fd0

Again, I assume the solution will be incorporated in a proper update when the development teams have time. I greatly appreciate the work everyone does for OS.

Revision history for this message
Lee Kirk (lrkaccounting) said :

I can see this is a little old but I am having the same problem with 10.04. Everything looks like my floppy should work. When I try to mount it I can hear a click in the drive but when I try to open it I get a message of "Unable to Mount Location - no media in the drive". I can boot from a floppy and XP can use the floppy but I cant get Linux to read it. I have searched and done all of the suggestions I can find but most of them are older and not specific to 10.04. Does Ubuntu simply not work with floppy drives anymore? Are there any other current distributions that will work with my floppy?

Any help would be appreciated. Especially from anyone who is actually using a floppy right now. I somehow think that what used to work in the past is no longer working now.


Revision history for this message
Barry John (cambray-court) said :

I have exactly the same problem as Lee Kirk i.e. Unable to mount Floppy with same message so this is not an isolated problem. It is very frustrating as I was getting on well with Ubuntu 10.40.

Revision history for this message
Poppa Smurf (adc-multiline) said :

As an update to my original post, both my friend & I have progressed on to version 10.04 & we still have the same problem with our internal floppies. I have tried regressing to previous version of udisk module, as suggested, & at first I thought the problem was solved, but no. Although the floppy mounts & I can view contents now, formatting, copying & writing start but go nowhere no matter how long I wait.
I sure hope this issue does get a professional solution as it is a real downer on Ubuntu's reputation. The longer it is debated & carries over through the versions, the more cred goes back to "Windows". May the good fairy help us!

Revision history for this message
Algis (algispetr) said :

I was really amazed that paid Ubuntu/Linux programmers improve only things that work on their notebook computers, and do not care about tens of millions of computers that are in third-world countries and still rely on floppies and on much older computers. Hundreds of comments, requests to restore floppy functionality - and still no care.

I spent two days until get floppy working. First day I managed to get read-only access, second day - to make them read-write. So my advice - if you have $100 buy Windows XP and forget this Linux crap. You live only once and lifecycle is too short to spend two days trying to write the file to the floppy. But if there is no money for MS, then I hope this helps.

I am ordinary user who just want to save file to the floppy, and have no any understanding what commands below do, yet the floppy started to work normally after these, collected piece by piece from various posts via Google.

1. Check if there is a line with one word in it:


in the text file /etc/modules.
Run from command prompt
sudo gedit /etc/modules

if there is no floppy line, type floppy on the new line at the end of the file, and press enter. Save the file and close the editor.

2. Check if there is the line
/dev/fd0 /media/floppy auto rw,user,noauto,exec,owner 0 0
in the file /etc/fstab
run from command prompt
sudo gedit /etc/fstab

if instead of /media/floppy there is another directory it is OK, just check if you have that directory. If not, enter the command
sudo mkdir /media/floppy

2. Reload older version of driver that has unfixed bug in newer version so floppy does not work, and disable updates of that driver.
Download 1.0.1-1build1 from here:
Select the 1.0.1-1build1 and download your processor version; example
for 32bit:


Open a terminal to the directory where you downloaded the file (or save it in the home directory, on my Ubuntu this is the default directory for terminal prompt):

$ sudo dpkg -i udisks_1.0.1-1build1_i386.deb

"You'll then need to pin the package in Synaptic and apt-get". Do the following commands:
$ sudo -s
[your password]
# echo udisks hold | dpkg --set-selections
# exit
$ sudo apt-get update && sudo apt-get upgrade

Now reboot.

After this, I was able to access floppies normally. There is still hope this will be fixed in new Ubuntu so that millions of floppy users will not be frustrated. Not everyone is on engineering level to perform these changes...

Revision history for this message
Lee Kirk (lrkaccounting) said :

Does anybody know if 10.10 can read the floppy drive without going through all the terminal activity described above. I am very much aware that the floppy is very old technology and this will almost certainly be the last system that I have with a floppy. I would like to get it to work so I can finally go through my old disks.


1 - Does 10.10 solve the problem so that the floppy drive can be used without all the command line activity?

2 - Is there any current distribution that does still support the floppy drive?

I know its an old topic but this is kind of my last ditch effort here to see if there are any ideas.

Thanks for any help.

Revision history for this message
Algis (algispetr) said :

The answer is NO. 10.10 cannot read the floppies out of the box. No attention in this release to those who cannot buy new computers, do not have skills, and still use floppies to save their files. I.e., 50% of African computers.

Do the instructions above - and floppy works. Or, buy support services for Linux, so they will do that for you...

Lets hope that floppy will be fixed in 11.04.

Revision history for this message
actionparsnip (andrew-woodhead666) said :

Dude you can get a FREE dropbox account and get 200Mb (or 175 floppies) worth of storage, is this a better alternative.....?

Revision history for this message
janusz (sunmake) said :

You are GREAT for me.I've stuck with thit problem for week!
Also BIG SHAME for Ubuntu developers, Especially,that 10.04 is LTS vesion.
PS: in 11.04 problem is not fix yet.

Revision history for this message
Poppa Smurf (adc-multiline) said :

Does anyone know if udisks 2.0 fixes this issue with 10.04?
If it does, how do I upgrade udisks 1.0 to 2.0?

Revision history for this message
actionparsnip (andrew-woodhead666) said :

If you can find a PPA, worth a try

Can you help with this problem?

Provide an answer of your own, or ask Poppa Smurf for more information if necessary.

To post a message you must log in.