when trying to install updates

Asked by FajardXorg

I got this message when i tried to install the secury updates and othes.
E: Could not get lock /var/cache/apt/archives/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the download directory

Is it possible to fix it.
thanks in advance

Question information

English Edit question
Ubuntu usplash Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Best Elfy (elfy) said :

Usually mean you have 2 of add/remove, synaptic, update manager (updating) or apt ot aptitude in a terminal at the same time - you can only be doing 1 at a time.

Revision history for this message
Collin Stocks (collinstocks) said :

forestpixie is correct. Sometimes, though, the processes don't shut down when you want them to, so look in the gnome-system-monitor (as root -- that is, "sudo gnome-system-monitor") and kill anything named synaptic or apt-get or aptitude. Alternatively, you can do "sudo killall synaptic", "sudo killall apt-get", and "sudo killall aptitude"

Revision history for this message
FajardXorg (rehevoli) said :

Thanks forestpixie, that solved my question.