Force VERBOSE without removing quiet?

Asked by Kamilion on 2008-04-25

A recent change in 0.5.13 shows a new VERBOSE mode.
Removing "quiet" from the kernel command line in hardy triggers VERBOSE mode.
How do I trigger VERBOSE mode without removing "quiet" from the kernel command line?
Can it be added in usplash.conf to force VERBOSE on forevermore?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu usplash Edit question
Assignee:
No assignee Edit question
Solved by:
Kamilion
Solved:
2008-04-26
Last query:
2008-04-26
Last reply:
2008-04-25
Bhavani Shankar (bhavi) said : #1

hello

I think there is a way..

you may be able to get what you want by changing the GRUB boot options from "quiet splash" to "noquiet".

Refer

man usplash

Or

man usplash_write

for more info..

Regards

Bhavani Shankar.

Kamilion (kamilion) said : #2

I was more asking if there was a way to enable VERBOSE mode without touching menu.lst at all...

When I remove quiet or add noquiet, I get a long ~25 second scroll of x64 kernel boot messages before uspash even initiates.
I'd much prefer to keep the kernel shut up and still keep usplash's VERBOSE mode enabled.

Is there a way to configure this from usplash.conf?
Or am I better off if I add -v to the usplash start in the initrd?
Or alternatively, should I run usplash_write VERBOSE true somewhere in the initrd?
How would I go about doing so in Ubuntu Hardy, and where would I do this?

Kamilion (kamilion) said : #3

Okay, I've solved this for myself.

Edit /usr/share/initramfs-tools/scripts/init-top/usplash

Original:

for x in $(cat /proc/cmdline); do
 case $x in
 splash*)
  SPLASH=true
  ;;
 quiet*)
  VERBOSE=false
  ;;
 esac
done

New:

for x in $(cat /proc/cmdline); do
 case $x in
 quiet*)
  VERBOSE=false
  ;;
 splashverbose*)
  SPLASH=true
  VERBOSE=true
  ;;
 splash*)
  SPLASH=true
  ;;
 esac
done

Then run "sudo update-initramfs -u"

and change your kernel command line from "quiet splash" to "quiet splashverbose"

Good luck to anyone else!