my Huawei usb modem don't work on on ubuntu 15.10

Asked by Battant on 2016-04-16

Hello,

Since several days, (probably since usb-modswitsh-data package was update to 20150627-1) version, on my ubuntu 15.10 64 bit, my usb modem Bus 001 Device 005: ID 12d1:14fe Huawei Technologies Co., Ltd. Modem (Mass Storage Mode) don't work..

Could you help me please to fix this issues ?

Best regards

Battant

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu usb-modeswitch Edit question
Assignee:
No assignee Edit question
Last query:
2016-04-25
Last reply:
2016-04-25

Have you tried upgrading to Xenial? Xenial is LTS and supported til April 2021. Wily is not LTS and will soon not be supported.

Battant (mparchet) said : #2

Hello,

The ubuntu 15.10 to Xenial seems not yot available.

1. How could I upgrade my ubunut version ?

2. Could you help me to fixe my issue

Best regrds

Battant

If you want to upgrade to Xenial (as it is prerelease) you can run:

sudo do-release-upgrade -d

If you run:

sudo /etc/udev/rules.d/70-huawei_e352.rules

Add the below text:

ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="14fe", RUN+="/usr/sbin/usb_modeswitch -v 12d1 -p 14fe -M '55534243123456780000000000000011062000000100000000000000000000'"
ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="14fe", RUN+="/bin/bash -c 'modprobe option && echo 12d1 1506 > /sys/bus/usb-serial/drivers/option1/new_id'"

Save the new file, close gedit and reload the rules:

udevadm control --reload-rules

Source:
http://bytefish.de/blog/huawei_e352s5/

Battant (mparchet) said : #5

Hello,

When I have upgrade the usb-modswith data package from 20151101-1 version to 20161112-1 version, my usb modem don't work the new driver version semms don't work with my modem

Note : when I update my sytem. which sudeo.apt-get update && sudo apt-get upgrade commande, the usb-modswitch is not upgrade

The following packages have been kept back:
  usb-modeswitch-data

my /etc/udev/rules.d/70-huawei_e352.rules file

ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="14fe", RUN+="/usr/sbin/usb_modeswitch -v 12d1 -p 14fe -M '55534243123456780000000000000011062000000100000000000000000000'"
ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="14fe", RUN+="/bin/bash -c 'modprobe option && echo 12d1 1506 > /sys/bus/usb-serial/drivers/option1/new_id'"

the lsusb output command

Bus 003 Device 010: ID 12d1:14fe Huawei Technologies Co., Ltd. Modem (Mass Storage Mode)

Could you help me please ?

Best regards

Battant

Battant (mparchet) said : #6

My configuration

ubuntu 16.04 LTS 64 bit

Battant

Battant (mparchet) said : #7

Hello,

When I try to install my modom drivers, I get this message :

sudo apt-get install usb-modeswitch
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 usb-modeswitch : Depends: usb-modeswitch-data (>= 20140529) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

sudo apt-get install usb-modeswitch-data
Reading package lists... Done
Building dependency tree
Reading state information... Done
usb-modeswitch-data is already the newest version (20160112-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Could you help me please

Thanks for your support

Best regards

Battant

Battant (mparchet) said : #8

Hello,

I have install successfully the usb-modeswitch-data package 20161112-1 but not usb-modeswitch

Here is my terminal output

 sudo apt-get install usb-modeswitch
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 usb-modeswitch : Depends: usb-modeswitch-data (>= 20140529) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Note : my usb modom don't work

Could you help me please ?

Best regards

Battant

Battant (mparchet) said : #9

My configuration :

uname -a
Linux mparchet-W240EU-W250EUQ-W270EUQ 4.4.0-18-generic #34-Ubuntu SMP Wed Apr 6 14:01:02 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04 LTS
Release: 16.04
Codename: xenial

Manfred Hampl (m-hampl) said : #10

What is the output of

apt-cache policy usb-modeswitch usb-modeswitch-data

Maybe the same cause as for another question that you have (I assume repository server missing updates).

Battant (mparchet) said : #11

Hello,

Here is my terminal output :

apt-cache policy usb-modeswitch usb-modeswitch-data
usb-modeswitch:
  Installed: (none)
  Candidate: 2.2.5+repack0-1ubuntu1
  Version table:
     2.2.5+repack0-1ubuntu1 500
        500 http://archive.ubuntu.csg.uzh.ch/ubuntu xenial/main amd64 Packages
        100 /var/lib/dpkg/status
usb-modeswitch-data:
  Installed: 20160112-1
  Candidate: 20160112-1
  Version table:
 *** 20160112-1 500
        500 http://archive.ubuntu.csg.uzh.ch/ubuntu xenial-proposed/main amd64 Packages
        500 http://archive.ubuntu.csg.uzh.ch/ubuntu xenial-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     20151101-1 500
        500 http://archive.ubuntu.csg.uzh.ch/ubuntu xenial/main amd64 Packages
        500 http://archive.ubuntu.csg.uzh.ch/ubuntu xenial/main i386 Packages

If you see this line

        500 http://archive.ubuntu.csg.uzh.ch/ubuntu xenial/main i386 Packages

Why a package was compile on 32 bit mod ?

Is it the problem cause ?

If yes how could I get this package in 64 bit ?

Thanks for your support

Best regards

Battant

Manfred Hampl (m-hampl) said : #12

What do you get for

sudo apt-get install usb-modeswitch

or - if that fails

sudo apt-get install usb-modeswitch usb-modeswitch-data

Remark:
Are you aware that the packages in the "-propsed" repository buckets are still in testing phase, and that there is a higher probability for errors with them?
You should enable the -proposed repositories only if you are able to cope with problems yourself.
This problem with usb-modeswitch(-data) probably is related to packages in the -proposed area.

Battant (mparchet) said : #13

Hello,

I have reinstall a frech ubuntu 16.04 LTS with my packages. The usbmodswitchda-data version work is 20151101-1 but the 2016 version don't work

Could you fix the bug in the usbmodswitsh data 2016 version ?

Thanks for your support

Best regards

Battant

Manfred Hampl (m-hampl) said : #14

I do not see a 2016* version of usb-modeswitch-data in the official repositories (it is there just for the future release), see https://launchpad.net/ubuntu/+source/usb-modeswitch-data

Why do you think that you have to install a version that is not designed for your release?

Battant (mparchet) said : #15

Hello,

I fond this package on the pre-release section

See below :

The Yakkety Yak (pre-release freeze)
Usb Modeswitch Data trunk series
20151101-1 release (main) 2016-04-22
20160112-1 proposed (main) 2016-04-22

My usb modem don't work yet with this version :

20160112-1 proposed (main) 2016-04-22

It is an information for the developer

Best regards

Battant

Manfred Hampl (m-hampl) said : #16

If you are fiddling around with packages from the development version (and Yakkety Yak is the Ubuntu release to be published in half a year's time) and get problems, then you are wrong in the question/answer section of Launchpad. We do our best to provide support for users of the packages provided by current Ubuntu releases.

If you want to help with development, you have to use the bug area, because that is where the developers work.

Can you help with this problem?

Provide an answer of your own, or ask Battant for more information if necessary.

To post a message you must log in.