ZTE MF821 4G usb broadband modem

Asked by Ray mccarthy on 2012-09-08

No onnection to Telstra network

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu usb-modeswitch Edit question
Assignee:
No assignee Edit question
Last query:
2012-09-09
Last reply:
2012-10-20
Thomas Krüger (thkrueger) said : #1

Please connect your stick freshly, open the Terminal and paste the folkowing line into it:

lsb_release -a; nmcli con; nmcli dev; lsusb; apt-cache show usb-modeswitch; dmesg | tail -n 20

Now press enter and post the output here! Thanks!

also:

uname -a; dmesg | grep -i modem

Thanks

Ray mccarthy (fitzpapi) said : #3

On 09/09/12 01:11, Thomas Krüger wrote:
> lsb_release -a; nmcli con; nmcli dev; lsusb; apt-cache show usb-
> modeswitch; dmesg | tail -n 20
ray@ray-Satellite-A200:~$ lsb_release -a; nmcli con; nmcli dev; lsusb;
apt-cache show usb-
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
NAME UUID TYPE TIMESTAMP-REAL
Telstra Telstra (Next G) 1 ea696f18-0a96-45c8-918e-1a2b2e5647fe
gsm Wed 22 Aug 2012 23:48:15 WST
FitzroyValleyMen 135fa2ea-a6a6-4b61-936c-40426f975059
802-11-wireless Sun 09 Sep 2012 09:51:13 WST
BigPond6A9A4E 0cdad8c3-c6ce-45db-a7b8-c360724c9481
802-11-wireless never
Wired connection 1 a388b776-935d-4d3f-96c7-4b3b5b54ae6e
802-3-ethernet Sun 09 Sep 2012 05:57:35 WST
mcsdl 1695e1aa-5444-4d85-968c-e3dd0ceff164
802-11-wireless Sat 23 Jun 2012 17:46:16 WST
DEVICE TYPE STATE
wlan0 802-11-wireless connected
eth0 802-3-ethernet unavailable
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 04f2:b008 Chicony Electronics Co., Ltd USB 2.0 Camera
Bus 004 Device 002: ID 0483:2016 SGS Thomson Microelectronics
Fingerprint Reader
Bus 006 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 003 Device 002: ID 0930:0508 Toshiba Corp. Integrated Bluetooth HCI
Bus 002 Device 004: ID 19d2:0257 ZTE WCDMA Technologies MSM
N: Unable to locate package usb-
E: No package found
ray@ray-Satellite-A200:~$ modeswitch; dmesg | tail -n 20
modeswitch: command not found
[ 7350.888063] wlan0: no IPv6 routers present
[ 9096.164101] usb 2-1: new high-speed USB device number 3 using ehci_hcd
[ 9096.432370] Initializing USB Mass Storage driver...
[ 9096.432582] scsi5 : usb-storage 2-1:1.0
[ 9096.432697] usbcore: registered new interface driver usb-storage
[ 9096.432699] USB Mass Storage support registered.
[ 9096.688154] usbcore: registered new interface driver uas
[ 9097.433729] scsi 5:0:0:0: CD-ROM L_T_E USB SCSI
CD-ROM USB PQ: 0 ANSI: 0
[ 9097.434460] scsi 5:0:0:1: Direct-Access ZTE MMC Storage
2.31 PQ: 0 ANSI: 0
[ 9097.438476] sr1: scsi-1 drive
[ 9097.438778] sr 5:0:0:0: Attached scsi CD-ROM sr1
[ 9097.443041] sr 5:0:0:0: Attached scsi generic sg2 type 5
[ 9097.443467] sd 5:0:0:1: Attached scsi generic sg3 type 0
[ 9097.446191] sd 5:0:0:1: [sdb] Attached SCSI removable disk
[ 9100.412585] usb 2-1: USB disconnect, device number 3
[ 9104.584110] usb 2-1: new high-speed USB device number 4 using ehci_hcd
[ 9104.723143] scsi6 : usb-storage 2-1:1.4
[ 9105.721729] scsi 6:0:0:0: Direct-Access ZTE MMC Storage
2.31 PQ: 0 ANSI: 0
[ 9105.723420] sd 6:0:0:0: Attached scsi generic sg2 type 0
[ 9105.727631] sd 6:0:0:0: [sdb] Attached SCSI removable disk
ray@ray-Satellite-A200:~$ C

Thomas Krüger (thkrueger) said : #4

It looks like you have a modem that is not supported by usb-modeswitch yet and shares an ID with the ZTE 820. :-/
But I found a tutorial that explains who to set it up. It requires that you know how to created and edit files with root rights and how to use the Terminal. If you need assistance just ask!

http://www.eigenmagic.com/2012/03/14/how-to-get-telstra-4g-mobile-broadband-working-with-linux/

Just change:
TRS{idVendor}=="19d2", ATTRS{idProduct}=="0166",

To:
TRS{idVendor}=="0257", ATTRS{idProduct}=="0166",

As those are the IDs from the lsusb output...

Marius B. Kotsbak (mariusko) said : #7

Is this still not working out of the box in Ubuntu 12.10?

Ray mccarthy (fitzpapi) said : #8

No luck but have just found a small script "sakis3g" which works.

Can you help with this problem?

Provide an answer of your own, or ask Ray mccarthy for more information if necessary.

To post a message you must log in.