usb-creator-gtk exits suddenly after copying files

Asked by Chris Wong on 2011-10-16

I'm using 64-bit Ubuntu 11.10 and trying to install the 32-bit version on my flash drive.

It copies the all the files on to the flash drive successfully, but does not install the boot loader or create the persistence file -- it just disappears. This is what it displayed on the console:

(usb-creator-gtk:16128): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.IW9L3V': No such file or directory

(usb-creator-gtk:16128): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory

I've tried it with and without the persistence file, erasing the drive each time, but to no avail.

According to Disk Utility, my flash drive has one "W95 FAT32 (LBA) (0x0c)" 4.0 GB bootable partition at /dev/sdb1.

 Any help would be welcome.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu usb-creator Edit question
Assignee:
No assignee Edit question
Solved by:
Chris Wong
Solved:
2011-11-02
Last query:
2011-11-02
Last reply:
2011-11-01
delance (olivier-delance) said : #1

The two warning messages are meaningless.
Can you see files in the USB key ?

Chris Wong (chrisyco) said : #2

> The two warning messages are meaningless.

I thought they were, but I attached them just in case.

> Can you see files in the USB key ?

Yes I can. After the USB creator disappears, if I reopen the USB drive, all the files it copied are there. However, both my laptop and my desktop refuse to boot from it.

delance (olivier-delance) said : #3

Do you still have an issue ?
Could you check if partition is bootable ?

Chris Wong (chrisyco) said : #4

I tried it again today, and it suddenly started working! No idea how...

Out of curiosity, what does the USB creator do if the bootable flag is not enabled? It should at least enable it automatically, not stop suddenly right after copying all the files.

Thank you for your help!