ureadahead removed from ubuntu 20.04, booting now is much slower!!

Asked by cptX on 2021-01-06

Recently I have upgraded from ubuntu 18.04 to ubuntu 20.04. I'm using spinning Hard disks, and I noticed significantly longer boot times. I researched further and realized that ureadahead is not available and installed anymore.
In ubuntu 18.04 I made experiments with and without ureadahead and had 20secs difference!!! (1min 17s boot time with ureadahead and 1min 37s without). Ureadahead was installed by default and gave a great advantage to the system!

I would like to experiment with ureadahead in Ubuntu 20.04 too, but the package is not available! Why is ureadahead removed from Ubuntu 20.04? Now booting is significantly slower! I would like this package to be available for all of us who still are using spinning disks and need it! I consider the decision for removing this package wrong and not based on real measurements and tests! I understand that there have been some issues with it (eg. log files etc) but this is not a reason to cut off completely such an important package!! I want to pursuade the corresponding team to reconsider this decision and to run more thorough tests. On my laptops I really notice significant differences in boot times!

Is it possible to compile it myself? Can you guide me where to find the source code and how to do it? Also, I think this requires a patch in the kernel. Do I need to do this too or does all the kernels support it already?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu ureadahead Edit question
Assignee:
No assignee Edit question
Last query:
2021-01-06
Last reply:
2021-01-07
cptX (myrbourfake) said : #2

This is no duplicate because the other post was closed as it was referring to linux mint. You can delete the other post completely as it didn't provide any use... This refers to Ubuntu.
The issue is very important and if you close it again will have no chance of getting solved.

I just managed to install the ureadahead_0.100.0-21_amd64.deb in ubuntu 20.04 in my second laptop. I again verfied significant difference in the boot time and I insist this package should be included in ubuntu 20.04 repositories!!!!!!!!!!!

Specifically with ureadahead I got 10seconds less booting time than without it (spinning disks of course). So I really don't understand the decision to remove it. I really doubt the people that took that decision that ran real life tests and did measurements on spinning disks.

Please if you are not willing to escallate this here just tell me where should I describe the problem in order to have a change to solve it. Just don't close it without providing a solution. Thanks in advance!

Daniel Letzeisen (dtl131) said : #3

"Please if you are not willing to escalate this here just tell me where should I describe the problem in order to have a change to solve it."

This is a site for users helping users. There is no "escalating" and we do not decide what packages are in Ubuntu. You've already responded to the relevant bug report where Canonical devs made the decision to remove ureadahead. That is your best chance to get further explanation and reverse the decision if appropriate. You're "barking up the wrong tree" here.

Manfred Hampl (m-hampl) said : #4

If you already have install the ureadahead version 0.100.0-21 in ubuntu 20.04, what else do you need?

By the way, there are some PPAs, see https://launchpad.net/ubuntu/+ppas?name_filter=ureadahead
Some of them do offer a version for Ubuntu focal.

cptX (myrbourfake) said : #5

I managed to install ureadahead just today. So I don't need instructions for compiling it at the moment although it would be good to find the source code and the methodology to compile it for future versions (as the existing .deb packages at some point will be too old...).
Most important for me now would to be to pursuade the people that took that decision to reconsider.

Daniel Letzeisen (dtl131) said : #6

ureadahead was an Ubuntu/Canonical project, so:
https://git.launchpad.net/ubuntu/+source/ureadahead

cptX (myrbourfake) said : #7

Thanks Daniel!

Daniel Letzeisen (dtl131) said : #8

Please mark the question "solved".

cptX (myrbourfake) said : #9

Daniel, one last question: you sent me the link with the source code. Where can I find the corresponding group to discuss the subject with the maintainers of ureadahead?

Daniel Letzeisen (dtl131) said : #10

AFAICT, the main dev of ureadahead is not active in Ubuntu anymore. ureadahead has not seen updates in 3 years.
The bug report is probably your best bet. Or maybe try: https://lists.ubuntu.com/mailman/listinfo/Ubuntu-devel-discuss

Can you help with this problem?

Provide an answer of your own, or ask cptX for more information if necessary.

To post a message you must log in.