Dos/Windows end of line in upstart logs

Asked by Bernd on 2014-01-04

Why does the all upstart logfiles have a dos/windows end of line eg \r\n (^M) and not the normal unix end of line

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu upstart Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2014-01-04
Last query:
2014-01-04
Last reply:
2014-01-04

What is the output of:

lsb_release -a; uname -a

Thanks

Bernd (midox) said : #2

##BOX-1
lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.3 LTS
Release: 12.04
Codename: precise

uname -a
Linux pc-1 3.2.0-58-generic #88-Ubuntu SMP Tue Dec 3 17:40:43 UTC 2013 i686 i686 i386 GNU/Linux

init --version
init (upstart 1.5)
Copyright (C) 2012 Scott James Remnant, Canonical Ltd
#####
####BOX2
lsb_release -a
No LSB modules are available.
Distributor ID: elementary OS
Description: elementary OS Luna
Release: 0.2
Codename: luna

uname -a
Linux midox-CQ60-Notebook-PC 3.12.6-031206-generic #201312201218 SMP Fri Dec 20 17:20:06 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

init --version
init (upstart 1.5)
Copyright (C) 2012 Scott James Remnant, Canonical Ltd.
####

Both boxes have the same Dos/Windows line endings in the upstart logfiles

I suggest you report a bug

michael (yellupcm-gmail) said : #4
Bernd (midox) said : #5

@michael
i use Ubuntu on a few boxes with exactly the same problem
so i think this is related to Upstart and not directly to elementary Os (eOs is only on one machine installed here)

i could open a bug too at https://bugs.launchpad.net/upstart (wich may result in a duplicate here)
as : "Ubuntu also tracks bugs for packages derived from this project"

so as suggested i opened a bug on this (here) and mark this question as solved

Bernd (midox) said : #6

Thanks actionparsnip, that solved my question.