How do I troubleshoot update-motd? it's not generating /etc/motd or /var/lib/motd

Asked by Eric Olsen

I was playing with update-motd, I created a couple files: 09-title and 10-server-info

09-title was simply an ascii of my server's name, and 10-server-info was a script to display a parsed-output of df and uptime.

Everything was working great, until I renamed 10-server-info to 60-server-info so it would display after 50-landscape-sysinfo. Once I did this, and ran sudo update-motd, my 10-server-info showed up both before landscape-sysinfo AND after. If I modified 60-server-info the changes would reflect in the text after landscape-sysinfo, but the old 10-server-info was still showing up in /etc/motd even though it didn't exist.

I've since removed both 09-title and 60-server-info from /etc/update-motd.d/ as well as emptying out /etc/motd, but that seems to have made it worse, as now the motd isn't being populated at all.

I haven't been able to find any way to get a verbose output of what's happening when update-motd executes to see if one of the scripts is failing, or some error is occuring, nor have I found any mention of logs anywhere. Is there any way for me to discover why motd isn't being populated (and why it was getting extra text from a no-longer-existant file)?


Question information

English Edit question
Ubuntu update-motd Edit question
No assignee Edit question
Solved by:
A. Denton
Last query:
Last reply:
Revision history for this message
Eric Olsen (falconv) said :

I forgot to mention:
I've ran dpkg-reconfigure update-motd as well as apt-get purge update-motd then apt-get install update-motd and this still occurs.

Revision history for this message
Best A. Denton (aquina) said :

This is probably a bug so I recommend you to file a bug report *and* link it with this question (please do not forget to do that).

Revision history for this message
Eric Olsen (falconv) said :

Thanks Aquina, that solved my question.