Update manager update problem WARNING: The following packages cannot be authenticated!

Asked by kumar on 2009-11-03

Today 03-11-2009 My update manager was listing recommended updates including update-manager. But when I click install updates, its saying those updates were not authenticated. I don't want do unauthenticated upgrade to my update-manager. Could you help me to solve this problem?
Output of sudo apt-get upgrade

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
  libpoppler-glib4 libpoppler5 libpython2.6 poppler-utils python2.6
  python2.6-minimal update-manager update-manager-core
8 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 6,606kB of archives.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]? Y
WARNING: The following packages cannot be authenticated!
  libpython2.6 python2.6 python2.6-minimal update-manager update-manager-core
Install these packages without verification [y/N]? N
E: Some packages could not be authenticated

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu update-manager Edit question
Assignee:
No assignee Edit question
Solved by:
Cristi Nistor
Solved:
2009-11-03
Last query:
2009-11-03
Last reply:
2009-11-03
Best Cristi Nistor (cristi-nistor) said : #1

Try first the sudo apt-get update command to update the source list.

Cristi Nistor (cristi-nistor) said : #2

And update the ftp server key with sudo apt-key update command.

kumar (kumar-physics) said : #3

Thanks Cristi Nistor, that solved my question.

kumar (kumar-physics) said : #4

I usually do first sudo apt-get update and then upgrade, but It didn't work first time. But I tried now it worked.. Thanks a lot.

olie (wa4css) said : #5

I was in Firefox and clicked on the adobe flash update. The update did not
happen and I cannot clear this update from the package manager.

kovax (kovax3) said : #6

kovax suggests this article as an answer to your question:
After this operation, 139kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  linux-libc-dev libc6-dev libstdc++6-4.2-dev g++-4.2 gcc-4.2 cpp-4.2 libgomp1
  gcc-4.2-base libgcc1 libstdc++6 libc6 libpam-runtime libpam0g libpam-modules
  base-files bash dash dpkg gzip login mount perl-modules perl perl-base
  sysvutils lsb-base tzdata util-linux bsdutils apt passwd python2.5-minimal
  sysv-rc bzip2 libbz2-1.0 libgnutls13 libssl0.9.8 libsasl2-2 libsasl2-modules
  initscripts procps cpp libkrb53 libldap-2.4-2 libcurl3-gnutls
  apt-transport-https dpkg-dev fakeroot gcc g++
Authentication warning overridden.
FAQ #61: “Packages required to compile a C program in Ubuntu”.