Unable to start update process-Failed to run /usr...

Asked by Chuck

I am trying to update using the update manager and get this message. I have re-booted 3 times. Can you help me? Thank You.

Failed to run /usr/sbin/synaptic '--hide-main-window' '--non-interactive' '--parent-window-id' '106954788' '-o' 'Synaptic::closeZvt=true' '--progress-str' 'Please wait, this can take some time.' '--finish-str' 'Update is complete' '--set-selections-file' '/tmp/tmp1yU3cg' as user root.

The underlying authorization mechanism (sudo) does not allow you to run this program. Contact the system administrator.

Question information

English Edit question
Ubuntu update-manager Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Chuck (chux-industryinet) said :

I tried to open synaptic and cannot. I get the note below:

Failed to run /usr/sbin/synaptic as user root.

Revision history for this message
Chuck (chux-industryinet) said :

Next steps: Googled problem and tried this:
chuck@Ubuntu:~$ sudo visudo
[sudo] password for chuck:
chuck is not in the sudoers file. This incident will be reported.
Tried : sudo synaptic and get bash: SUDO: command not found.

I will now try to figure out how to boot in rescue mood and follow the steps from there.

Revision history for this message
Chuck (chux-industryinet) said :

I probably have compounded the problem as the visudo program was not correctly modified and now contains an error I doubt I can fix unless one of you want to drop by the house. I was trying to add chuck ALL+ALL...... and I messed up it seems. Unless you all have a simple solution. I will probably try to update to the new 9.1 even if I have to do a clean install.

I don't have a clue how the problem happened and I would be interested to some possible ways this problem happened so I may avoid it happening agan. Finally if ya have a way to undo the problem I've made on line 16 of visudo and how to get my user name authenticated I'd sure be willing to try and fix it.

I tried and failed to update to sys. 9.1 over the internet but my password doesn't verify because of the problem. I am downloading a 9.1 beta system disk+

Revision history for this message
zvacet (ivicakolic) said :

You don´t haver admin privileges to run updatews in synaptic.Do you have two accounts?If you do one doesn´t have admin privileges ( one you made after installation).If you have just one account and you still can run sudo the boot in recovery mode and type

adduser username admin

username= your username

sudo reboot

You should wait until someone try to help you and don´t touch sudoers file because without good instructions you can mess it up.But you already know that.

Revision history for this message
Chuck (chux-industryinet) said :

Zvacet, I followed your instructions and it worked (so far). I am now updating and checked that I could use synaptic. I sure got a rush--- thanks a ton. I was ready rebuild the entire hard drive but sure dreaded doing it.

 Question: (1) is my "sudoers" file still goofed up or (2) is it fixed or (3) does the updates fix it or (4) will my update to 9.10 fix it? If the answer is 2,3 or 4 I believe you have solved my problem. If the answer is (1), I don't have a clue how to fix it and would be super thankful for your help.

I tried to solve this problem myself using examples from others similar problems, but my lack of knowledge of the code sure does get in the way.

Thank you so much for your time and your help.

Revision history for this message
Best zvacet (ivicakolic) said :

If you can use sudo and get updates it look like it is fixed.

Revision history for this message
Chuck (chux-industryinet) said :

Thanks zvacet, that solved my question.