E: Unable to locate package php5.6 digitalocean

Asked by Rahul Yadav on 2020-06-18

Hello Friends,

I tried to install php5.6 on my ubuntu 14.04 server and i did following things :

sudo apt install software-properties-common
sudo add-apt-repository ppa:ondrej/php
sudo apt update

sudo apt install php5.6
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package php5.6
E: Couldn't find any package by regex 'php5.6'

Please let me know what we do for installing php5.6.

Thanks!!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu update-manager Edit question
Assignee:
No assignee Edit question
Last query:
2020-06-18
Last reply:
2020-06-18
Manfred Hampl (m-hampl) said : #1

Support for Ubuntu 14.04 has already ended (except for ESM - Extended Security Maintenance for selected server packages)., see https://wiki.ubuntu.com/Releases
I assume that this is the reason that O. Sury has removed the php5.6 package from his repository.

Do you get error messsages for the command
sudo apt update
confirming this?

Rahul Yadav (rahulluutaa) said : #2

Hello @Manfred ,

Previously i got this error with update command

Err http://ppa.launchpad.net trusty/main amd64 Packages
  403 Forbidden [IP: 91.189.95.83 80]
Err http://ppa.launchpad.net trusty/main i386 Packages
  403 Forbidden [IP: 91.189.95.83 80]
Ign http://ppa.launchpad.net trusty/main Translation-en_US
Ign http://ppa.launchpad.net trusty/main Translation-en
W: Failed to fetch http://ppa.launchpad.net/ondrej/mysql/ubuntu/dists/trusty/main/binary-amd64/Packages 403 Forbidden [IP: 91.189.95.83 80]

W: Failed to fetch
http://ppa.launchpad.net/ondrej/mysql/ubuntu/dists/trusty/main/binary-i386/Packages
403 Forbidden [IP: 91.189.95.83 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.

I fixed it using this:
sudo rm /etc/apt/sources.list.d/ondrej-mysql*

There are no packages for Trusty (Ubuntu 14.04) . It is end of life. What you are doing is like looking for updates for Windows XP

There are none. I suggest you either upgrade to Xenial (Ubuntu 16.04) which you can do in one jump OR run a final full update, Remove the server, spin up a Focal server (Ubuntu 20.04) then restore your user data / settings

Can you help with this problem?

Provide an answer of your own, or ask Rahul Yadav for more information if necessary.

To post a message you must log in.