update manager out of date repositories

Asked by Bob Harvey on 2009-04-14

Binary package hint: adept-updater

This installation has been automatically updated from 7.04 to 7.10 to 8.04 to 8.10 using the update manager from the system menu.

It all worked fine up until the end of January, but I have just come back from a trip and found that the update manager now reports errors with repositories that I would have expected to have long since been replaced by the process described above.

Where are the names stored?
Do I have to fix this by hand?
Are there any logs, config files you need to expand this report?
Is the system being correctly updated when I accept this error dialogue?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu update-manager Edit question
Assignee:
No assignee Edit question
Solved by:
Craig Huffstetler
Solved:
2011-11-11
Last query:
2011-11-11
Last reply:
2009-04-15

This question was originally filed as bug #361157.

Bob Harvey (bobharvey) said : #1
Michael Vogt (mvo) said : #2

Thanks for your bugreport.

The "feisty" version of ubuntu reached the end-of-life and that means it got pulled from the main mirrors.
Please remove this repository via the "software sources" tool (in System/Administration/Software Sources).

Craig Huffstetler (xq) said : #3

If you need help in doing what Michael Vogt describes, please let us know. Otherwise, we will assumed this is answered.

Bob Harvey (bobharvey) said : #4

Well, I'm away working at the moment. Might not be back for a month or so, I'll try it then.

But surely, when I updated these repositories should have been replaced by the new version as part of the update process?

Best Craig Huffstetler (xq) said : #5

They should have been. You can double check this by opening up the /etc/apt/sources.list

My worry is your third party repositories.

Open up a Terminal (Applications > Accessories > Terminal)

And type:

sudo gedit /etc/apt/sources.list

You will see a lot of lines that should look like this:

deb http://us.archive.ubuntu.com/ubuntu/ jaunty main universe restricted multiverse

NOTE the "jaunty"

If ANY line contains "intrepid" "hardy" or any previous release, this is your problem. It will need to be removed and replaced with jaunty.

Please also note some personal package archives, or third party suppliers, may have not updated their repositories to have jaunty in them yet. This may be a problem. After you have confirmed that your sources.list file is all "jaunty" then on the terminal run:

sudo apt-get clean
sudo apt-get update

And wait for those to finish.

Run update-manager again and see if you get the error message.

If there are lines at the end of your sources.list that you are unsure about -- these are probably the package archives I am referring to that are third party that update-manager would not have updated for jaunty. For now you may need to comment these out like this:

# This line is commented out
# deb http://this is commented out too

Sincerely,

Craig

Bob Harvey (bobharvey) said : #6

Oh look, this is back in my list.

The advice resolved the problem, back when it happened.

Bob Harvey (bobharvey) said : #7

Thanks Craig Huffstetler, that solved my question.