libxine1 error

Asked by Ziaa on 2009-02-08

Hi
    I m using gusty kubuntu 7.10 and I wnan to upgrade it by

  sudo apt-get upgrade

All of the process run well but at last at unpacking stage it gave an error.then i reboot my PC
and try to run

sudo apt-get update --fix-missing
it gave error in libxine1 the output of konsole is

[sudo] password for ziaa:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  amarok amarok-xine kaffeine libavcodec1d linux-headers-generic
  linux-image-generic linux-restricted-modules-generic ssl-cert
The following packages will be upgraded:
  libxine1
1 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.
Need to get 0B/2493kB of archives.
After unpacking 0B of additional disk space will be used.
Do you want to continue [Y/n]? Y
WARNING: The following packages cannot be authenticated!
  libxine1
Install these packages without verification [y/N]? y
(Reading database ... 93855 files and directories currently installed.)
Preparing to replace libxine1 1.1.7-1ubuntu1 (using .../libxine1_1.1.7-1ubuntu1.4_i386.deb) ...
Unpacking replacement libxine1 ...
dpkg-deb: subprocess paste killed by signal (Broken pipe)
dpkg: error processing /var/cache/apt/archives/libxine1_1.1.7-1ubuntu1.4_i386.deb (--unpack):
 corrupted filesystem tarfile - corrupted package archive
Errors were encountered while processing:
 /var/cache/apt/archives/libxine1_1.1.7-1ubuntu1.4_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
ziaa@Gikian:~

I wana to install it but it cannot proceed forward thnx.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu update-manager Edit question
Assignee:
No assignee Edit question
Solved by:
Rafik Ouerchefani
Solved:
2009-02-08
Last query:
2009-02-08
Last reply:
2009-02-08
Best Rafik Ouerchefani (rafik) said : #1

Hello,

Please delete the corrupted package archive before trying the process again.
$ sudo rm /var/cache/apt/archives/libxine1_1.1.7-1ubuntu1.4_i386.deb

The package will be downloaded again and the error should disappear.

- Rafik

Ziaa (ziaphx-2007) said : #2

Ok thanks alot.

I acted on ur advice and the package download in start up.

Regards

Ziaa

Ziaa (ziaphx-2007) said : #3

Thanks Rafik Ouerchefani, that solved my question.