Applications are "lost" after upgrade

Asked by bim on 2009-01-15

Upgraded from Hardy to Intrepid.
My new Applications menu did not pick up WINE nor VBOX.. The data is present in my /home partition.

How can I restore these items to the menu?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu update-manager Edit question
Assignee:
No assignee Edit question
Solved by:
bim
Solved:
2009-01-16
Last query:
2009-01-16
Last reply:
2009-01-15
Sebastian Geiger (lanoxx) said : #1

Go to System->Preference->Main Menu:

There look around for Wine to see if it has been recognized, maybe its just not activated. If its completely missing you might add it your self:

Make a new menu item and name it Wine there you have

"Browse C:\ Drive"
xdg-open .wine/dosdevices/c:
Browse your virtual C:\ drive

Configure Wine
winecfg
Change application-specific and general Wine options

Uninstall Wine Software
uninstaller
Uninstall Windows applications for Wine

Then add another Menu Subfolder named Programms in there you will have to add the programms that are installed by your self.

Also an option might be to just reinstall wine, run:
 sudo aptitude reinstall wine

Last but not least if you installed wine via the community repository form wineHQ here:
http://www.winehq.org/download/deb
then you will need to update you repository information as mentioned on the page. afterwards run an update.

Best Regards
Lanoxx

nhasian (nhasian) said : #2

hello bim,

do you have wine and virtualbox's repositories enabled in your /etc/apt/sources.list ? If you did before the upgrade they were probably disabled. change the hardy to intrepid and it should look like this:

#WineHQ - Ubuntu 8.10 "Intrepid Ibex"
deb http://wine.budgetdedicated.com/apt intrepid main
#Virtualbox - Ubuntu 8.10 "Intrepid ibex"
deb http://download.virtualbox.org/virtualbox/debian intrepid non-free

bim (mng-kingston) said : #3

I reported the update wrongly. The update from 8.04 to 8.10 over the
web gave me a white screen after rebooting. Therefore I reinstalled
8.10 from a self-booting CD. That is how I lost the
references. (Also lost my printer driver, but I know how to reinstall that).

But no solution yet to getting those two things back in the
applications menu.

I therefore added both entries into sources list and ran update.
Got two GPG errors because public keys were not
available. Unfortunately no change to the menu.
So nhasian's solution didn't help. Thanks for your time trying.

  Now to try Shaddow's solution.

At 2009/1/14 22:40, you wrote:
>Your question #57507 on Ubuntu changed:
>https://answers.launchpad.net/ubuntu/+question/57507
>
>nhasian proposed the following answer:
>hello bim,
>
>do you have wine and virtualbox's repositories enabled in your
>/etc/apt/sources.list ? If you did before the upgrade they were
>probably disabled. change the hardy to intrepid and it should look like
>this:
>
>#WineHQ - Ubuntu 8.10 "Intrepid Ibex"
>deb http://wine.budgetdedicated.com/apt intrepid main
>#Virtualbox - Ubuntu 8.10 "Intrepid ibex"
>deb http://download.virtualbox.org/virtualbox/debian intrepid non-free
>
>--
>If this answers your question, please go to the following page to let us
>know that it is solved:
>https://answers.launchpad.net/ubuntu/+question/57507/+confirm?answer_id=1
>
>If you still need help, you can reply to this email or go to the
>following page to enter your feedback:
>https://answers.launchpad.net/ubuntu/+question/57507
>
>You received this question notification because you are a direct
>subscriber of the question.

bim (mng-kingston) said : #4

Well. This is solved.
I did learn from Shaddow about the menus. so thanks for that.
I needed to reinstall both Wine and VBox, since they both have to respect the new kernel in 8.10.

What I had worried about turned out to be of no concern. Wine reconnected with the data it had set up before.
And the new VBox connected with my former XP installation and the 64 GiB I had defined for it.

I don't have solution yet as to how to get to the public keys of those two items, but at least that is not holding me back.
Many thanks for the support from both of you,

"Bim"