Trying to do-release upgrade 12.04

Asked by Talchar on 2014-07-18

hi i tried to do a release upgrade from an updated system 12.04
result (in swedish bu i guess you recognize it anyway..

----------------------------------------------------------------------
magnus@bigbox:~$ sudo do-release-upgrade
Letar efter en ny Ubuntu-utgåva
Fel Uppgraderingsverktygets signatur
  404 Not Found [IP: 91.189.92.201 80]
Fel Uppgraderingsverktyg
  404 Not Found [IP: 91.189.92.201 80]
Hämtade 0 B på 0s (0 B/s)
WARNING:root:file 'quantal.tar.gz.gpg' missing
Misslyckades med att hämta
Hämtningen av uppgraderingen misslyckades. Det kan vara ett problem med nätverket.
-----------------------------------------------------------------------------

a whois on ip gives

--------------------------------------------------------------------------------------
magnus@bigbox:~$ whois 91.189.92.201
% This is the RIPE Database query service.
% The objects are in RPSL format.
%
% The RIPE Database is subject to Terms and Conditions.
% See http://www.ripe.net/db/support/db-terms-conditions.pdf

% Note: this output has been filtered.
% To receive output for a database update, use the "-B" flag.

% Information related to '91.189.88.0 - 91.189.95.255'

% No abuse contact registered for 91.189.88.0 - 91.189.95.255

inetnum: 91.189.88.0 - 91.189.95.255
netname: CANONICAL-CORE
descr: Canonical Ltd
country: GB
org: ORG-CAN1-RIPE
admin-c: CAN-RIPE
tech-c: CAN-RIPE
status: ASSIGNED PI
mnt-by: RIPE-NCC-END-MNT
mnt-lower: RIPE-NCC-END-MNT
mnt-by: CANONICAL-MNT
mnt-routes: CANONICAL-MNT
mnt-domains: CANONICAL-MNT
remarks: rev-srv: ns1.canonical.com
remarks: rev-srv: ns2.canonical.com
remarks: rev-srv: ns3.canonical.com
source: RIPE # Filtered
remarks: rev-srv attribute deprecated by RIPE NCC on 02/09/2009

organisation: ORG-CAN1-RIPE
org-name: Canonical Ltd
org-type: OTHER
address: 1 Circular Road
address: Douglas
address: Isle of Man
address: IM1 1AF
address: United Kingdom
mnt-ref: CANONICAL-MNT
mnt-by: CANONICAL-MNT
source: RIPE # Filtered

role: Canonical Ltd Admin
address: 1 Circular Road
address: Douglas
address: Isle of Man
address: IM1 1AF
admin-c: LJ974-RIPE
admin-c: JT2256-RIPE
admin-c: NM1806-RIPE
admin-c: HM129-RIPE
tech-c: LJ974-RIPE
tech-c: JT2256-RIPE
tech-c: NM1806-RIPE
tech-c: HM129-RIPE
nic-hdl: CAN-RIPE
mnt-by: CANONICAL-MNT
source: RIPE # Filtered

% Information related to '91.189.92.0/24AS41231'

route: 91.189.92.0/24
descr: Canonical Route Object
origin: AS41231
mnt-by: CANONICAL-MNT
source: RIPE # Filtered

% This query was served by the RIPE Database Query Service version 1.74.1 (DB-3)

magnus@bigbox:~$
--------------------------------------------------------------------------------------

... so the server are on ipadress.. when i check out dists, quantal is missing.. how come?
i can do a CD upgrade but i would really like to be able to get security updates..

Best regards Magnus Thulin

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu update-manager Edit question
Assignee:
No assignee Edit question
Last query:
2014-07-21
Last reply:
2014-08-18
Talchar (magnus-thulin) said : #1

extra info link to server : ftp://91.189.92.201/ubuntu/dists/

i also tried other servers, same result.. so quantal is on holiday eh?

Quantal is EOL. So more.....dead than on holiday.

If you boot to the Trusty install CD you can use it to upgrade the installed OS.

Or you can try to upgrade directly to Ubuntu 14.04 with:

sudo do-release-upgrade -d

Which starts the upgrade in my 12.04 testing VM, so it should also work with your system :)

Hamish

Talchar (magnus-thulin) said : #4

tanks for help, will be helpful later when i need to upgrade a bunch of computers.. i noticed support had ended for 12.10 , 13,04

Kindest regards, Magnus Thulin

"Går man ut i snön i kortkalsonger får man både reumatism och ånger."
            Tage Danielsson

Den fredag, 18 juli 2014 22:07 skrev Hamish McIntyre-Bhatty <email address hidden>:

Your question #251853 on update-manager in Ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/update-manager/+question/251853

Hamish McIntyre-Bhatty proposed the following answer:
Or you can try to upgrade directly to Ubuntu 14.04 with:

sudo do-release-upgrade -d

Which starts the upgrade in my 12.04 testing VM, so it should also work
with your system :)

Hamish

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+source/update-manager/+question/251853/+confirm?answer_id=2

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+source/update-manager/+question/251853

You received this question notification because you asked the question.

Talchar (magnus-thulin) said : #5

"
Which starts the upgrade in my 12.04 testing VM, so it should also work
with your system :)
..the upgrade started alright..  when i entered the alternate cd in computer i had the option to install , which i did.. i also managed to upgrade this way all the way up to 14.04 that night, after that i think this error occured.. well im back in 12.04 and will try an upgrade to 14.04 later.. just not now..  ill be back if i run into trouble.. tnx again.. :)

"Går man ut i snön i kortkalsonger får man både reumatism och ånger."
    Tage Danielsson

Den måndag, 21 juli 2014 14:07 skrev Talchar <email address hidden>:

Your question #251853 on update-manager in Ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/update-manager/+question/251853

    Status: Answered => Open

You are still having a problem:
tanks for help, will be helpful later when i need to upgrade a bunch of
computers.. i noticed support had ended for 12.10 , 13,04

Kindest regards, Magnus Thulin

"Går man ut i snön i kortkalsonger får man både reumatism och ånger."
                                    Tage Danielsson

Den fredag, 18 juli 2014 22:07 skrev Hamish McIntyre-Bhatty <email address hidden>:

Your question #251853 on update-manager in Ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/update-manager/+question/251853

Hamish McIntyre-Bhatty proposed the following answer:
Or you can try to upgrade directly to Ubuntu 14.04 with:

sudo do-release-upgrade -d

Which starts the upgrade in my 12.04 testing VM, so it should also work
with your system :)

Hamish

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+source/update-manager/+question/251853/+confirm?answer_id=2

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+source/update-manager/+question/251853

You received this question notification because you asked the question.

You received this question notification because you asked the question.

Christoph Loesch (mmil) said : #6

same problem here, aptitude update runs fine, but do-release-upgrade cant find quantal.tar.gz.gpg on 91.189.92.200:

christoph@voip-dev:~$ grep Prompt /etc/update-manager/release-upgrades
#Prompt=lts
Prompt=normal
christoph@voip-dev:~$ sudo do-release-upgrade
Checking for a new Ubuntu release
Err Upgrade tool signature
  404 Not Found [IP: 91.189.92.200 80]
Err Upgrade tool
  404 Not Found [IP: 91.189.92.200 80]
Fetched 0 B in 0s (0 B/s)
WARNING:root:file 'quantal.tar.gz.gpg' missing
Failed to fetch
Fetching the upgrade failed. There may be a network problem.
christoph@voip-dev:~$ sudo do-release-upgrade -d
Checking for a new Ubuntu release
Err Upgrade tool signature
  404 Not Found [IP: 91.189.88.153 80]
Err Upgrade tool
  404 Not Found [IP: 91.189.88.153 80]
Fetched 0 B in 0s (0 B/s)
WARNING:root:file 'quantal.tar.gz.gpg' missing
Failed to fetch
Fetching the upgrade failed. There may be a network problem.
christoph@voip-dev:~$ egrep "deb|deb-src" /etc/apt/sources.list
# deb cdrom:[Ubuntu-Server 12.04.3 LTS _Precise Pangolin_ - Release amd64 (20130820.2)]/ dists/precise/main/binary-i386/
# deb cdrom:[Ubuntu-Server 12.04.3 LTS _Precise Pangolin_ - Release amd64 (20130820.2)]/ dists/precise/restricted/binary-i386/
# deb cdrom:[Ubuntu-Server 12.04.3 LTS _Precise Pangolin_ - Release amd64 (20130820.2)]/ precise main restricted
#deb cdrom:[Ubuntu-Server 12.04.3 LTS _Precise Pangolin_ - Release amd64 (20130820.2)]/ dists/precise/main/binary-i386/
#deb cdrom:[Ubuntu-Server 12.04.3 LTS _Precise Pangolin_ - Release amd64 (20130820.2)]/ dists/precise/restricted/binary-i386/
#deb cdrom:[Ubuntu-Server 12.04.3 LTS _Precise Pangolin_ - Release amd64 (20130820.2)]/ precise main restricted
deb http://at.archive.ubuntu.com/ubuntu/ precise main restricted
deb-src http://at.archive.ubuntu.com/ubuntu/ precise main restricted
deb http://at.archive.ubuntu.com/ubuntu/ precise-updates main restricted
deb-src http://at.archive.ubuntu.com/ubuntu/ precise-updates main restricted
deb http://at.archive.ubuntu.com/ubuntu/ precise universe
deb-src http://at.archive.ubuntu.com/ubuntu/ precise universe
deb http://at.archive.ubuntu.com/ubuntu/ precise-updates universe
deb-src http://at.archive.ubuntu.com/ubuntu/ precise-updates universe
deb http://at.archive.ubuntu.com/ubuntu/ precise multiverse
deb-src http://at.archive.ubuntu.com/ubuntu/ precise multiverse
deb http://at.archive.ubuntu.com/ubuntu/ precise-updates multiverse
deb-src http://at.archive.ubuntu.com/ubuntu/ precise-updates multiverse
deb http://at.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
deb-src http://at.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu precise-security main restricted
deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
deb http://security.ubuntu.com/ubuntu precise-security universe
deb-src http://security.ubuntu.com/ubuntu precise-security universe
deb http://security.ubuntu.com/ubuntu precise-security multiverse
deb-src http://security.ubuntu.com/ubuntu precise-security multiverse
# deb http://archive.canonical.com/ubuntu precise partner
# deb-src http://archive.canonical.com/ubuntu precise partner
# deb http://extras.ubuntu.com/ubuntu precise main
# deb-src http://extras.ubuntu.com/ubuntu precise main

Quantal doesn't exist on the server any more, as it is out of support. You could try modifying /etc/update-manager/release-upgrades so it reads:

prompt=lts
#prompt=normal

However, if you can, doing a clean install will almost certainly give you the better result.

Hamish

Christoph Loesch (mmil) said : #8

thanks hamish! that helped to upgrade with: sudo do-release-upgrade -d

Can you help with this problem?

Provide an answer of your own, or ask Talchar for more information if necessary.

To post a message you must log in.