sudo updatedb & gives /usr/bin/find: '~/.gvfs ': Permission denied

Asked by sageb1 on 2014-01-23

I use updatedb to update the database containing a list of all paths on my main Linux system partition.

Then I use locate to locate the file which is a simple string not containing "/" as suffix.

It uses /usr/bin/find to search the directory structure.

It fails on ~/.gvfs because of the following attributes for this directory:
dr-x------ 2 1000 1000 0 Jan 22 20:37 .gvfs

This directory appears to be a "virtual" directory created by the gvfs software on boot up. .gvfs must first "point" to a mounted disc. However the updatedb program still gives the same error because of the above attrbutes on the directory.

Therefore it is a "fake" error caused by root respecting the read only execute attribute for the directory .gvfs which is a signal indicate that a scan of a .gvfs directory should fail.

I cannot prune the full path to .gvfs because it is a virtual directory i.e. only exists for libgvfs and possibly libfuse.

It does not exist for updatedb and /usr/bin/find.

However, locate finds it without error due to the directory's attributes.

If I am wrong about my interpretation of why I get this common error, then please tell me soon.

I know I am supposed to ignore the error because it's the only one that occurs using "sudo updatedb &"

My idea of a "fix" is to let the error stream from the output of updatedb be redirect to standard output and filter out "~/.gvfs" e.g. using grep "gvfs"|grep ~ where "~" is your home user directory name.

Even so, to reiterate, ignoring the error is more useful because the error is not mission critical.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu update-manager Edit question
Assignee:
No assignee Edit question
Solved by:
sageb1
Solved:
2014-01-24
Last query:
2014-01-24
Last reply:
sageb1 (shkawamoto) said : #1

apologizes: this is supported to be a new error, not part of Ubuntu update-manager.

Can the maintainer of the Ubuntu update-manager errors please move this post to a new error of its own or to a previous reference of this error?

sageb1 (shkawamoto) said : #2

Please move my question to findutils package