E:Encountered a section with no Package: header, E:Problem with MergeList

Asked by kapetr on 2013-11-23

1. ubuntu-bug update-manager fails - so manually:
2. I get error from update manager (in Czech):

------------------------
Nahlaste prosím tento problém vůči balíčku „update-manager“ a přiložte následující chybovou hlášku:

'E:Encountered a section with no Package: header, E:Problem with MergeList /var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_precise-security_main_i18n_Translation-cs, E:Seznamy balíků nebo stavový soubor nemohly být zpracovány nebo otevřeny.'
--------------------------

The /var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_precise-security_main_i18n_Translation-cs is in attachment.

As you can see - in the file is not what should.

I use wifi ISP - hotspot => before log in, all HTTP traffic is redirected to ISP's login page.
I do not know how, but Ubuntu gets this content and saves it to this file.

I have to delete this file and re-run update manager to get proper content (after ISP login).
The problem is only with this file - in /var/lib/apt/lists/.

Ubuntu 12.04 LTS 64b.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu update-manager Edit question
Assignee:
No assignee Edit question
Solved by:
N1ck 7h0m4d4k15
Solved:
2013-11-27
Last query:
2013-11-27
Last reply:
2013-11-27
N1ck 7h0m4d4k15 (nicktux) said : #1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We understand the difficulties you are facing, but it is better to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. You can also find help with your problem in the support forum of your local Ubuntu community http://loco.ubuntu.com/ or asking at http://askubuntu.com or http://ubuntuforums.org. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs.

Best Regards
 NikTh

kapetr (kapetr) said : #2

I'm sorry - but I do not agree.
If fails such esential function like update - and requires manual assistance, then it is a Bug.

That simply must not happen.

wget https://dl.dropbox.com/u/8850924/fixpackage
chmod +x ./fixpackage
sudo ./fixpackage

Should resolve it

kapetr (kapetr) said : #4

Thank You - it is +- the same what I do too, but I want not do it allmost every time I connect to Net
:-(
That is the Problem. It is Bug.
These files should be checked before used - e.g. downloaded via HTTPS or checked content, ...

Not to download something wrong, use it and stop working!

Manfred Hampl (m-hampl) said : #5

This is bug #346386 which I thought has been solved in apt 0.8.16~exp12ubuntu10.5

Which version of apt do you have on your system?

dpkg -l apt

kapetr (kapetr) said : #6

I run continuously updated U12.04 64b LTS.

apt 0.8.16~exp12ubuntu10.15

And YES - i seems to be the same bug as #346386 - reported on 2009-03-21 and with Importance = HIGH.

But it is back again ?

N1ck 7h0m4d4k15 (nicktux) said : #7

@kapter

the Team Bug Bot has marked your bug report as a duplicate.
The bug that @Manfred Hampl linked is the [MASTER] one. Visit the link and see how many duplicates it has.

I saw that you've changed your bug status back to "New". That is OK. That's the procedure. Well done. :-)

If you disagree with the duplicate mark, you can add a comment in your bug report.

Please don't forget to add the tag "regression-update" in your bug report, for the developers to be informed.

Please don't forget to close this question as solved (when this done) by clicking the button "This solved my question" at the appropriate answer.

Best Regards
    NikTh

N1ck 7h0m4d4k15 (nicktux) said : #8

Oh, I've forgot.

You can also remove the duplicate mark from your bug, in order to get it back in action. ;-)

Best Regards
    NikTh

kapetr (kapetr) said : #9

Hello - thanks for explanation, but I do not understand English well.
=> not sure what and how to do.

I do not not know,
1. where I should set the "regression-update" tag. In Bug #346386 or in Bug #1254271 ?
2. how can I set this tag ? I see no place to enter it/to click.

Best N1ck 7h0m4d4k15 (nicktux) said : #10

Hello,

the "regression-update" tag should be added in your bug report. (Bug #1254271)

I have fixed that for you now. Also I removed the duplicate mark. The bug is back in action right now.

For future knowledge, you can add tags if you click the yellow pencil icon in tags section. You must separate tags with space.

Best Regards
   NikTh

kapetr (kapetr) said : #11

Thank you very much for help and assistance.

kapetr (kapetr) said : #12

Thanks Nik.Th., that solved my question.