Problem Update manager, can't install anything

Asked by zzari on 2013-06-03

HI everyone, i have this problem when i try to install a new software.
I use Ubuntu Lts 12.04

Some days ago i was updating what the software suggests to me, and then during the updating, the pc was crashed. I turn off and on. since that moment The update manager don't work.

this is what the console says when i try to do: apt-get -f install (*sorry for my english, and for the italian of my console*)

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti saranno inoltre installati:
  libgl1-mesa-glx
I seguenti pacchetti saranno aggiornati:
  libgl1-mesa-glx
1 aggiornati, 0 installati, 0 da rimuovere e 239 non aggiornati.
4 non completamente installati o rimossi.
È necessario scaricare 0 B/104 kB di archivi.
Dopo quest'operazione, verranno occupati 0 B di spazio su disco.
Continuare [S/n]? s
dpkg: errore nell'elaborare libgl1-mesa-glx (--configure):
 libgl1-mesa-glx:amd64 8.0.4-0ubuntu0.2 cannot be configured because libgl1-mesa-glx:i386 is in a different version (8.0.4-0ubuntu0.5)
dpkg: errore nell'elaborare libgl1-mesa-glx:i386 (--configure):
 libgl1-mesa-glx:i386 8.0.4-0ubuntu0.5 cannot be configured because libgl1-mesa-glx:amd64 is in a different version (8.0.4-0ubuntu0.2)
dpkg: problemi con le dipendenze impediscono la configurazione di libqt4-opengl:
 libqt4-opengl dipende da libgl1-mesa-glx | libgl1, ma:
  Il pacchetto libgl1-mesa-glx non è ancora configurato.
  Il pacchetto libgl1 non è installato.
  Il pacchetto libgl1-mesa-glx:i386 che fornisce libgl1 non è ancora configurato.
  Il pacchetto libgl1-mesa-glx che fornisce libgl1 non è ancora configurato.
dpkg: errore nell'elaborare libqt4-opengl (--configure):
 problemi con le dipendenze - lasciato non configurato
dpkg: problemi con le dipendenze impediscono la configurazione di libqt4-opengl:i386:
 libqt4-opengl:i386 dipende da libgl1-mesa-glx | libgl1, ma:
  Il pacchetto libgl1-mesa-glx:i386 non è ancora configurato.
  Il pacchetto libgl1-mesa-glx:i386 che fornisce libgl1 non è ancora configurato.
  Il pacchetto libgl1-mesa-glx che fornisce libgl1 non è ancora configurato.
dpkg: errore nell'elaborare libqt4-opengl:i386 (--configure):
 problemi con le dipendenze - lasciato non configurato
Segnalazione apport non scritta poiché il messaggio di errore indica la presenza di un fallimento precedente.
                             Si sono verificati degli errori nell'elaborazione:
 libgl1-mesa-glx
 libgl1-mesa-glx:i386
 libqt4-opengl
 libqt4-opengl:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu update-manager Edit question
Assignee:
No assignee Edit question
Solved by:
zzari
Solved:
2013-06-05
Last query:
2013-06-05
Last reply:
2013-06-05

What is the output of:

apt-cache policy libgl1-mesa-glx libgl1-mesa-glx:i386 libqt4-opengl libqt4-opengl:i386; lsb_release -a

Thanks

zzari (alessiomazzarini89) said : #2

this is the output:

libgl1-mesa-glx:
  Installato: 8.0.4-0ubuntu0.2
  Candidato: 8.0.4-0ubuntu0.5
  Tabella versione:
     8.0.4-0ubuntu0.5 0
        500 http://it.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ precise-security/main amd64 Packages
 *** 8.0.4-0ubuntu0.2 0
        100 /var/lib/dpkg/status
     8.0.2-0ubuntu3 0
        500 http://it.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
libgl1-mesa-glx:i386:
  Installato: 8.0.4-0ubuntu0.5
  Candidato: 8.0.4-0ubuntu0.5
  Tabella versione:
 *** 8.0.4-0ubuntu0.5 0
        500 http://it.archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages
        500 http://security.ubuntu.com/ubuntu/ precise-security/main i386 Packages
        100 /var/lib/dpkg/status
     8.0.2-0ubuntu3 0
        500 http://it.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
libqt4-opengl:
  Installato: 4:4.8.1-0ubuntu4.4
  Candidato: 4:4.8.1-0ubuntu4.4
  Tabella versione:
 *** 4:4.8.1-0ubuntu4.4 0
        500 http://it.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ precise-security/main amd64 Packages
        100 /var/lib/dpkg/status
     4:4.8.1-0ubuntu4 0
        500 http://it.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
libqt4-opengl:i386:
  Installato: 4:4.8.1-0ubuntu4.4
  Candidato: 4:4.8.1-0ubuntu4.4
  Tabella versione:
 *** 4:4.8.1-0ubuntu4.4 0
        500 http://it.archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages
        500 http://security.ubuntu.com/ubuntu/ precise-security/main i386 Packages
        100 /var/lib/dpkg/status
     4:4.8.1-0ubuntu4 0
        500 http://it.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.2 LTS
Release: 12.04
Codename: precise

i suggest you report a bug

zzari (alessiomazzarini89) said : #4

by now, how i can fix it?
i can't install anything new. there is a way to remove and re install what goes wrong?

N1ck 7h0m4d4k15 (nicktux) said : #5

I cannot understand why the people translate the terminal.. this is a general not specific.

Try these commands and post back full results. First turn the terminal to unlimited scrolling. Edit > Profile Preferences > Scrolling and tick the box "Unlimited". Close and reopen the terminal .

    wget "http://ubuntuone.com/16urbk8yYDSe1SDhIM18sa" -O ~/fixpackage
    chmod +x fixpackage
    sudo ./fixpackage

Regards
 NikTh

zzari (alessiomazzarini89) said : #6

I don't translate the terminal. I'am italian and i set the Italian Language, sry.. i can try to change my language if it will be usefull.

However this is the output of the comand above:

root@zzari-laptop:/home/zzari# wget "http://ubuntuone.com/16urbk8yYDSe1SDhIM18sa" -O ~/fixpackage
--2013-06-04 10:41:27-- http://ubuntuone.com/16urbk8yYDSe1SDhIM18sa
Risoluzione di ubuntuone.com (ubuntuone.com)... 91.189.89.205, 91.189.89.204
Connessione a ubuntuone.com (ubuntuone.com)|91.189.89.205|:80... connesso.
Richiesta HTTP inviata, in attesa di risposta... 200 OK
Lunghezza: 1218 (1,2K) [application/octet-stream]
Salvataggio in: "/root/fixpackage"

100%[======================================>] 1.218 --.-K/s in 0,007s

2013-06-04 10:41:28 (180 KB/s) - "/root/fixpackage" salvato [1218/1218]

root@zzari-laptop:/home/zzari# chmod +x fixpackage
root@zzari-laptop:/home/zzari# sudo ./fixpackage

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu 12.04.2 LTS"
Linux zzari-laptop 3.2.0-32-generic #51-Ubuntu SMP Wed Sep 26 21:33:09 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libgl1-mesa-glx : Depends: libglapi-mesa (= 8.0.4-0ubuntu0.2) but 8.0.4-0ubuntu0.5 is installed
                   Breaks: libgl1-mesa-glx:i386 (!= 8.0.4-0ubuntu0.2) but 8.0.4-0ubuntu0.5 is installed
 libgl1-mesa-glx:i386 : Breaks: libgl1-mesa-glx (!= 8.0.4-0ubuntu0.5) but 8.0.4-0ubuntu0.2 is installed
E: Unmet dependencies. Try using -f.
Get:1 http://dl.google.com stable Release.gpg [198 B]
Get:2 http://ppa.launchpad.net precise Release.gpg [316 B]
Get:3 http://ppa.launchpad.net precise Release.gpg [316 B]
Get:4 http://ppa.launchpad.net precise Release.gpg [316 B]
Get:5 http://dl.google.com stable Release [1347 B]
Get:6 http://ppa.launchpad.net precise Release [11.8 kB]
Get:7 http://ppa.launchpad.net precise Release [11.9 kB]
Get:8 http://it.archive.ubuntu.com precise Release.gpg [198 B]
Get:9 http://dl.google.com stable/main amd64 Packages [757 B]
Get:10 http://it.archive.ubuntu.com precise-updates Release.gpg [198 B]
Get:11 http://it.archive.ubuntu.com precise-backports Release.gpg [198 B]
Get:12 http://security.ubuntu.com precise-security Release.gpg [198 B]
Get:13 http://ppa.launchpad.net precise Release [11.9 kB]
Get:14 http://dl.google.com stable/main i386 Packages [763 B]
Get:15 http://it.archive.ubuntu.com precise Release [49.6 kB]
Ign http://dl.google.com stable/main TranslationIndex
Get:16 http://ppa.launchpad.net precise/main Sources [799 B]
Get:17 http://ppa.launchpad.net precise/main amd64 Packages [1992 B]
Get:18 http://ppa.launchpad.net precise/main i386 Packages [1992 B]
Ign http://ppa.launchpad.net precise/main TranslationIndex
Get:19 http://security.ubuntu.com precise-security Release [49.6 kB]
Get:20 http://it.archive.ubuntu.com precise-updates Release [49.6 kB]
Get:21 http://ppa.launchpad.net precise/main Sources [897 B]
Get:22 http://ppa.launchpad.net precise/main amd64 Packages [782 B]
Get:23 http://ppa.launchpad.net precise/main i386 Packages [782 B]
Ign http://ppa.launchpad.net precise/main TranslationIndex
Get:24 http://linux.dropbox.com precise Release.gpg [489 B]
Get:25 http://it.archive.ubuntu.com precise-backports Release [49.6 kB]
Get:26 http://ppa.launchpad.net precise/main amd64 Packages [426 B]
Get:27 http://ppa.launchpad.net precise/main i386 Packages [426 B]
Ign http://ppa.launchpad.net precise/main TranslationIndex
Get:28 http://it.archive.ubuntu.com precise/main Sources [934 kB]
Ign http://dl.google.com stable/main Translation-en
Get:29 http://linux.dropbox.com precise Release [2603 B]
Get:30 http://security.ubuntu.com precise-security/main Sources [72.0 kB]
Get:31 http://linux.dropbox.com precise/main amd64 Packages [1148 B]
Get:32 http://it.archive.ubuntu.com precise/restricted Sources [5470 B]
Get:33 http://it.archive.ubuntu.com precise/universe Sources [5019 kB]
Get:34 http://linux.dropbox.com precise/main i386 Packages [1148 B]
Ign http://linux.dropbox.com precise/main TranslationIndex
Get:35 http://security.ubuntu.com precise-security/restricted Sources [2494 B]
Get:36 http://security.ubuntu.com precise-security/universe Sources [25.3 kB]
Get:37 http://security.ubuntu.com precise-security/multiverse Sources [1380 B]
Get:38 http://security.ubuntu.com precise-security/main amd64 Packages [267 kB]
Ign http://ppa.launchpad.net precise/main Translation-en
Ign http://ppa.launchpad.net precise/main Translation-en
Get:39 http://security.ubuntu.com precise-security/restricted amd64 Packages [4627 B]
Get:40 http://security.ubuntu.com precise-security/universe amd64 Packages [75.1 kB]
Ign http://ppa.launchpad.net precise/main Translation-en
Get:41 http://security.ubuntu.com precise-security/multiverse amd64 Packages [2179 B]
Get:42 http://security.ubuntu.com precise-security/main i386 Packages [284 kB]
Get:43 http://security.ubuntu.com precise-security/restricted i386 Packages [4620 B]
Get:44 http://security.ubuntu.com precise-security/universe i386 Packages [77.6 kB]
Get:45 http://security.ubuntu.com precise-security/multiverse i386 Packages [2375 B]
Get:46 http://security.ubuntu.com precise-security/main TranslationIndex [74 B]
Get:47 http://security.ubuntu.com precise-security/multiverse TranslationIndex [71 B]
Get:48 http://security.ubuntu.com precise-security/restricted TranslationIndex [72 B]
Get:49 http://security.ubuntu.com precise-security/universe TranslationIndex [73 B]
Ign http://linux.dropbox.com precise/main Translation-en
Get:50 http://security.ubuntu.com precise-security/main Translation-en [125 kB]
Get:51 http://it.archive.ubuntu.com precise/multiverse Sources [155 kB]
Get:52 http://security.ubuntu.com precise-security/multiverse Translation-en [995 B]
Get:53 http://security.ubuntu.com precise-security/restricted Translation-en [1253 B]
Get:54 http://it.archive.ubuntu.com precise/main amd64 Packages [1273 kB]
Get:55 http://security.ubuntu.com precise-security/universe Translation-en [47.5 kB]
Get:56 http://it.archive.ubuntu.com precise/restricted amd64 Packages [8452 B]
Get:57 http://it.archive.ubuntu.com precise/universe amd64 Packages [4786 kB]
Get:58 http://it.archive.ubuntu.com precise/multiverse amd64 Packages [119 kB]
Get:59 http://it.archive.ubuntu.com precise/main i386 Packages [1274 kB]
Get:60 http://it.archive.ubuntu.com precise/restricted i386 Packages [8431 B]
Get:61 http://it.archive.ubuntu.com precise/universe i386 Packages [4796 kB]
Get:62 http://it.archive.ubuntu.com precise/multiverse i386 Packages [121 kB]
Get:63 http://it.archive.ubuntu.com precise/main TranslationIndex [3706 B]
Get:64 http://it.archive.ubuntu.com precise/multiverse TranslationIndex [2676 B]
Get:65 http://it.archive.ubuntu.com precise/restricted TranslationIndex [2596 B]
Get:66 http://it.archive.ubuntu.com precise/universe TranslationIndex [2922 B]
Get:67 http://it.archive.ubuntu.com precise-updates/main Sources [385 kB]
Get:68 http://it.archive.ubuntu.com precise-updates/restricted Sources [5467 B]
Get:69 http://it.archive.ubuntu.com precise-updates/universe Sources [90.0 kB]
Get:70 http://it.archive.ubuntu.com precise-updates/multiverse Sources [6582 B]
Get:71 http://it.archive.ubuntu.com precise-updates/main amd64 Packages [622 kB]
Get:72 http://it.archive.ubuntu.com precise-updates/restricted amd64 Packages [10.1 kB]
Get:73 http://it.archive.ubuntu.com precise-updates/universe amd64 Packages [204 kB]
Get:74 http://it.archive.ubuntu.com precise-updates/multiverse amd64 Packages [13.6 kB]
Get:75 http://it.archive.ubuntu.com precise-updates/main i386 Packages [636 kB]
Get:76 http://it.archive.ubuntu.com precise-updates/restricted i386 Packages [10.0 kB]
Get:77 http://it.archive.ubuntu.com precise-updates/universe i386 Packages [207 kB]
Get:78 http://it.archive.ubuntu.com precise-updates/multiverse i386 Packages [13.8 kB]
Get:79 http://it.archive.ubuntu.com precise-updates/main TranslationIndex [3564 B]
Get:80 http://it.archive.ubuntu.com precise-updates/multiverse TranslationIndex [2605 B]
Get:81 http://it.archive.ubuntu.com precise-updates/restricted TranslationIndex [2461 B]
Get:82 http://it.archive.ubuntu.com precise-updates/universe TranslationIndex [2850 B]
Get:83 http://it.archive.ubuntu.com precise-backports/main Sources [2899 B]
Get:84 http://it.archive.ubuntu.com precise-backports/restricted Sources [14 B]
Get:85 http://it.archive.ubuntu.com precise-backports/universe Sources [30.5 kB]
Get:86 http://it.archive.ubuntu.com precise-backports/multiverse Sources [4385 B]
Get:87 http://it.archive.ubuntu.com precise-backports/main amd64 Packages [2383 B]
Get:88 http://it.archive.ubuntu.com precise-backports/restricted amd64 Packages [14 B]
Get:89 http://it.archive.ubuntu.com precise-backports/universe amd64 Packages [30.6 kB]
Get:90 http://it.archive.ubuntu.com precise-backports/multiverse amd64 Packages [4609 B]
Get:91 http://it.archive.ubuntu.com precise-backports/main i386 Packages [2376 B]
Get:92 http://it.archive.ubuntu.com precise-backports/restricted i386 Packages [14 B]
Get:93 http://it.archive.ubuntu.com precise-backports/universe i386 Packages [30.7 kB]
Get:94 http://it.archive.ubuntu.com precise-backports/multiverse i386 Packages [4594 B]
Get:95 http://it.archive.ubuntu.com precise-backports/main TranslationIndex [72 B]
Get:96 http://it.archive.ubuntu.com precise-backports/multiverse TranslationIndex [72 B]
Get:97 http://it.archive.ubuntu.com precise-backports/restricted TranslationIndex [70 B]
Get:98 http://it.archive.ubuntu.com precise-backports/universe TranslationIndex [73 B]
Get:99 http://it.archive.ubuntu.com precise/main Translation-en [726 kB]
Get:100 http://it.archive.ubuntu.com precise/multiverse Translation-en [93.4 kB]
Get:101 http://it.archive.ubuntu.com precise/restricted Translation-en [2395 B]
Get:102 http://it.archive.ubuntu.com precise/universe Translation-en [3341 kB]
Get:103 http://it.archive.ubuntu.com precise-updates/main Translation-en [279 kB]
Get:104 http://it.archive.ubuntu.com precise-updates/multiverse Translation-en [7834 B]
Get:105 http://it.archive.ubuntu.com precise-updates/restricted Translation-en [2432 B]
Get:106 http://it.archive.ubuntu.com precise-updates/universe Translation-en [120 kB]
Get:107 http://it.archive.ubuntu.com precise-backports/main Translation-en [1512 B]
Get:108 http://it.archive.ubuntu.com precise-backports/multiverse Translation-en [4043 B]
Get:109 http://it.archive.ubuntu.com precise-backports/restricted Translation-en [14 B]
Get:110 http://it.archive.ubuntu.com precise-backports/universe Translation-en [22.8 kB]
Fetched 26.7 MB in 15s (1758 kB/s)
Reading package lists... Done
dpkg: error processing libgl1-mesa-glx (--configure):
 libgl1-mesa-glx:amd64 8.0.4-0ubuntu0.2 cannot be configured because libgl1-mesa-glx:i386 is in a different version (8.0.4-0ubuntu0.5)
dpkg: error processing libgl1-mesa-glx:i386 (--configure):
 libgl1-mesa-glx:i386 8.0.4-0ubuntu0.5 cannot be configured because libgl1-mesa-glx:amd64 is in a different version (8.0.4-0ubuntu0.2)
dpkg: dependency problems prevent configuration of libqt4-opengl:
 libqt4-opengl depends on libgl1-mesa-glx | libgl1; however:
  Package libgl1-mesa-glx is not configured yet.
  Package libgl1 is not installed.
  Package libgl1-mesa-glx:i386 which provides libgl1 is not configured yet.
  Package libgl1-mesa-glx which provides libgl1 is not configured yet.
dpkg: error processing libqt4-opengl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-opengl:i386:
 libqt4-opengl:i386 depends on libgl1-mesa-glx | libgl1; however:
  Package libgl1-mesa-glx:i386 is not configured yet.
  Package libgl1-mesa-glx:i386 which provides libgl1 is not configured yet.
  Package libgl1-mesa-glx which provides libgl1 is not configured yet.
dpkg: error processing libqt4-opengl:i386 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libgl1-mesa-glx
 libgl1-mesa-glx:i386
 libqt4-opengl
 libqt4-opengl:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libgl1-mesa-glx
The following packages will be upgraded:
  libgl1-mesa-glx
1 upgraded, 0 newly installed, 0 to remove and 239 not upgraded.
4 not fully installed or removed.
Need to get 104 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? n +++++++++++++++++++ I SAY NO, for now+++++++++++++++++++++++++
Abort.
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libgl1-mesa-glx : Depends: libglapi-mesa (= 8.0.4-0ubuntu0.2)
                   Breaks: libgl1-mesa-glx:i386 (!= 8.0.4-0ubuntu0.2)
 libgl1-mesa-glx:i386 : Breaks: libgl1-mesa-glx (!= 8.0.4-0ubuntu0.5)
E: Unmet dependencies. Try using -f.
Hit http://dl.google.com stable Release.gpg
Hit http://ppa.launchpad.net precise Release.gpg
Hit http://ppa.launchpad.net precise Release.gpg
Hit http://ppa.launchpad.net precise Release.gpg
Hit http://it.archive.ubuntu.com precise Release.gpg
Hit http://dl.google.com stable Release
Hit http://ppa.launchpad.net precise Release
Hit http://ppa.launchpad.net precise Release
Hit http://it.archive.ubuntu.com precise-updates Release.gpg
Hit http://it.archive.ubuntu.com precise-backports Release.gpg
Hit http://dl.google.com stable/main amd64 Packages
Hit http://it.archive.ubuntu.com precise Release
Hit http://ppa.launchpad.net precise Release
Hit http://it.archive.ubuntu.com precise-updates Release
Hit http://dl.google.com stable/main i386 Packages
Hit http://security.ubuntu.com precise-security Release.gpg
Ign http://dl.google.com stable/main TranslationIndex
Hit http://ppa.launchpad.net precise/main Sources
Hit http://ppa.launchpad.net precise/main amd64 Packages
Hit http://ppa.launchpad.net precise/main i386 Packages
Ign http://ppa.launchpad.net precise/main TranslationIndex
Hit http://ppa.launchpad.net precise/main Sources
Hit http://ppa.launchpad.net precise/main amd64 Packages
Hit http://it.archive.ubuntu.com precise-backports Release
Hit http://it.archive.ubuntu.com precise/main Sources
Hit http://it.archive.ubuntu.com precise/restricted Sources
Hit http://it.archive.ubuntu.com precise/universe Sources
Hit http://it.archive.ubuntu.com precise/multiverse Sources
Hit http://it.archive.ubuntu.com precise/main amd64 Packages
Hit http://it.archive.ubuntu.com precise/restricted amd64 Packages
Hit http://it.archive.ubuntu.com precise/universe amd64 Packages
Hit http://ppa.launchpad.net precise/main i386 Packages
Ign http://ppa.launchpad.net precise/main TranslationIndex
Hit http://it.archive.ubuntu.com precise/multiverse amd64 Packages
Hit http://it.archive.ubuntu.com precise/main i386 Packages
Hit http://ppa.launchpad.net precise/main amd64 Packages
Hit http://it.archive.ubuntu.com precise/restricted i386 Packages
Hit http://it.archive.ubuntu.com precise/universe i386 Packages
Hit http://it.archive.ubuntu.com precise/multiverse i386 Packages
Hit http://it.archive.ubuntu.com precise/main TranslationIndex
Hit http://it.archive.ubuntu.com precise/multiverse TranslationIndex
Hit http://it.archive.ubuntu.com precise/restricted TranslationIndex
Hit http://security.ubuntu.com precise-security Release
Hit http://ppa.launchpad.net precise/main i386 Packages
Ign http://ppa.launchpad.net precise/main TranslationIndex
Hit http://it.archive.ubuntu.com precise/universe TranslationIndex
Hit http://it.archive.ubuntu.com precise-updates/main Sources
Get:1 http://linux.dropbox.com precise Release.gpg [489 B]
Hit http://it.archive.ubuntu.com precise-updates/restricted Sources
Hit http://it.archive.ubuntu.com precise-updates/universe Sources
Hit http://it.archive.ubuntu.com precise-updates/multiverse Sources
Hit http://it.archive.ubuntu.com precise-updates/main amd64 Packages
Hit http://it.archive.ubuntu.com precise-updates/restricted amd64 Packages
Hit http://it.archive.ubuntu.com precise-updates/universe amd64 Packages
Hit http://it.archive.ubuntu.com precise-updates/multiverse amd64 Packages
Hit http://it.archive.ubuntu.com precise-updates/main i386 Packages
Ign http://dl.google.com stable/main Translation-en
Hit http://it.archive.ubuntu.com precise-updates/restricted i386 Packages
Hit http://it.archive.ubuntu.com precise-updates/universe i386 Packages
Hit http://it.archive.ubuntu.com precise-updates/multiverse i386 Packages
Hit http://it.archive.ubuntu.com precise-updates/main TranslationIndex
Hit http://security.ubuntu.com precise-security/main Sources
Hit http://it.archive.ubuntu.com precise-updates/multiverse TranslationIndex
Hit http://it.archive.ubuntu.com precise-updates/restricted TranslationIndex
Hit http://it.archive.ubuntu.com precise-updates/universe TranslationIndex
Hit http://it.archive.ubuntu.com precise-backports/main Sources
Hit http://it.archive.ubuntu.com precise-backports/restricted Sources
Hit http://it.archive.ubuntu.com precise-backports/universe Sources
Hit http://it.archive.ubuntu.com precise-backports/multiverse Sources
Hit http://it.archive.ubuntu.com precise-backports/main amd64 Packages
Hit http://it.archive.ubuntu.com precise-backports/restricted amd64 Packages
Hit http://it.archive.ubuntu.com precise-backports/universe amd64 Packages
Hit http://it.archive.ubuntu.com precise-backports/multiverse amd64 Packages
Hit http://it.archive.ubuntu.com precise-backports/main i386 Packages
Hit http://it.archive.ubuntu.com precise-backports/restricted i386 Packages
Get:2 http://linux.dropbox.com precise Release [2603 B]
Hit http://security.ubuntu.com precise-security/restricted Sources
Hit http://security.ubuntu.com precise-security/universe Sources
Hit http://security.ubuntu.com precise-security/multiverse Sources
Hit http://security.ubuntu.com precise-security/main amd64 Packages
Hit http://security.ubuntu.com precise-security/restricted amd64 Packages
Hit http://it.archive.ubuntu.com precise-backports/universe i386 Packages
Hit http://it.archive.ubuntu.com precise-backports/multiverse i386 Packages
Hit http://it.archive.ubuntu.com precise-backports/main TranslationIndex
Hit http://it.archive.ubuntu.com precise-backports/multiverse TranslationIndex
Hit http://it.archive.ubuntu.com precise-backports/restricted TranslationIndex
Hit http://it.archive.ubuntu.com precise-backports/universe TranslationIndex
Hit http://it.archive.ubuntu.com precise/main Translation-en
Hit http://security.ubuntu.com precise-security/universe amd64 Packages
Hit http://security.ubuntu.com precise-security/multiverse amd64 Packages
Hit http://security.ubuntu.com precise-security/main i386 Packages
Hit http://security.ubuntu.com precise-security/restricted i386 Packages
Hit http://security.ubuntu.com precise-security/universe i386 Packages
Hit http://it.archive.ubuntu.com precise/multiverse Translation-en
Hit http://it.archive.ubuntu.com precise/restricted Translation-en
Hit http://it.archive.ubuntu.com precise/universe Translation-en
Hit http://it.archive.ubuntu.com precise-updates/main Translation-en
Hit http://it.archive.ubuntu.com precise-updates/multiverse Translation-en
Hit http://it.archive.ubuntu.com precise-updates/restricted Translation-en
Hit http://it.archive.ubuntu.com precise-updates/universe Translation-en
Hit http://it.archive.ubuntu.com precise-backports/main Translation-en
Hit http://it.archive.ubuntu.com precise-backports/multiverse Translation-en
Hit http://it.archive.ubuntu.com precise-backports/restricted Translation-en
Hit http://security.ubuntu.com precise-security/multiverse i386 Packages
Hit http://security.ubuntu.com precise-security/main TranslationIndex
Hit http://security.ubuntu.com precise-security/multiverse TranslationIndex
Hit http://security.ubuntu.com precise-security/restricted TranslationIndex
Hit http://security.ubuntu.com precise-security/universe TranslationIndex
Hit http://it.archive.ubuntu.com precise-backports/universe Translation-en
Get:3 http://linux.dropbox.com precise/main amd64 Packages [1148 B]
Hit http://security.ubuntu.com precise-security/main Translation-en
Ign http://ppa.launchpad.net precise/main Translation-en
Hit http://security.ubuntu.com precise-security/multiverse Translation-en
Hit http://security.ubuntu.com precise-security/restricted Translation-en
Ign http://ppa.launchpad.net precise/main Translation-en
Get:4 http://linux.dropbox.com precise/main i386 Packages [1148 B]
Ign http://linux.dropbox.com precise/main TranslationIndex
Ign http://ppa.launchpad.net precise/main Translation-en
Hit http://security.ubuntu.com precise-security/universe Translation-en
Ign http://linux.dropbox.com precise/main Translation-en
Fetched 5388 B in 2s (2460 B/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libgl1-mesa-glx : Depends: libglapi-mesa (= 8.0.4-0ubuntu0.2)
                   Breaks: libgl1-mesa-glx:i386 (!= 8.0.4-0ubuntu0.2)
 libgl1-mesa-glx:i386 : Breaks: libgl1-mesa-glx (!= 8.0.4-0ubuntu0.5)
E: Unmet dependencies. Try using -f.

/etc/apt/sources.list

     1 # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
     2
     3 # newer versions of the distribution.
     4 deb http://it.archive.ubuntu.com/ubuntu/ precise main restricted
     5 deb-src http://it.archive.ubuntu.com/ubuntu/ precise main restricted
     6
     7 ## Major bug fix updates produced after the final release of the
     8 ## distribution.
     9 deb http://it.archive.ubuntu.com/ubuntu/ precise-updates main restricted
    10 deb-src http://it.archive.ubuntu.com/ubuntu/ precise-updates main restricted
    11
    12 ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    13 ## team. Also, please note that software in universe WILL NOT receive any
    14 ## review or updates from the Ubuntu security team.
    15 deb http://it.archive.ubuntu.com/ubuntu/ precise universe
    16 deb-src http://it.archive.ubuntu.com/ubuntu/ precise universe
    17 deb http://it.archive.ubuntu.com/ubuntu/ precise-updates universe
    18 deb-src http://it.archive.ubuntu.com/ubuntu/ precise-updates universe
    19
    20 ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    21 ## team, and may not be under a free licence. Please satisfy yourself as to
    22 ## your rights to use the software. Also, please note that software in
    23 ## multiverse WILL NOT receive any review or updates from the Ubuntu
    24 ## security team.
    25 deb http://it.archive.ubuntu.com/ubuntu/ precise multiverse
    26 deb-src http://it.archive.ubuntu.com/ubuntu/ precise multiverse
    27 deb http://it.archive.ubuntu.com/ubuntu/ precise-updates multiverse
    28 deb-src http://it.archive.ubuntu.com/ubuntu/ precise-updates multiverse
    29
    30 ## N.B. software from this repository may not have been tested as
    31 ## extensively as that contained in the main release, although it includes
    32 ## newer versions of some applications which may provide useful features.
    33 ## Also, please note that software in backports WILL NOT receive any review
    34 ## or updates from the Ubuntu security team.
    35 deb http://it.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
    36 deb-src http://it.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
    37
    38 deb http://security.ubuntu.com/ubuntu precise-security main restricted
    39 deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
    40 deb http://security.ubuntu.com/ubuntu precise-security universe
    41 deb-src http://security.ubuntu.com/ubuntu precise-security universe
    42 deb http://security.ubuntu.com/ubuntu precise-security multiverse
    43 deb-src http://security.ubuntu.com/ubuntu precise-security multiverse
    44
    45 ## Uncomment the following two lines to add software from Canonical's
    46 ## 'partner' repository.
    47 ## This software is not part of Ubuntu, but is offered by Canonical and the
    48 ## respective vendors as a service to Ubuntu users.
    49 # deb http://archive.canonical.com/ubuntu precise partner
    50 # deb-src http://archive.canonical.com/ubuntu precise partner
    51
    52 ## Uncomment the following two lines to add software from Ubuntu's
    53 ## 'extras' repository.
    54 ## This software is not part of Ubuntu, but is offered by third-party
    55 ## developers who want to ship their latest software.
    56 # deb http://extras.ubuntu.com/ubuntu precise main
    57 # deb-src http://extras.ubuntu.com/ubuntu precise main

/etc/apt/sources.list.d/dropbox.list

     1 deb http://linux.dropbox.com/ubuntu precise main

/etc/apt/sources.list.d/google-talkplugin.list

     1 ### THIS FILE IS AUTOMATICALLY CONFIGURED ###
     2 # You may comment out this entry, but any other modifications may be lost.
     3 deb http://dl.google.com/linux/talkplugin/deb/ stable main

/etc/apt/sources.list.d/ubuntu-defaults.list

     1 deb http://ppa.launchpad.net/ubuntu-defaults-it-team/ubuntu-defaults-it/ubuntu precise main

/etc/apt/sources.list.d/eugenesan-java-precise.list

     1 deb http://ppa.launchpad.net/eugenesan/java/ubuntu precise main
     2 deb-src http://ppa.launchpad.net/eugenesan/java/ubuntu precise main

/etc/apt/sources.list.d/tiheum-equinox-precise.list

     1 deb http://ppa.launchpad.net/tiheum/equinox/ubuntu precise main
     2 deb-src http://ppa.launchpad.net/tiheum/equinox/ubuntu precise main

N1ck 7h0m4d4k15 (nicktux) said : #7

Your system is already broken. You must remove some software (that conficts) in order to fix this issue.

Try this

    sudo apt-get install aptitude
    sudo aptitude update
    sudo aptitude full-upgrade

HIT the Q button to Quit. Do not take any action, but post here the results.

Regards
 NikTh

zzari (alessiomazzarini89) said : #8

Is there a command to translate the terminal?? i can't install anything new as you can say :(

zzari@zzari-laptop:~$ sudo apt-get install aptitude

[sudo] password for zzari:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto

È utile eseguire "apt-get -f install" per correggere questi problemi:
I seguenti pacchetti hanno dipendenze non soddisfatte:
 aptitude : Dipende: libboost-iostreams1.46.1 (>= 1.46.1-1) ma non sta per essere installato
            Dipende: libcwidget3 ma non sta per essere installato
            Dipende: libept1.4.12 ma non sta per essere installato
            Raccomanda: libparse-debianchangelog-perl ma non sta per essere installato
 libgl1-mesa-glx : Dipende: libglapi-mesa (= 8.0.4-0ubuntu0.2)
                   Rompe: libgl1-mesa-glx:i386 (!= 8.0.4-0ubuntu0.2)
 libgl1-mesa-glx:i386 : Rompe: libgl1-mesa-glx (!= 8.0.4-0ubuntu0.5)
E: Dipendenze non soddisfatte. Provare "apt-get -f install" senza pacchetti (o specificare una soluzione).
zzari@zzari-laptop:~$ sudo aptitude update
sudo: aptitude: comando non trovato
zzari@zzari-laptop:~$ sudo aptitude full-upgrade
sudo: aptitude: comando non trovato
zzari@zzari-laptop:~$

N1ck 7h0m4d4k15 (nicktux) said : #9

Try

    LANG=C ; sudo apt-get remove libgl1-mesa-glx:i386

DO NOT ANSWER Yes. Hit n (NO) and post back here the results.

Regards
 NikTh

zzari (alessiomazzarini89) said : #10

I cannot answer NO, beacause it never asks me ;)

root@zzari-laptop:/home/zzari# LANG=C ; sudo apt-get remove libgl1-mesa-glx:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libgl1-mesa-glx : Depends: libglapi-mesa (= 8.0.4-0ubuntu0.2)
 libglu1-mesa:i386 : Depends: libgl1-mesa-glx:i386 or
                              libgl1:i386
 libqt4-opengl:i386 : Depends: libgl1-mesa-glx:i386 or
                               libgl1:i386
 libvisual-0.4-plugins:i386 : Depends: libgl1-mesa-glx:i386 or
                                       libgl1:i386
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Manfred Hampl (m-hampl) said : #11

Try

sudo apt-get install -f libgl1-mesa-glx libgl1-mesa-glx:i386 libqt4-opengl libqt4-opengl:i386

and copy/paste the output into this question document

zzari (alessiomazzarini89) said : #12

here is the output... i Say YES, when it asks me...

zzari@zzari-laptop:~$ LANG=C;sudo apt-get install -f libgl1-mesa-glx libgl1-mesa-glx:i386 libqt4-opengl libqt4-opengl:i386

Reading package lists... Done
Building dependency tree
Reading state information... Done
libqt4-opengl is already the newest version.
libgl1-mesa-glx:i386 is already the newest version.
libgl1-mesa-glx:i386 set to manually installed.
libqt4-opengl:i386 is already the newest version.
libqt4-opengl:i386 set to manually installed.
The following packages will be upgraded:
  libgl1-mesa-glx
1 upgraded, 0 newly installed, 0 to remove and 237 not upgraded.
4 not fully installed or removed.
Need to get 0 B/104 kB of archives.
After this operation, 0 B of additional disk space will be used.

Do you want to continue [Y/n]? y

dpkg: error processing libgl1-mesa-glx (--configure):
 libgl1-mesa-glx:amd64 8.0.4-0ubuntu0.2 cannot be configured because libgl1-mesa-glx:i386 is in a different version (8.0.4-0ubuntu0.5)
dpkg: error processing libgl1-mesa-glx:i386 (--configure):
 libgl1-mesa-glx:i386 8.0.4-0ubuntu0.5 cannot be configured because libgl1-mesa-glx:amd64 is in a different version (8.0.4-0ubuntu0.2)
dpkg: dependency problems prevent configuration of libqt4-opengl:
 libqt4-opengl depends on libgl1-mesa-glx | libgl1; however:
  Package libgl1-mesa-glx is not configured yet.
  Package libgl1 is not installed.
  Package libgl1-mesa-glx:i386 which provides libgl1 is not configured yet.
  Package libgl1-mesa-glx which provides libgl1 is not configured yet.
dpkg: error processing libqt4-opengl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-opengl:i386:
 libqt4-opengl:i386 depends on libgl1-mesa-glx | libgl1; however:
  Package libgl1-mesa-glx:i386 is noNo apport report written because the error message indicates its a followup error from a previous failure.
                                                              t configured yet.
  Package libgl1-mesa-glx:i386 which provides libgl1 is not configured yet.
  Package libgl1-mesa-glx which provides libgl1 is not configured yet.
dpkg: error processing libqt4-opengl:i386 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libgl1-mesa-glx
 libgl1-mesa-glx:i386
 libqt4-opengl
 libqt4-opengl:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)
zzari@zzari-laptop:~$

Manfred Hampl (m-hampl) said : #13

ok, did not work, then try:

sudo dpkg -i /var/cache/apt/archives/libgl1-mesa-glx_8.0.4-0ubuntu0.5_\*.deb
sudo dpkg --configure -a

and copy/paste all outpu as done before.

zzari (alessiomazzarini89) said : #14

root@zzari-laptop:/home/zzari# sudo dpkg -i /var/cache/apt/archives/libgl1-mesa-glx_8.0.4-0ubuntu0.5_\*.deb
dpkg: error processing /var/cache/apt/archives/libgl1-mesa-glx_8.0.4-0ubuntu0.5_*.deb (--install):
 cannot access archive: No such file or directory
Errors were encountered while processing:
 /var/cache/apt/archives/libgl1-mesa-glx_8.0.4-0ubuntu0.5_*.deb
root@zzari-laptop:/home/zzari# sudo dpkg --configure -a
dpkg: error processing libgl1-mesa-glx (--configure):
 libgl1-mesa-glx:amd64 8.0.4-0ubuntu0.2 cannot be configured because libgl1-mesa-glx:i386 is in a different version (8.0.4-0ubuntu0.5)
dpkg: error processing libgl1-mesa-glx:i386 (--configure):
 libgl1-mesa-glx:i386 8.0.4-0ubuntu0.5 cannot be configured because libgl1-mesa-glx:amd64 is in a different version (8.0.4-0ubuntu0.2)
dpkg: dependency problems prevent configuration of libqt4-opengl:
 libqt4-opengl depends on libgl1-mesa-glx | libgl1; however:
  Package libgl1-mesa-glx is not configured yet.
  Package libgl1 is not installed.
  Package libgl1-mesa-glx:i386 which provides libgl1 is not configured yet.
  Package libgl1-mesa-glx which provides libgl1 is not configured yet.
dpkg: error processing libqt4-opengl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-opengl:i386:
 libqt4-opengl:i386 depends on libgl1-mesa-glx | libgl1; however:
  Package libgl1-mesa-glx:i386 is not configured yet.
  Package libgl1-mesa-glx:i386 which provides libgl1 is not configured yet.
  Package libgl1-mesa-glx which provides libgl1 is not configured yet.
dpkg: error processing libqt4-opengl:i386 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libgl1-mesa-glx
 libgl1-mesa-glx:i386
 libqt4-opengl
 libqt4-opengl:i386

Manfred Hampl (m-hampl) said : #15

Seems there was an escape character too much in the command:

sudo dpkg -i /var/cache/apt/archives/libgl1-mesa-glx_8.0.4-0ubuntu0.5_*.deb
sudo dpkg --configure -a

and copy/paste all output as done before.

zzari (alessiomazzarini89) said : #16

root@zzari-laptop:/home/zzari# sudo dpkg -i /var/cache/apt/archives/libgl1-mesa-glx_8.0.4-0ubuntu0.5_*.deb
(Reading database ... 217682 files and directories currently installed.)
Preparing to replace libgl1-mesa-glx 8.0.4-0ubuntu0.2 (using .../libgl1-mesa-glx_8.0.4-0ubuntu0.5_amd64.deb) ...
Unpacking replacement libgl1-mesa-glx ...
Setting up libgl1-mesa-glx (8.0.4-0ubuntu0.5) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
root@zzari-laptop:/home/zzari# sudo dpkg --configure -a
Setting up libgl1-mesa-glx:i386 (8.0.4-0ubuntu0.5) ...
Setting up libqt4-opengl (4:4.8.1-0ubuntu4.4) ...
Setting up libqt4-opengl:i386 (4:4.8.1-0ubuntu4.4) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place

zzari (alessiomazzarini89) said : #17

now seems to work!! thanks so much for the help everyone!!

N1ck 7h0m4d4k15 (nicktux) said : #18

Please mark the answer #15 "This solved my question" for future-help-others with same problem.

Regards
 NikTh

zzari (alessiomazzarini89) said : #19

there is no buttom on the answer #15... there is only in your (NikTh) answers.