upgrade from 10.04 to 12.04 not possible

Asked by Helmut Gerlach on 2013-04-05

The system I try to upgrade is a biolinux6 system which is based on ubuntu 10.04 and where a script is provided to make a two-step upgrade to biolinux7 on ubuntu 12.04. I had several trials for testing the upgrade via the script on virtual machines without any problem.
Normally the script first upgrades the system to the new ubuntu version and in the second step it installs the new packages for biolinux7.
What`s happened was, that after running the script first there was an update of the packages for 10.04, after this the first restart
follows. Then I run the script again and it made a test to the python-version after this result it starts the update-manager to start the upgrade. Normally this works without any problems and the system should have to be restarted again and running the script one time more. But here it stops with two times the waring

Failed to read the mirror file

from the update-manager an information appears that some third-party sources are set inactive which could be activated later.
Than it looks as if the new sources are installed. But instead of finishing this and go on downloading the updated files the information appears that an update was not possible because of the reason that there broken packages are held. But this is the point I am not familiar with and don't now how to go on solving this problem by myself.
Package-Version:

update-manager:
  Installiert: 1:0.134.12.1
  Kandidat: 1:0.134.12.1

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: update-manager 1:0.134.12.1
ProcVersionSignature: Ubuntu 2.6.38-10.46~lucid1-generic 2.6.38.7
Uname: Linux 2.6.38-10-generic x86_64
Architecture: amd64
Date: Fri Apr 5 14:29:25 2013
GConfNonDefault:
 /apps/update-manager/check_new_release_ignore=
 /apps/update-manager/first_run=false
 /apps/update-manager/show_versions=false
 /apps/update-manager/window_size=(749,761)
InstallationMedia: Bio-Linux 6 based on Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=de_DE:en
 PATH=(custom, no user)
 LANG=de_DE.utf8
 SHELL=/bin/zsh
SourcePackage: update-manager
VarLogDistupgradeAptclonesystemstate.tar.gz: Error: [Errno 13] Keine Berechtigung: '/var/log/dist-upgrade/apt-clone_system_state.tar.gz'
VarLogDistupgradeTermlog:

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu update-manager Edit question
Assignee:
No assignee Edit question
Solved by:
Helmut Gerlach
Solved:
2013-04-10
Last query:
2013-04-10
Last reply:
2013-04-09

This question was originally filed as bug #1164988.

Brian Murray (brian-murray) said : #1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs#When%20not%20to%20file%20a%20bug. There is also a vibrant support community available at http://askubuntu.com and you might consider asking your question there.

Dear Brian, thank you for your answer and moving my topic to the question-corner. Unfortunately the colleague who is working with the system got so many crashes with the system after the partitial update, so I decided to setup a new system. Although it would have been a good experience to find the way through the dificulties. So I have to close this question. So thank you for your support.

N1ck 7h0m4d4k15 (nicktux) said : #3

Please mark the question as SOLVED.

Regards
 NikTh

Because of the re-installation of the system the problem is solved