upgrade problem 12.04 to 12.10

Asked by RIZA BAYOGLU on 2013-02-05

I just upgraded from 12.04 to 12.10 version of Ubuntu.

Not suprisingly, my laptop gave me trouble. I have searched through some similar problems here, but problem still exist.

I tried these commands:

sudo apt-get update >>>>>>>>>>>>> it says Fetched 957 kB in 30s (31.6 kB/s)
                                                                      Reading package lists... Done

then tried this one, sudo apt-get upgrade.
It says:
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 ubuntu-artwork : Depends: light-themes but it is not installed
 xserver-xorg-input-vmmouse : Depends: xserver-xorg-input-mouse but it is not installed
 xservez-xorg-input-mouse : Depends: libc6 (= (>= 2.7) but 2.15-0ubuntu20 is installed
E: Unmet dependencies. Try using -f.

Then,

sudo apt-get -f install

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libgtkmm-2.4-1c2a libnss3-1d libreadline5
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  light-themes xserver-xorg-input-mouse
The following packages will be REMOVED:
  xservez-xorg-input-mouse
The following NEW packages will be installed:
  light-themes xserver-xorg-input-mouse
0 upgraded, 2 newly installed, 1 to remove and 2 not upgraded.
241 not fully installed or removed.
Need to get 0 B/333 kB of archives.
After this operation, 898 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
dpkg: warning: parsing file '/var/lib/dpkg/status' near line 28949 package 'xservez-xorg-input-mouse':
 `Depends' field, reference to `libc6':
 implicit exact match on version number, suggest using `=' instead
dpkg: warning: parsing file '/var/lib/dpkg/status' near line 28949 package 'xservez-xorg-input-mouse':
 `Depends' field, reference to `libc6':
 version value starts with non-alphanumeric, suggest adding a space
dpkg: error: parsing file '/var/lib/dpkg/status' near line 28949 package 'xservez-xorg-input-mouse':
 `Depends' field, reference to `libc6': version contains `)'
E: Sub-process /usr/bin/dpkg returned an error

This did not work out either,

 sudo apt-get dist-upgrade

sudo: unable to resolve host rocker
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 ubuntu-artwork : Depends: light-themes but it is not installed
 xserver-xorg-input-vmmouse : Depends: xserver-xorg-input-mouse but it is not installed
 xservez-xorg-input-mouse : Depends: libc6 (= (>= 2.7) but 2.15-0ubuntu20 is installed
E: Unmet dependencies. Try using -f.

What do you suggest at this point? By the way, if I will be okay by going back to 12.04 just tell me please (and how), becase I got sicked of this.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu update-manager Edit question
Assignee:
No assignee Edit question
Last query:
2013-02-05
Last reply:
2013-02-05
Warren Hill (warren-hill) said : #1

Personally I would go back to 12.04 but only because I prefer to stick to Long Term Stable (LTS) releases. They are supported for longer

The easiest way to do that would be to make sure you have a good set of backups; do a clean install and then restore your personal files from the backups.

If you want to use 12.10 however follow the procedure here:

https://help.ubuntu.com/community/PackageManagerTroubleshootingProcedure

Don't open a new question but paste the results back here and we can advise further

RIZA BAYOGLU (r-bayoglu) said : #2

Thanks Warren Hill.
I eventually went back to 12.04. But, there is still something is wrong with my laptop.
When I try to install updates, it says package system is broken. In detail part, these are reported:

The following packages have unmet dependencies:

libc6: Depends: libc-bin (= 2.15-0ubuntu10) but 2.15-0ubuntu10.2 is installed
libc6-dev: Depends: libc6 (= 2.15-0ubuntu10.2) but 2.15-0ubuntu10 is installed
           Depends: libc-dev-bin (= 2.15-0ubuntu10.2) but 2.15-0ubuntu10.2 is installed

Based on the suggestion, I issued this command: sudo apt-get -f install

But, it did not solve the problem either. It gave me this output:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libc-bin libc-dev-bin libc6 libc6-dev
Suggested packages:
  glibc-doc
The following packages will be upgraded:
  libc-bin libc-dev-bin libc6 libc6-dev
4 upgraded, 0 newly installed, 0 to remove and 319 not upgraded.
1 not fully installed or removed.
Need to get 10.2 MB of archives.
After this operation, 18.4 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main libc-dev-bin i386 2.15-0ubuntu10.3 [77.7 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main libc6-dev i386 2.15-0ubuntu10.3 [5,100 kB]
Get:3 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main libc-bin i386 2.15-0ubuntu10.3 [1,131 kB]
Get:4 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main libc6 i386 2.15-0ubuntu10.3 [3,940 kB]
Fetched 10.2 MB in 2min 7s (80.6 kB/s)
Preconfiguring packages ...
(Reading database ... 141438 files and directories currently installed.)
Preparing to replace libc-dev-bin 2.15-0ubuntu10.2 (using .../libc-dev-bin_2.15-0ubuntu10.3_i386.deb) ...
Unpacking replacement libc-dev-bin ...
Preparing to replace libc-bin 2.15-0ubuntu10.2 (using .../libc-bin_2.15-0ubuntu10.3_i386.deb) ...
Unpacking replacement libc-bin ...
Processing triggers for man-db ...
Setting up libc-bin (2.15-0ubuntu10.3) ...
(Reading database ... 141438 files and directories currently installed.)
Preparing to replace libc6 2.15-0ubuntu10 (using .../libc6_2.15-0ubuntu10.3_i386.deb) ...
Unpacking replacement libc6 ...
Setting up libc6 (2.15-0ubuntu10.3) ...
Setting up libc-dev-bin (2.15-0ubuntu10.3) ...
dpkg: dependency problems prevent configuration of libc6-dev:
 libc6-dev depends on libc6 (= 2.15-0ubuntu10.2); however:
  Version of libc6 on system is 2.15-0ubuntu10.3.
 libc6-dev depends on libc-dev-bin (= 2.15-0ubuntu10.2); however:
  Version of libc-dev-bin on system is 2.15-0ubuntu10.3.
dpkg: error processing libc6-dev (--configure):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin ...
No apport report written because MaxReports is reached already
                                                              ldconfig deferred processing now taking place
Errors were encountered while processing:
 libc6-dev
E: Sub-process /usr/bin/dpkg returned an error code (1)

How shall I proceed?

Can you help with this problem?

Provide an answer of your own, or ask RIZA BAYOGLU for more information if necessary.

To post a message you must log in.