An upgrade from 'lisa' to 'oneiric' is not supported with this tool.

Asked by K Israel on 2012-11-28

I cannot use the Synaptic package manager. in terminal, I get: Unable to get exclusive lock
This usually means that another package management application (like apt-get or aptitude) is already running. Please close that application first.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu update-manager Edit question
Assignee:
No assignee Edit question
Last query:
2012-11-28
Last reply:
2012-11-29

Are you using Mint "lisa" ... ?

Robert (deadflowr) said : #2

You can only run one instance of apt at a time.
What this means is either your system was updating, or installing packages, or you had another instance running, like apt-get install program.
Normally, if you wait a moment the program will finish and free it up again.
I don't think the mixing of lisa and oneric repos would cause that error.
I would say though that if it remains in a prolong state, file a bug using the ubuntu-bug package name technique in the terminal.
However, since you have the mint repo I don't know if ubuntu-bug would work, since having the mint repo most likely means you're running mint so...

Warren Hill (warren-hill) said : #3

I would not recommend upgrading to oneiric: support runs out in April. I would definitely go with precise; assuming you want Ubuntu.

Lisa is not Ubuntu, Mint? Its not surprising you can not update. I would recommend a backup then a clean install of the version you want.

Can you help with this problem?

Provide an answer of your own, or ask K Israel for more information if necessary.

To post a message you must log in.