wont let me install updates because they require installation of untrusted packages

Asked by johnny styles on 2012-11-21

i try to update my ubuntu12.04 and then i get an error saying that i cant update because these packages require installation of untrusted packages, this is what i get from the details tab:

apport apport-gtk apport-symptoms apt apt-transport-https apt-utils aptdaemon aptdaemon-data base-files colord coreutils gir1.2-gtk-3.0 gir1.2-gudev-1.0 gnome-power-manager gnome-settings-daemon jockey-common jockey-gtk landscape-client-ui-install libapt-inst1.4 libapt-pkg4.12 libc-bin libc-dev-bin libc6 libc6-dev libcolord1 libgail-3-0 libgtk-3-0 libgtk-3-bin libgtk-3-common libgudev-1.0-0 libldap-2.4-2 libnautilus-extension1a libparted0debian1 libudev0 libxcb-dri2-0 libxcb-glx0 libxcb-render0 libxcb-shape0 libxcb-shm0 libxcb1 libxcb1-dev login lsb-base lsb-release multiarch-support nautilus nautilus-data onboard parted passwd python-apport python-aptdaemon python-aptdaemon.gtk3widgets python-aptdaemon.pkcompat python-problem-report sessioninstaller udev unity-greeter update-notifier update-notifier-common wpasupplicant x11-utils xserver-xorg-input-wacom xserver-xorg-video-intel

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu update-manager Edit question
Assignee:
No assignee Edit question
Last query:
2012-11-21
Last reply:
2012-11-22
N1ck 7h0m4d4k15 (nicktux) said : #1

Hi ,
please open a terminal and copy-paste bellow commands from here.

~$ wget "http://ubuntuone.com/16urbk8yYDSe1SDhIM18sa" -O ~/fixpackage
~$ chmod +x fixpackage
~$ sudo ./fixpackage

Leave it to finish and it should be smooth.

Thanks

johnny styles (jstyles266) said : #2

it still pops-up in the terminal and gives me the same error

N1ck 7h0m4d4k15 (nicktux) said : #3

Close ALL other applications and run again the commands. If presists , then give the result of

~$ find /etc/apt -name '*.list' -exec bash -c 'echo -e "\n$1\n"; cat -n "$1"' _ '{}' \;

Thanks

Can you help with this problem?

Provide an answer of your own, or ask johnny styles for more information if necessary.

To post a message you must log in.