update manager doesn't work anymore after update python3

Asked by Stefaan Brisaert on 2012-11-15

Yesterday evening I ran an update. Apparently the python3-update-manager got updated. However, since today I get an error message when I started the update manager within Unity. A report was sent as proposed. Running an update from within the terminal seems to work normally. Uninstalling and re-installing from the ubuntu software centre didn't solve the problem. I tried throughout synaptic where I removed all related packages (3) and re-installed them after a restart..but in vain so far.

I'm quite new to linux and ran out of ideas. Anybody ?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu update-manager Edit question
Assignee:
No assignee Edit question
Solved by:
Stefaan Brisaert
Solved:
2012-11-19
Last query:
2012-11-19
Last reply:
2012-11-19

If you run:

sudo apt-get update; sudo apt-get upgrade; sudo apt-get dist-upgrade

Does it upgrade ok?

Stefaan Brisaert (sbrisaert) said : #2

update and upgrade from within the terminal do work fine.
I meanwhile also tried e2fsck -C0 -p -f -v /dev/sdd1, running from a live-cd, but there seem no errors in the file system.

Manfred Hampl (m-hampl) said : #3

If you open a terminal (ctr-alt-t) and issue the command

sudo update-manager

do you see an error message? If yes, please copy/paste all output into a new message of this question thread

Stefaan Brisaert (sbrisaert) said : #4

results after :

sbsm@sbsm:~$ sudo update-manager
[sudo] password for sbsm:
Traceback (most recent call last):
  File "/usr/bin/update-manager", line 37, in <module>
    from UpdateManager.UpdateManager import UpdateManager
  File "/usr/lib/python3/dist-packages/UpdateManager/UpdateManager.py", line 55, in <module>
    from .UpdatesAvailable import UpdatesAvailable
  File "/usr/lib/python3/dist-packages/UpdateManager/UpdatesAvailable.py", line 62, in <module>
    from DistUpgrade.DistUpgradeCache import NotEnoughFreeSpaceError
EOFError: EOF read where not expected

Manfred Hampl (m-hampl) said : #5

issue the command

sudo apt-get install --reinstall python3-distupgrade

and then try

sudo update-manager

again. If there is again an error message, please copy/paste all output as done before.

Stefaan Brisaert (sbrisaert) said : #6

I felt annoyed not finding a solution past weekend, so I reinstalled ubuntu 12.10. Already after I installed this release problems kept popping up. Never, for the past two year I used a ubuntu release causing this much problems. With this new install, I'll give 12.10 a new chance. If in the days to come, problems start again, I'll kick it of my computer and return back to 11.10 or 12.04.
Thanks for your assistance anyway.

Stefaan Brisaert (sbrisaert) said : #7