Ubuntu

Cant boot after update, stuck on a loop

Asked by Jonathan Zaiat on 2012-02-17

Hello, today I update my Ubuntu 11.10 to kernel version 3.0.0-16-generic.
After the update I restarted the computer and then I got stucked on a loop right after the initial screen where all the modules are loaded (showing an [OK] text on the right). All I see is the mouse pointer and then it goes back to that screen, and so on.
On some cases, I can see an error that says: "initctl: Event failed".

What should I do?

Thanks in advance,
Jonathan

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu update-manager Edit question
Assignee:
No assignee Edit question
Solved by:
Chris
Solved:
2012-02-18
Last query:
2012-02-18
Last reply:
2012-02-18
Chris (fabricator4) said : #1

I think it might have failed to compile and install the new kernel. Run the previous version of the kernel from the grub menu and see if it starts normally. If so, you should probably remove the install files for the new kernel and try updating again.

Chris

Jonathan Zaiat (jzaiat) said : #2

Hi Chris, thanks for the answer. The previous kernel version doesnt work either... I tried them all and none of them worked.
Any other idea?
Thanks!!
Jonathan

Best Chris (fabricator4) said : #3

It's a bit more serious then. See if you can get to a console. When it appears to have booted as far as it will go, press <alt><F2> and you should get a text screen with a login prompt. Type your username then press enter, then type your password and press enter. There will be no password characters at all echoed to the screen; just type your password and press enter.

If you manager to successfully log in, try running apt-get to update the system and maybe replace whatever was broken removed.

#update the software index
sudo apt-get update

#try to repair any problems with updates
sudo apt-get -f install

#try another update to install any missing packages
sudo apt-get upgrade

Chris

Jonathan Zaiat (jzaiat) said : #4

I couldnt make it work since it didnt recognize my network on the recovery console either! After several attemps to fix that, I tried a more radical approach: reinstalling ubuntu using a livecd... it took me two attemps, the first one killed my video card, and finally a second one solved all the problems!
Anyway, I appreciate your help, thanks a lot!
Have a nice weekend,
Jonathan