Can't download any upgrade: problem with repositories in Ubuntu 11.04 64 bits,

Asked by Daniel Morales Garnica on 2011-12-30

I can't download any upgrade.

This is what the console tells about the bug:

W:Failed to fetch http://ppa.launchpad.net/sevenmachines/flash/ubuntu/dists/natty/main/source/Sources 404 Not Found
, W:Failed to fetch http://ppa.launchpad.net/sevenmachines/flash/ubuntu/dists/natty/main/binary-amd64/Packages 404 Not Found
, E:Some index files failed to download. They have been ignored, or old ones used instead.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu update-manager Edit question
Assignee:
No assignee Edit question
Solved by:
Sam_
Solved:
2011-12-31
Last query:
2011-12-31
Last reply:
2011-12-30
Fabio Marconi (fabiomarconi) said : #1

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Best Sam_ (and-sam) said : #2

Disable sevenmachines ppa which is obsolete since adobe-flash is available from official repos.
Please open software sources third party tab, unmark the ppa and apply the changes.
https://help.ubuntu.com/community/Repositories/Ubuntu#Third-Party_Software_Tab

Chris (fabricator4) said : #3

It's not a bug, it's a problem with the configuration of software sources: specifically some personal PPAs from Launchpad user sevenmachines no long exists. As long as you have the four main sources enable in 'software sources' the machine will still get updates fine.

Open "software sources' from the dash and make sure that in the first tab all of main, universe, restricted and multiverse are enabled. Next go to the 'other software' tab and remove any of the PPAs that are causing problems.

The next tab, updates, controls how and when you will get the updates automatically. You should have at least "important security updates" and "recommended updates" enabled. Pre-release and unsupported updates should probably not be enabled unless you have a good reason to do so. If you have "Release Upgrade" enabled the system will offer to upgrade to 11.10 for you, however I recommend that you download the ISO for CD and upgrade from the installer on the LiveCD if that is what you wish to do.

The reason for personal PPAs to be removed is if they are no longer valid or useful, such as when software contained in them is obsolete or if they have been moved into the main repositories. You might review any other PPAs that you've added to the software sources while you are looking at them.

Chris

Uff thank you Sam, I thought that it was a important problem, sorry for that, I'm a beginner with Ubuntu hehe.
Thanks :)

Ah, Thank you Sam and Chris, in my email I only saw at first that Sam answered me hehe.