update manager, software center, synaptic packages manager and computer janitor cannot open (pls. help)

Asked by z3r0c007 on 2011-11-04

sudo apt-get update
Ign cdrom://Ubuntu 11.10 _Oneiric Ocelot_ - Release i386 (20111012) oneiric InRelease
Ign cdrom://Ubuntu 11.10 _Oneiric Ocelot_ - Release i386 (20111012) oneiric Release.gpg
Ign cdrom://Ubuntu 11.10 _Oneiric Ocelot_ - Release i386 (20111012) oneiric Release
Ign cdrom://Ubuntu 11.10 _Oneiric Ocelot_ - Release i386 (20111012) oneiric/main TranslationIndex
Ign cdrom://Ubuntu 11.10 _Oneiric Ocelot_ - Release i386 (20111012) oneiric/restricted TranslationIndex
Err cdrom://Ubuntu 11.10 _Oneiric Ocelot_ - Release i386 (20111012) oneiric/main i386 Packages
  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
Err cdrom://Ubuntu 11.10 _Oneiric Ocelot_ - Release i386 (20111012) oneiric/restricted i386 Packages
  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
Ign cdrom://Ubuntu 11.10 _Oneiric Ocelot_ - Release i386 (20111012) oneiric/main Translation-en_US
Ign cdrom://Ubuntu 11.10 _Oneiric Ocelot_ - Release i386 (20111012) oneiric/main Translation-en
Ign cdrom://Ubuntu 11.10 _Oneiric Ocelot_ - Release i386 (20111012) oneiric/restricted Translation-en_US
Ign cdrom://Ubuntu 11.10 _Oneiric Ocelot_ - Release i386 (20111012) oneiric/restricted Translation-en
Ign http://extras.ubuntu.com oneiric InRelease
Ign http://es.archive.ubuntu.com oneiric InRelease
Ign http://es.archive.ubuntu.com oneiric-updates InRelease
Ign http://security.ubuntu.com oneiric-security InRelease
Ign http://ppa.launchpad.net oneiric InRelease
Ign http://archive.canonical.com oneiric InRelease
W: Failed to fetch cdrom://Ubuntu 11.10 _Oneiric Ocelot_ - Release i386 (20111012)/dists/oneiric/main/binary-i386/Packages Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs

W: Failed to fetch cdrom://Ubuntu 11.10 _Oneiric Ocelot_ - Release i386 (20111012)/dists/oneiric/restricted/binary-i386/Packages Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs

E: Some index files failed to download. They have been ignored, or old ones used instead.

i used all command like this :

sudo cp -arf /var/lib/dpkg /var/lib/dpkg.backup
sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status
sudo cp /var/lib/dpkg/available-old /var/lib/dpkg/available
sudo rm -rf /var/lib/dpkg/updates/*; sudo rm -rf /var/lib/apt/lists
sudo mkdir /var/lib/apt/lists; sudo mkdir /var/lib/apt/lists/partial
sudo apt-get clean; sudo apt-get autoclean
sudo apt-get update
sudo dpkg --clear-avail; sudo dpkg --configure -a
sudo apt-get install -f
sudo apt-get update
sudo apt-get dist-upgrade

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu update-manager Edit question
Assignee:
No assignee Edit question
Solved by:
z3r0c007
Solved:
2011-11-05
Last query:
2011-11-05
Last reply:
2011-11-04

Try to do this:
1. Open a terminal by hitting CTRL + ALT + T
2. Insert and run this command:
software-properties-gtk

3. In the opened window, in the first tab, uncheck the installation of package from the CD-ROM. Then close.

4. Try to update now.

mycae (mycae) said : #2

Use "software sources" to remove the CD from your list of package sources.

z3r0c007 (kimchloekc) said : #3

while using this software-properties-gtk i have some errors:

~$>software-properties-gtk
Traceback (most recent call last):
  File "/usr/bin/software-properties-gtk", line 25, in <module>
    from gi.repository import Gtk
  File "/usr/lib/python2.7/dist-packages/gi/importer.py", line 76, in load_module
    dynamic_module._load()
  File "/usr/lib/python2.7/dist-packages/gi/module.py", line 224, in _load
    overrides_modules = __import__('gi.overrides', fromlist=[self._namespace])
  File "/usr/lib/python2.7/dist-packages/gi/overrides/Gtk.py", line 523, in <module>
    class FontSelectionDialog(Gtk.FontSelectionDialog, Dialog):
  File "/usr/lib/python2.7/dist-packages/gi/module.py", line 105, in __getattr__
    self.__name__, name))
AttributeError: 'gi.repository.Gtk' object has no attribute 'FontSelectionDialog'

How have you installed this version of Ubuntu?

Do alredy this:
1. Open a terminal
2. Insert this command:
cat /etc/apt/sources.list -n

3. Copy and paste here the result.

z3r0c007 (kimchloekc) said : #5

HERE ARE THE RESULT using cat /etc/apt/sources.list -n

     1 # deb cdrom:[Ubuntu 10.10 _Maverick Meerkat_ - Release i386 (20101007)]/ maverick main restricted
     2 # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
     3 # newer versions of the distribution.
     4
     5 deb cdrom:[Ubuntu 11.10 _Oneiric Ocelot_ - Release i386 (20111012)]/ oneiric main restricted
     6 deb http://es.archive.ubuntu.com/ubuntu/ oneiric main restricted
     7 deb-src http://es.archive.ubuntu.com/ubuntu/ oneiric main restricted
     8
     9 ## Major bug fix updates produced after the final release of the
    10 ## distribution.
    11 deb http://es.archive.ubuntu.com/ubuntu/ oneiric-updates main restricted
    12 deb-src http://es.archive.ubuntu.com/ubuntu/ oneiric-updates main restricted
    13
    14 ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    15 ## team. Also, please note that software in universe WILL NOT receive any
    16 ## review or updates from the Ubuntu security team.
    17 deb http://es.archive.ubuntu.com/ubuntu/ oneiric universe
    18 deb-src http://es.archive.ubuntu.com/ubuntu/ oneiric universe
    19 deb http://es.archive.ubuntu.com/ubuntu/ oneiric-updates universe
    20 deb-src http://es.archive.ubuntu.com/ubuntu/ oneiric-updates universe
    21
    22 ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    23 ## team, and may not be under a free licence. Please satisfy yourself as to
    24 ## your rights to use the software. Also, please note that software in
    25 ## multiverse WILL NOT receive any review or updates from the Ubuntu
    26 ## security team.
    27 deb http://es.archive.ubuntu.com/ubuntu/ oneiric multiverse
    28 deb-src http://es.archive.ubuntu.com/ubuntu/ oneiric multiverse
    29 deb http://es.archive.ubuntu.com/ubuntu/ oneiric-updates multiverse
    30 deb-src http://es.archive.ubuntu.com/ubuntu/ oneiric-updates multiverse
    31
    32 ## Uncomment the following two lines to add software from the 'backports'
    33 ## repository.
    34 ## N.B. software from this repository may not have been tested as
    35 ## extensively as that contained in the main release, although it includes
    36 ## newer versions of some applications which may provide useful features.
    37 ## Also, please note that software in backports WILL NOT receive any review
    38 ## or updates from the Ubuntu security team.
    39 # deb http://es.archive.ubuntu.com/ubuntu/ maverick-backports main restricted universe multiverse
    40 # deb-src http://es.archive.ubuntu.com/ubuntu/ maverick-backports main restricted universe multiverse
    41
    42 ## Uncomment the following two lines to add software from Canonical's
    43 ## 'partner' repository.
    44 ## This software is not part of Ubuntu, but is offered by Canonical and the
    45 ## respective vendors as a service to Ubuntu users.
    46 # deb http://archive.canonical.com/ubuntu maverick partner
    47 # deb-src http://archive.canonical.com/ubuntu maverick partner
    48
    49 ## This software is not part of Ubuntu, but is offered by third-party
    50 ## developers who want to ship their latest software.
    51 deb http://extras.ubuntu.com/ubuntu oneiric main
    52 deb-src http://extras.ubuntu.com/ubuntu oneiric main
    53
    54 deb http://security.ubuntu.com/ubuntu oneiric-security main restricted
    55 deb-src http://security.ubuntu.com/ubuntu oneiric-security main restricted
    56 deb http://security.ubuntu.com/ubuntu oneiric-security universe
    57 deb-src http://security.ubuntu.com/ubuntu oneiric-security universe
    58 deb http://security.ubuntu.com/ubuntu oneiric-security multiverse
    59 deb-src http://security.ubuntu.com/ubuntu oneiric-security multiverse
    60

cntraviata (shenglizhezhe) said : #6

I also met this problem.

Traceback (most recent call last):
  File "/usr/bin/update-manager", line 26, in <module>
    from gi.repository import Gtk
  File "/usr/lib/python2.7/dist-packages/gi/importer.py", line 76, in load_module
    dynamic_module._load()
  File "/usr/lib/python2.7/dist-packages/gi/module.py", line 224, in _load
    overrides_modules = __import__('gi.overrides', fromlist=[self._namespace])
  File "/usr/lib/python2.7/dist-packages/gi/overrides/Gtk.py", line 523, in <module>
    class FontSelectionDialog(Gtk.FontSelectionDialog, Dialog):
  File "/usr/lib/python2.7/dist-packages/gi/module.py", line 105, in __getattr__
    self.__name__, name))
AttributeError: 'gi.repository.Gtk' object has no attribute 'FontSelectionDialog'

z3r0c007 (kimchloekc) said : #7

any one can help my problem

Have you done what mycae suggested? Please remove CD-ROM from Software Sources then run 'sudo apt-get update'.

z3r0c007 (kimchloekc) said : #9

i can't open software source and update manager any more solution...

i try it already the command sudo apt-get update but nothing's happened

z3r0c007 (kimchloekc) said : #10

and i can't open also my ubuntu software center

any one help me pls

z3r0c007 (kimchloekc) said : #11

THANKS to all of you i resolved the problem thanks here's the command that i used:

sudo rm -vf /var/cache/apt/*.bin
sudo aptitude update
sudo aptitude full-upgrade

sudo apt-get update

or

sudo apt-get install -f
sudo dpkg --configure -a
sudo apt-get update

but it's better to used the first one

JJNR (obiguanquenove) said : #12

Still does not work for me.

"

jj@enanoblanco:~$ sudo update-manager
Traceback (most recent call last):
  File "/usr/bin/update-manager", line 26, in <module>
    from gi.repository import Gtk
ImportError: No module named gi.repository

"

Any clues... I did not find anthing to solve this.... well, in fact i found many things, but none of them worked for me.

I am on ubuntu 12.04.