11.10 upgrade fails with dpkg: error: unknown option 'foreign-architecture'

Asked by Benjamin Rubinger on 2011-10-14

I am upgrading from 11.04 to 11.10. In the "Installing the upgrades" step, the upgrade fails with "Could not install the upgrades. The upgrade has aborted. Your system could be in an unusable state." The errors show up in the distribution upgrade UI as:

E:Sub-process /usr/bin/dpkg returned an error code (2), E:Sub-process /usr/bin/dpkg returned an error code (2), ... (repeated many times)

/var/log/dist-upgrade/apt-term.log shows a slightly more specific error (many times):

dpkg: error: configuration error: /etc/dpkg/dpkg.cfg.d/multiarch:1: unknown option 'foreign-architecture'

I attempted to remove 'user installed' packages in synaptic, but synaptic fails with the same dpkg error. Loading update manager, I receive this error in the UI:

Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade.

Please report this bug against the 'update-manager' package and include the following error message:
'E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.'

/var/log/dist-upgrade/apt.log has

...
  Installing gir1.2-rb-3.0 as Depends of rhythmbox-plugins
  Installing distro-info as Depends of ubuntu-dev-tools
  new important dependency: python-mmkeys
  Installing python-mmkeys as Recommends of quodlibet
  Installing gtk3-engines-unico as Depends of light-themes
  Installing gir1.2-cogl-1.0 as Depends of gir1.2-clutter-1.0
  Installing gir1.2-json-1.0 as Depends of gir1.2-clutter-1.0
  Installing libexporter-lite-perl as Depends of libparse-debcontrol-perl
  new important dependency: libgphoto2-l10n
  Installing libgphoto2-l10n as Recommends of libgphoto2-2
Starting
Starting 2
Investigating (0) python2.7 [ amd64 ] < 2.7.1-5ubuntu2 -> 2.7.2-5ubuntu1 > ( python )
Broken python2.7:amd64 Conflicts on python-profiler [ amd64 ] < 2.6.6-0ubuntu1 > ( multiverse/python ) (<= 2.7.1-2)
  Considering python-profiler:amd64 0 as a solution to python2.7:amd64 1161
  Added python-profiler:amd64 to the remove list
  Fixing python2.7:amd64 via remove of python-profiler:amd64
Investigating (0) libdbusmenu-glib4 [ amd64 ] < none -> 0.5.0-0ubuntu3 > ( libs )
Broken libdbusmenu-glib4:amd64 Breaks on gir1.2-unity-3.0 [ amd64 ] < 3.8.4-0ubuntu1 > ( libs ) (< 3.8.4-0ubuntu2)
  Considering gir1.2-unity-3.0:amd64 5 as a solution to libdbusmenu-glib4:amd64 85
  Added gir1.2-unity-3.0:amd64 to the remove list
  Fixing libdbusmenu-glib4:amd64 via remove of gir1.2-unity-3.0:amd64
Investigating (0) gvfs [ amd64 ] < 1.8.0-0ubuntu3 -> 1.10.0-0ubuntu1 > ( libs )
Broken gvfs:amd64 Conflicts on libgvfscommon0 [ amd64 ] < 1.8.0-0ubuntu3 > ( libs )
  Considering libgvfscommon0:amd64 -1 as a solution to gvfs:amd64 75
  Added libgvfscommon0:amd64 to the remove list
  Fixing gvfs:amd64 via remove of libgvfscommon0:amd64
Investigating (0) libjack-jackd2-0 [ amd64 ] < none -> 1.9.7~dfsg-1ubuntu2 > ( libs )
...
Investigating (2) libpulse-browse0 [ amd64 ] < 1:0.9.22+stable-queue-24-g67d18-0ubuntu3.1 > ( sound )
Broken libpulse-browse0:amd64 Depends on libpulse0 [ amd64 ] < 1:0.9.22+stable-queue-24-g67d18-0ubuntu3.1 -> 1:1.0-0ubuntu3 > ( libs ) (= 1:0.9.22+stable-queue-24-g67d18-0ubuntu3.1)
  Considering libpulse0:amd64 119 as a solution to libpulse-browse0:amd64 5
  Removing libpulse-browse0:amd64 rather than change libpulse0:amd64
 Try to Re-Instate (2) flashplugin-installer:amd64
Investigating (3) indicator-applet [ amd64 ] < 0.4.12-0ubuntu1 > ( gnome )
Broken indicator-applet:amd64 Depends on gnome-panel [ amd64 ] < 1:2.32.1-0ubuntu6.5 -> 1:3.2.0-0ubuntu1 > ( universe/gnome )
  Considering gnome-panel:amd64 20 as a solution to indicator-applet:amd64 20
  Removing indicator-applet:amd64 rather than change gnome-panel:amd64
Investigating (3) padevchooser [ amd64 ] < 0.9.3-2ubuntu4 > ( sound )
Broken padevchooser:amd64 Depends on libpulse-browse0 [ amd64 ] < 1:0.9.22+stable-queue-24-g67d18-0ubuntu3.1 > ( sound ) (>= 0.9.8)
  Considering libpulse-browse0:amd64 119 as a solution to padevchooser:amd64 5
  Removing padevchooser:amd64 rather than change libpulse-browse0:amd64
Done
dpkg: error: configuration error: /etc/dpkg/dpkg.cfg.d/multiarch:1: unknown option 'foreign-architecture'
.: 19: Can't open base-installer/kernel/.sh
  Installing evince as Depends of ubuntu-desktop
  Setting NOT as auto-installed (direct Depends of pkg in APT::Never-MarkAuto-Sections)
    Installing libevince3-3 as Depends of evince
(end of log)

I would like to complete the upgrade to 11.10 without errors. Any suggestions?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu update-manager Edit question
Assignee:
No assignee Edit question
Solved by:
Benjamin Rubinger
Solved:
2011-10-16
Last query:
2011-10-16
Last reply:
2011-10-15
Sam_ (and-sam) said : #1

Open the file via terminal:
gksudo gedit /etc/dpkg/dpkg.cfg.d/multiarch

Insert only in the first line (rest of file is empty):
foreign-architecture i386

Save the file.
Run:
sudo dpkg --configure -a
sudo apt-get update
sudo apt-get upgrade

Any errors?

Reference.
http://wiki.debian.org/Multiarch/Implementation
https://lists.ubuntu.com/archives/ubuntu-devel-announce/2011-August/000886.html
https://lists.ubuntu.com/archives/ubuntu-devel/2011-March/032750.html

Just in case, deactivate third party repos, make sure Natty is fully up-to-date.
https://help.ubuntu.com/community/Repositories/Ubuntu#Third-Party_Software_Tab

Thank you for the reply!

I opened that file, and found the line you asked me to add was already there. I continue to get the same error.

~$ cat /etc/dpkg/dpkg.cfg.d/multiarch
foreign-architecture i386
~$ sudo dpkg --configure -a
dpkg: error: configuration error: /etc/dpkg/dpkg.cfg.d/multiarch:1: unknown option 'foreign-architecture'
~$

sudo apt-get update completed, and I am running sudo apt-get upgrade right now. It will be downloading items for some time, but I suspect that will still lead to the same result, since I haven't changed anything. Currently, my repositories are only set to the official Canonical Oneiric ones due to the partially completed upgrade.

sudo apt-get upgrade did crash out wit this message:
E: Could not perform immediate configuration on 'util-linux'. Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)

These seem to be the relevant parts of the terminal output:

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  acroread aisleriot alsa-utils apache2 apache2-mpm-worker apache2-utils apache2.2-bin apache2.2-common appmenu-gtk apport-gtk apt apt-transport-https apt-utils aptdaemon aptitude apturl apturl-common aspectj at-spi audacity audacity-data bamfdaemon banshee
  banshee-extension-soundmenu banshee-extension-ubuntuonemusicstore baobab bind9-host binutils blender bogofilter-bdb brasero brasero-cdrkit brasero-common brltty brltty-x11 ca-certificates cdrdao checkbox checkbox-gtk chromium-browser chromium-browser-l10n cmake
  cmake-curses-gui cmake-data compiz compiz-core compiz-gnome compiz-plugins compiz-plugins-extra compiz-plugins-main compizconfig-backend-gconf computer-janitor computer-janitor-gtk console-setup couchdb-bin cpp cpp-4.4 cpp-4.5 cups cups-bsd cups-client dconf-tools
  devscripts dnsutils doc-base eclipse eclipse-jdt eclipse-pde eclipse-platform eclipse-platform-data eclipse-rcp empathy empathy-common enblend enfuse eog erlang-base erlang-crypto erlang-inets erlang-mnesia erlang-public-key erlang-runtime-tools erlang-ssl
  erlang-syntax-tools erlang-xmerl esound-common evince evince-common evolution evolution-common evolution-couchdb evolution-data-server evolution-data-server-common evolution-exchange evolution-indicator evolution-plugins evolution-webcal exfalso f-spot ffmpeg
  ffmpeg2theora file-roller filezilla filezilla-common firefox firefox-globalmenu flashplugin-installer foo2zjs foomatic-db-compressed-ppds foomatic-db-engine g++ g++-4.5 gawk gbrainy gcalctool gcc gcc-4.4 gcc-4.4-base gcc-4.5 gcc-4.5-base gcj-4.5-jre-lib gconf-editor
  gdebi gdebi-core gdm gedit gedit-common gedit-plugins geoclue-ubuntu-geoip gir1.2-appindicator-0.1 gir1.2-clutter-1.0 gir1.2-dbusmenu-glib-0.4 gir1.2-freedesktop gir1.2-glib-2.0 gir1.2-gnomegamessupport-1.0 gitg glchess glib-networking glines gnect gnibbles gnobots2
  gnome-applets gnome-applets-data gnome-bluetooth gnome-control-center gnome-dictionary gnome-disk-utility gnome-games gnome-games-common gnome-icon-theme gnome-keyring gnome-mahjongg gnome-media gnome-nettool gnome-orca gnome-panel gnome-panel-data gnome-power-manager
  gnome-screensaver gnome-screenshot gnome-search-tool gnome-session gnome-session-bin gnome-session-canberra gnome-session-common gnome-settings-daemon gnome-subtitles gnome-sudoku gnome-system-log gnome-system-monitor gnome-system-tools gnome-terminal
  gnome-terminal-data gnome-user-share gnome-utils-common gnomine gnotravex gnotski gnucash gsettings-desktop-schemas gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad gstreamer0.10-plugins-good gstreamer0.10-plugins-ugly gstreamer0.10-pulseaudio gtali gtk2-engines-pixbuf
  gucharmap guile-1.8-libs gvfs gvfs-backends gvfs-bin gvfs-fuse gwibber gwibber-service hedgewars hugin hugin-data hugin-tools ia32-libs iagno ibus ibus-gtk ibus-m17n ibus-pinyin ibus-pinyin-db-open-phrase icedtea-6-jre-cacao icedtea-6-jre-jamvm icedtea-netx
  icedtea-plugin indicator-application indicator-appmenu indicator-datetime indicator-messages indicator-session indicator-sound info inkscape iproute iputils-ping jlint jockey-common jockey-gtk krb5-multidev language-selector-common language-selector-gnome lftp
  lib32asound2 lib32gcc1 lib32ncurses5 lib32ncursesw5 lib32stdc++6 libalgorithm-diff-xs-perl libapparmor-perl libappindicator0.1-cil libappindicator1 libaprutil1 libaprutil1-dbd-sqlite3 libaprutil1-ldap libapt-pkg-perl libaqbanking-plugins-libgwenhywfar60 libaqbanking33
  libaqbanking33-plugins libaqofxconnect7 libart2.0-cil libasound2 libasound2-dev libasound2-plugins libavcodec-dev libavdevice-dev libavfilter-dev libavformat-dev libavutil-dev libbamf0 libbind9-60 libc-bin libc-dev-bin libc6 libc6-dev libc6-i386 libcairo-perl
  libcanberra-pulse libcanberra0 libcloog-ppl0 libclutter-1.0-0 libcompizconfig0 libcompress-raw-bzip2-perl libcompress-raw-zlib-perl libcouchdb-glib-1.0-2 libcrypt-ssleay-perl libcups2 libcups2-dev libcupsmime1 libcurl3 libcurl3-gnutls libcwidget3 libdaemons-ruby1.8
  libdbd-mysql-perl libdbi-perl libdecoration0 libdigest-sha1-perl libdns69 libept1 libequinox-osgi-java libesd0 libesd0-dev libevolution libflickrnet2.2-cil libgadu3 libgail-common libgail18 libgcc1 libgcj-bc libgcj11 libgconf2.0-cil libgdata1.7-cil libgdict-1.0-6
  libgdu-gtk0 libgfortran3 libggz2 libgirepository-1.0-1 libgkeyfile1.0-cil libgl1-mesa-dev libgl1-mesa-dri libgl1-mesa-glx libglade2.0-cil libglib-perl libglib2.0-0 libglib2.0-bin libglib2.0-cil libglib2.0-dev libglibmm-2.4-1c2a libgmime2.4-cil libgmpxx4ldbl
  libgnome-bluetooth8 libgnome-keyring0 libgnome-keyring1.0-cil libgnome-vfs2.0-cil libgnome2-canvas-perl libgnome2-perl libgnome2-vfs-perl libgnome2.24-cil libgnomekbd-common libgnomevfs2-0 libgnutls-dev libgnutls26 libgoffice-0.8-8 libgomp1 libgssapi-krb5-2 libgssrpc4
  libgtk-sharp-beans-cil libgtk-vnc-1.0-0 libgtk2-perl libgtk2.0-0 libgtk2.0-bin libgtk2.0-cil libgtkmm-2.4-1c2a libgucharmap7 libgudev1.0-cil libgwenhywfar60 libhtml-parser-perl libindicate5 libio-compress-perl libio-pty-perl libisc62 libisccfg62 libisofs6
  libjson-xs-perl libk5crypto3 libkrb5-3 libkrb5-dev libkrb5support0 liblapack3gf liblaunchpad-integration1.0-cil libldap-2.4-2 liblocale-gettext-perl liblog4r-ruby1.8 liblucene2-java liblwres60 libmagick++3 libmission-control-plugins0 libmono-addins-gui0.2-cil
  libmono-addins0.2-cil libmono-corlib2.0-cil libmono-data-tds2.0-cil libmono-i18n2.0-cil libmono-management2.0-cil libmono-messaging2.0-cil libmono-posix2.0-cil libmono-security2.0-cil libmono-sharpzip2.84-cil libmono-simd2.0-cil libmono-sqlite2.0-cil
  libmono-system-data-linq2.0-cil libmono-system-data2.0-cil libmono-system-messaging2.0-cil libmono-system-web2.0-cil libmono-system2.0-cil libmono-wcf3.0-cil libmono-zeroconf1.0-cil libmono2.0-cil libmpc2 libmpfr4 libmusicbrainz4c2a libnautilus-extension1
  libncurses-ruby1.8 libncurses5 libncurses5-dev libncursesw5 libndesk-dbus-glib1.0-cil libndesk-dbus1.0-cil libneon27 libneon27-gnutls libnet-dbus-perl libnet-dns-perl libnm-glib-vpn1 libnotify0.4-cil libpam-modules libpam-modules-bin libpango-perl
  libparse-debcontrol-perl libphonon4 libplymouth2 libpq5 libprojectm-dev libprojectm2 libpt-1.10.10 libpulse-dev libpulse-mainloop-glib0 libpulse0 libpurple0 libpython2.6 libpython2.7 libqt4-dbus libqt4-declarative libqt4-designer libqt4-dev libqt4-help libqt4-network
  libqt4-opengl libqt4-opengl-dev libqt4-qt3support libqt4-script libqt4-scripttools libqt4-sql libqt4-sql-mysql libqt4-sql-sqlite libqt4-svg libqt4-test libqt4-xml libqt4-xmlpatterns libqtcore4 libqtgui4 librdf0 libreadline5 libreadline6 libred5-java
  libreoffice-base-core libreoffice-calc libreoffice-common libreoffice-core libreoffice-draw libreoffice-gnome libreoffice-gtk libreoffice-impress libreoffice-math libreoffice-style-galaxy libreoffice-writer librsvg2-2 librsvg2-common librtmp0 libruby1.8 libsasl2-2
  libsasl2-modules libsigc++-2.0-0c2a libsmbios2 libsnmp15 libsox-fmt-ffmpeg libsqlite3-ruby1.8 libssl-dev libssl0.9.8 libstartup-notification0 libstdc++6 libstdc++6-4.5-dev libstruts1.2-java libsub-name-perl libsyncdaemon-1.0-1 libtag1-vanilla libtag1c2a
  libtaglib2.0-cil libtelepathy-logger2 libterm-readkey-perl libterm-size-perl libtext-charwidth-perl libtext-format-ruby libtext-format-ruby1.8 libtext-iconv-perl libubuntuone-1.0-1 libubuntuone1.0-cil libuuid-perl libv4l-0 libvte-common libvte9 libwpd-0.9-9
  libwps-0.2-2 libwvstreams4.6-extras libwww-perl libxapian22 libxine1 libxine1-bin libxine1-console libxine1-ffmpeg libxine1-misc-plugins libxine1-x libxml++2.6-2 libxml-libxml-perl libxml-parser-perl libyaml-syck-perl light-themes linux-generic linux-headers-generic
  linux-image-generic lmms lmms-common lynx-cur menu mesa-common-dev mono-2.0-gac mono-csharp-shell mono-gac mono-gmcs mono-runtime mount mousetweaks mplayer mumble museekd musetup-gtk mysql-admin mysql-gui-tools-common mysql-query-browser nautilus nautilus-data
  nautilus-sendto nautilus-sendto-empathy nautilus-share ncurses-bin network-manager network-manager-gnome network-manager-pptp network-manager-pptp-gnome nmap notification-daemon notify-osd nspluginwrapper ntfs-3g openjdk-6-jdk openjdk-6-jre openjdk-6-jre-headless
  openjdk-6-jre-lib openoffice.org-thesaurus-en-au openprinting-ppds openssh-client openssl overlay-scrollbar parted pavucontrol pdftk performous perl perl-base perl-modules perlmagick phonon picard pidgin pidgin-data pidgin-libnotify plymouth plymouth-label
  plymouth-x11 postfix postgresql postgresql-8.4 postgresql-client-8.4 postgresql-contrib postgresql-contrib-8.4 postgresql-doc protobuf-compiler pulseaudio pulseaudio-esound-compat pulseaudio-module-bluetooth pulseaudio-module-gconf pulseaudio-module-x11
  pulseaudio-module-zeroconf pulseaudio-utils python python-appindicator python-apt python-aptdaemon python-aptdaemon-gtk python-aptdaemon.gtk3widgets python-aptdaemon.gtkwidgets python-crypto python-dev python-gconf python-glade2 python-gnome2 python-gobject
  python-gtk2 python-gtkglext1 python-ibus python-indicate python-minimal python-openssl python-protobuf python-pyatspi python-pycurl python-scipy python-ubuntuone python-ubuntuone-client python-ubuntuone-control-panel python-uno python-vte python-xapian python2.6
  python2.6-minimal python2.7 python2.7-dev python2.7-minimal qt4-qmake quadrapassel quodlibet rdesktop rhino rhythmbox rhythmbox-plugin-cdrecorder rhythmbox-plugins rss-glx ruby ruby-tmail ruby1.8 ruby1.8-dev sat4j scim scim-bridge-agent seahorse seed shotwell
  simple-scan software-center software-properties-gtk synaptic sysinfo tcpdump telepathy-gabble telepathy-idle telepathy-logger telepathy-mission-control-5 telepathy-salut thunderbird thunderbird-globalmenu thunderbird-locale-en-gb thunderbird-locale-en-us timidity
  timidity-daemon tomboy totem totem-common totem-mozilla totem-plugins tracker tracker-extract tracker-gui tracker-miner-evolution tracker-miner-fs tracker-utils transmission-common transmission-gtk ttf-arabeyes ubuntu-desktop ubuntu-dev-tools ubuntuone-client
  ubuntuone-client-gnome ubuntuone-control-panel ubuntuone-control-panel-gtk unity unity-common unity-place-applications unity-place-files update-manager update-manager-core update-notifier update-notifier-common upower usb-creator-common usb-creator-gtk vim vim-common
  vim-runtime vim-tiny vinagre vino vlc vlc-nox vlc-plugin-notify vlc-plugin-pulse w3m wget wine wine1.2 wireshark wireshark-common wpasupplicant x264 xserver-xorg-core xserver-xorg-video-intel yelp zenity
The following packages will be upgraded:
  acl acpi acpid alacarte alsa-base alsa-oss ant ant-optional anthy anthy-common antlr app-install-data app-install-data-commercial app-install-data-partner apparmor apparmor-utils appmenu-qt apport apport-symptoms apt-xapian-index aptdaemon-data aspell-en at autoconf
  autotools-dev avahi-autoipd avahi-daemon avahi-utils base-files base-passwd bash bash-completion binfmt-support bluetooth bluez bluez-alsa bluez-cups bluez-gstreamer bluez-utils bogofilter bogofilter-common bsdmainutils bsdutils busybox-initramfs busybox-static bzr
  bzr-builddeb bzr-dbus bzr-doc bzr-email bzr-gtk bzr-pipeline bzr-pqm bzr-search bzrtools ca-certificates-java cabextract checkinstall chromium-codecs-ffmpeg cli-common command-not-found command-not-found-data compiz-fusion-plugins-extra compiz-fusion-plugins-main
  compizconfig-settings-manager conky conky-all consolekit cron cups-common cups-driver-gutenprint cups-ppdc cupsddk dash dbus dbus-x11 dctrl-tools debconf debconf-i18n debian-keyring debianutils debootstrap default-jdk default-jre default-jre-headless
  desktop-file-utils desktopcouch dhcp3-client dhcp3-common dictionaries-common dkms dmsetup dnsmasq-base dosfstools dput dvd+rw-tools ecryptfs-utils eject enigmail espeak espeak-data example-content fakeroot file firefox-gnome-support firefox-locale-en
  firefox-locale-ja fontconfig fontconfig-config foomatic-filters fop friendly-recovery ftgl-dev ftp fuse-utils gamin gcj-4.5-base gconf-defaults-service gconf2 gconf2-common gdb gdm-guest-session geoclue geoip-database ggzcore-bin ghostscript ghostscript-cups
  ghostscript-x gimp gimp-data gimp-help-common gimp-help-en gir1.2-atk-1.0 gir1.2-dee-0.5 gir1.2-gconf-2.0 gir1.2-gdkpixbuf-2.0 gir1.2-gstreamer-0.10 gir1.2-gtk-2.0 gir1.2-notify-0.7 gir1.2-pango-1.0 gir1.2-soup-2.4 git git-core git-doc git-man glassfish-javaee
  gnome-accessibility-themes gnome-alsamixer gnome-codec-install gnome-doc-utils gnome-menus gnome-user-guide gnome-utils gnucash-common graphviz grep groff-base groovy growisofs grub grub-common gsfonts-x11 gstreamer0.10-alsa gstreamer0.10-gnomevfs
  gstreamer0.10-gnonlin gstreamer0.10-plugins-base gstreamer0.10-plugins-base-apps gstreamer0.10-tools gstreamer0.10-x guile-1.6 guile-1.6-libs guile-1.6-slib gwibber-service-facebook gwibber-service-identica gwibber-service-twitter hal hddtemp hdparm hedgewars-data
  hostname hpijs hplip hplip-cups hplip-data human-theme humanity-icon-theme hunspell-en-ca hunspell-en-us hwdata hwtest hwtest-gtk ibus-anthy ibus-pinyin-db-android ibus-table icoutils ifupdown im-switch imagemagick initramfs-tools initramfs-tools-bin initscripts
  inputattach insserv install-info iotop iputils-arping iputils-tracepath isc-dhcp-client isc-dhcp-common iso-codes ivy jarwrapper java-common java-wrappers kbd kerneloops-daemon keyboard-configuration keyutils klibc-utils language-pack-en language-pack-en-base
  language-pack-gnome-en language-pack-gnome-en-base language-pack-gnome-ja language-pack-gnome-ja-base language-pack-ja language-pack-ja-base language-pack-kde-en language-pack-kde-en-base language-pack-kde-ja language-pack-kde-ja-base language-selector
  launchpad-integration less liba52-0.7.4 libaccess-bridge-java libaccess-bridge-java-jni libacl1 libactionmailer-ruby libactionmailer-ruby1.8 libactionpack-ruby libactionpack-ruby1.8 libactiverecord-ruby1.8 libactiveresource-ruby libactiveresource-ruby1.8
  libactivesupport-ruby libactivesupport-ruby1.8 libalut0 libamd2.2.0 libanthy0 libantlr-java libao-common libao4 libapache2-mod-wsgi libapparmor1 libapr1 libaqbanking-data libasm3-java libass4 libatk1.0-0 libatk1.0-data libatkmm-1.6-1 libatspi1.0-0 libattr1
  libaudio-dev libaudio2 libavahi-client-dev libavahi-client3 libavahi-common-data libavahi-common-dev libavahi-common3 libavahi-compat-libdnssd1 libavahi-core7 libavahi-glib1 libavahi-gobject0 libavahi-ui0 libaxis-java libbcprov-java libblas3gf libblkid1 libbluetooth3
  libbrlapi0.5 libbsd0 libburn4 libc-ares2 libcaca-dev libcaca0 libcairo-gobject2 libcairo2 libcairomm-1.0-1 libcanberra-gtk-module libcanberra-gtk0 libcap-ng0 libcap2 libcap2-bin libcdaudio1 libcdt4 libcglib-java libcgraph5 libck-connector0 libclutter-1.0-common
  libcolamd2.7.1 libcommon-sense-perl libcommons-codec-java libcommons-collections-java libcommons-collections3-java libcommons-httpclient-java libcommons-pool-java libcompress-zlib-perl libcupscgi1 libcupsdriver1 libcupsimage2 libcupsppdc1 libdate-manip-perl libdatrie1
  libdb4.7 libdb4.8 libdbus-1-3 libdbus-1-dev libdbus-glib-1-2 libdbusmenu-qt2 libdc1394-22 libdca0 libdconf0 libdee-1.0-1 libdesktopcouch-glib-1.0-2 libdevel-symdump-perl libdevmapper-event1.02.1 libdevmapper1.02.1 libdigest-hmac-perl libdirac-encoder0
  libdirectfb-1.2-9 libdiscid0 libdjvulibre-text libdjvulibre21 libdrm-dev libdrm-intel1 libdrm-nouveau1a libdrm-radeon1 libdrm2 libdv4 libdvdread4 libebml3 libecj-java libecryptfs0 libedit2 libelf1 libelfg0 libenca0 libenchant1c2a libespeak1 libevent-1.4-2
  libexcalibur-logkit-java libexif12 libfaac0 libfftw3-3 libflac++6 libflac8 libfluidsynth1 libfontconfig1 libfontconfig1-dev libfreetype6 libfreetype6-dev libftgl-dev libftgl2 libfuse2 libg15daemon-client1 libg15render1 libgamin0 libgc1c2 libgcj-common libgconf2-4
  libgcrypt11 libgcrypt11-dev libgd2-xpm libgdata-common libgdbm3 libgdiplus libgdk-pixbuf2.0-0 libgdu0 libgee2 libgeoclue0 libgeoip1 libgexiv2-0 libggzcore9 libggzmod4 libgimp2.0 libgksu2-0 libgladeui-1-11 libglew1.5 libglew1.5-dev libglewmx1.5 libglib2.0-data
  libglu1-mesa libglu1-mesa-dev libgmime-2.4-2 libgmp3c2 libgnome-menu2 libgnomecanvas2-0 libgnomecanvas2-common libgnomeprint2.2-0 libgnomeprint2.2-data libgnomeprintui2.2-0 libgnomeprintui2.2-common libgnomeui-0 libgnomeui-common libgnomevfs2-bin libgnomevfs2-common
  libgnomevfs2-extra libgoffice-0.8-8-common libgpg-error-dev libgpg-error0 libgpgme11 libgphoto2-2 libgphoto2-port0 libgpm2 libgpod-common libgpod4 libgraph4 libgs9 libgs9-common libgsf-1-114 libgsf-1-common libgsl0ldbl libgssdp-1.0-2 libgstfarsight0.10-0
  libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libgtk2.0-common libgtkglext1 libgtkspell0 libgtop2-7 libgtop2-common libgudev-1.0-0 libguile-ltdl-1 libgupnp-1.0-3 libgupnp-igd-1.0-3 libgutenprint2 libgvc5 libgvpr1 libgweather-common libgwengui-gtk2-0
  libgwenhywfar-data libhal-storage1 libhal1 libhawtjni-runtime-java libhibernate3-java libhpmud0 libhtml-format-perl libhtml-tableextract-perl libhtml-template-perl libhtml-tree-perl libice-dev libice6 libidl0 libidn11 libido-0.1-0 libieee1284-3 libimage-exiftool-perl
  libimlib2 libimobiledevice2 libio-compress-base-perl libio-compress-zlib-perl libipc-run-perl libisccc60 libiw30 libjack0 libjansi-java libjansi-native-java libjaudiotagger-java libjaxen-java libjcommon-java libjfreechart-java libjpeg-progs libjpeg62 libjpeg8
  libjpeg8-dev libjs-jquery libjs-prototype libjs-scriptaculous libjson-glib-1.0-0 libjson-perl libjtidy-java libkeyutils1 libklibc libkms1 libkpathsea5 libktoblzcheck1c2a liblaunchpad-integration-common liblaunchpad-integration1 liblcms1 liblcms1-dev liblircclient0
  liblogback-java liblouis-data liblouis2 libltdl-dev libltdl7 liblua5.1-0 liblvm2app2.2 liblzo2-2 libmagic1 libmagickcore3 libmagickcore3-extra libmagickwand3 libmailtools-perl libmcs1 libmeanwhile1 libmetacity-private0 libmikmod2 libmimic0 libmina2-java libmms0
  libmng1 libmocha-ruby1.8 libmodplug1 libmono-cairo2.0-cil libmono-i18n-west2.0-cil libmp3splt-mp3 libmp3splt-ogg libmp3splt0 libmtdev1 libmysqlclient16 libnet-daemon-perl libnet-domain-tld-perl libnet-ip-perl libnewt0.52 libnih-dbus1 libnih1 libnl1 libnotify4 libnspr4
  libnspr4-0d libnss3 libnss3-1d libofx4 libogg0 libopenal1 libopencc1 liborbit2 liborc-0.4-0 libosp5 libossp-uuid16 libotr2 libpam-ck-connector libpam-gnome-keyring libpam-runtime libpam-smbpass libpam0g libpango1.0-0 libpangomm-1.4-1 libpano13-2 libpano13-bin
  libpaper-utils libpaper1 libparse-debianchangelog-perl libparted0debian1 libpathplan4 libpcap0.8 libpci3 libpciaccess0 libpcsclite1 libphysfs1 libpipeline1 libpisock9 libpisync1 libpixman-1-0 libplist1 libpng12-0 libpng12-dev libpolkit-agent-1-0 libpolkit-backend-1-0
  libpolkit-gobject-1-0 libpolkit-gtk-1-0 libpoppler-glib6 libpoppler13 libportaudio2 libportsmf0 libproxy0 libpt-1.10.10-plugins-alsa libpt-1.10.10-plugins-v4l2 libpthread-stubs0 libpthread-stubs0-dev libpurple-bin libqt3-compat-headers libqt3-headers libqt3-mt
  libqt4-webkit libqtassistantclient4 libqtwebkit-dev libqtwebkit4 libquvi0 libraptor1 libraw1394-11 libreoffice-emailmerge libreoffice-help-en-gb libreoffice-help-en-us libreoffice-help-ja libreoffice-java-common libreoffice-l10n-common libreoffice-l10n-en-gb
  libreoffice-l10n-en-za libreoffice-l10n-ja libreoffice-style-human librpc-xml-perl libruby1.8-extras libsamplerate0 libsane libsane-hpaio libsaxon-java libschroedinger-1.0-0 libscim8c2a libsctp1 libsdl-gfx1.2-4 libsdl-gfx1.2-dev libsdl-image1.2 libsdl-mixer1.2
  libsdl1.2-dev libsdl1.2debian libsdl1.2debian-pulseaudio libselinux1 libsensors4 libsepol1 libservlet2.5-java libsfml-network1.6 libsgutils2-2 libshout3 libslang2 libslang2-dev libslf4j-java libsm-dev libsm6 libsmbclient libsmi2ldbl libsndfile1 libsnmp-base
  libsoundtouch0 libsoup-gnome2.4-1 libsoup2.4-1 libsox-fmt-alsa libsox-fmt-base libsox-fmt-mp3 libsox-fmt-oss libsox-fmt-pulse libsox1b libspeechd2 libspeex1 libspeexdsp1 libspring-aop-2.5-java libspring-beans-2.5-java libspring-context-2.5-java
  libspring-context-support-2.5-java libspring-core-2.5-java libspring-jdbc-2.5-java libspring-tx-2.5-java libspring-web-2.5-java libsqlite0 libsqlite3-0 libsqlite3-dev libsqlite3-ruby libstk0c2a libsvga1 libsvn1 libtalloc2 libtasn1-3 libtasn1-3-dev libtdb1
  libtelepathy-farsight0 libtelepathy-glib0 libtest-pod-perl libthai-data libthai0 libtiff4 libtiffxx0c2 libtmail-ruby1.8 libtomcat6-java libtool libtotem-plparser17 libts-0.0-0 libtwolame0 libudev0 libumfpack5.4.0 libuniconf4.6 libunique-1.0-0 libunistring0 libupnp3
  libupower-glib1 liburi-perl libusb-0.1-4 libusb-1.0-0 libutempter0 libutouch-frame1 libutouch-geis1 libutouch-grail1 libuuid1 libva-x11-1 libva1 libvecmath-java libvisual-0.4-plugins libvlc5 libvlccore4 libvorbis0a libvorbisenc2 libvorbisfile3 libwbclient0
  libwebkitgtk-1.0-0 libwebkitgtk-1.0-common libwildmidi1 libwireshark-data libwmf-bin libwmf0.2-7 libwmf0.2-7-gtk libwnck-common libwnck22 libwpg-0.2-2 libwrap0 libwvstreams4.6-base libwxbase2.6-0 libwxbase2.8-0 libwxgtk2.6-0 libwxgtk2.8-0 libx11-6 libx11-data
  libx11-dev libx11-xcb1 libx86-1 libxau-dev libxau6 libxcb-dri2-0 libxcb-keysyms1 libxcb-randr0 libxcb-render0 libxcb-shape0 libxcb-shm0 libxcb-xv0 libxcb1 libxcb1-dev libxcomposite1 libxcursor-dev libxcursor1 libxdamage1 libxdmcp-dev libxdmcp6 libxerces2-java
  libxext-dev libxext6 libxfixes-dev libxfixes3 libxfont1 libxft-dev libxft2 libxi-dev libxi6 libxinerama-dev libxinerama1 libxklavier16 libxml-twig-perl libxml2 libxml2-utils libxmlgraphics-commons-java libxmlrpc-core-c3-0 libxmu-dev libxmu-headers libxmu6 libxmuu1
  libxom-java libxp6 libxrandr-dev libxrandr2 libxrender-dev libxrender1 libxslt1.1 libxss1 libxt-dev libxt6 libxtst6 libxv1 libxvidcore4 libxxf86vm1 libyaml-0-2 libzbar0 libzeitgeist-1.0-1 libzephyr4 lintian linux-firmware linux-libc-dev linux-sound-base lksctp-tools
  lm-sensors locales lockfile-progs login logrotate lsb-base lsb-release m17n-contrib m17n-db m4 make man-db mdf2iso media-player-info meld memtest86+ mercurial mercurial-common metacity metacity-common mlocate mobile-broadband-provider-info modemmanager
  module-init-tools mountall mtr-tiny multiarch-support myspell-en-au myspell-en-gb myspell-en-za mysql-client-5.1 mysql-client-core-5.1 mysql-common mysql-navigator mysql-server mysql-server-5.1 mysql-server-core-5.1 mythes-en-us ncurses-base netbase netcat
  netcat-openbsd netcat-traditional nicotine ntpdate nux-tools nvidia-common nvidia-current nvidia-settings obexd-client onboard openoffice.org-calc openoffice.org-common openoffice.org-draw openoffice.org-emailmerge openoffice.org-gnome openoffice.org-gtk
  openoffice.org-help-en-gb openoffice.org-help-en-us openoffice.org-help-ja openoffice.org-hyphenation-en-us openoffice.org-impress openoffice.org-java-common openoffice.org-l10n-en-gb openoffice.org-l10n-en-za openoffice.org-l10n-ja openoffice.org-math
  openoffice.org-thesaurus-en-us openoffice.org-writer openssl-blacklist os-prober p7zip-full passwd patch patchutils pbuilder pbzip2 pciutils pgadmin3 pgadmin3-data pidgin-skype pitivi pkg-config plymouth-theme-ubuntu-logo plymouth-theme-ubuntu-text pm-utils
  policykit-1 policykit-1-gnome policykit-desktop-privileges poppler-utils popularity-contest postgresql-client-common postgresql-common postgresql-doc-8.4 pppoeconf pristine-tar procps projectm-data psmisc putty putty-tools pxljr python-apport python-apt-common
  python-argparse python-avahi python-brlapi python-bzrlib python-cairo python-central python-chardet python-compizconfig python-configglue python-configobj python-cups python-cupshelpers python-dateutil python-dbus python-debian python-desktopcouch-application
  python-desktopcouch-records python-django python-django-debug-toolbar python-django-doc python-dns python-egenix-mxdatetime python-egenix-mxtools python-farsight python-feedparser python-gdata python-gdbm python-gmenu python-gnomekeyring python-gnupginterface
  python-gobject-cairo python-gpod python-gst0.10 python-gtksourceview2 python-gtkspell python-httplib2 python-imaging python-keyring python-launchpad-integration python-launchpadlib python-lazr.restfulclient python-lazr.uri python-libproxy python-libxml2
  python-logilab-common python-louis python-lxml python-magic python-mako python-markupsafe python-musicbrainz2 python-mutagen python-mysqldb python-nltk python-notify python-numpy python-oauth python-openid python-papyon python-paramiko python-pexpect python-pip
  python-piston-mini-client python-pkg-resources python-problem-report python-psycopg2 python-pygame python-pyinotify python-qt4 python-renderpm python-reportbug python-reportlab python-reportlab-accel python-rsvg python-serial python-setuptools python-simplejson
  python-sip python-smbc python-software-properties python-speechd python-support python-telepathy python-tk python-twisted-bin python-twisted-core python-twisted-names python-twisted-web python-ubuntuone-storageprotocol python-utidylib python-virtkey python-wadllib
  python-webkit python-wnck python-wsgi-intercept python-wxgtk2.6 python-wxgtk2.8 python-wxversion python-xdg python-xkit python-yaml python-zope.interface qt3-dev-tools quodlibet-plugins rails rails-ruby1.8 rake readline-common reportbug rsync rsyslog rtkit
  ruby-actionmailer ruby-actionmailer-2.3 ruby-actionpack ruby-actionpack-2.3 ruby-activerecord ruby-activerecord-2.3 ruby-activeresource ruby-activeresource-2.3 ruby-activesupport ruby-activesupport-2.3 ruby-mocha ruby-net-ldap ruby-rails-2.3 ruby-rchardet rubygems
  rubygems1.8 samba samba-common samba-common-bin sane-utils scim-bridge-client-gtk scim-gtk2-immodule scim-modules-socket scons screen screen-resolution-extra sed sessioninstaller sg3-utils sgml-data shared-mime-info sharutils smbclient sox speech-dispatcher splix
  sqlite sqlite3 ssh-askpass-gnome stk strace subversion sudo swig syslinux syslinux-common system-config-printer-common system-config-printer-gnome system-config-printer-udev sysv-rc sysvinit-utils tasksel tasksel-data tcl8.5 tcpd telepathy-butterfly telepathy-haze
  tesseract-ocr thunderbird-locale-ja tk8.5 torcs toshset transfig tsconf ttf-dejavu ttf-dejavu-core ttf-dejavu-extra ttf-droid ttf-freefont ttf-liberation ttf-mscorefonts-installer ttf-opensymbol ttf-thai-tlwg ttf-ubuntu-font-family ttf-wqy-zenhei twolame tzdata
  tzdata-java ubufox ubuntu-artwork ubuntu-docs ubuntu-minimal ubuntu-mono ubuntu-sso-client ubuntu-standard ubuntu-system-service ubuntu-wallpapers ucf udev udisks ufw unattended-upgrades unetbootin unetbootin-translations uni2ascii unity-asset-pool uno-libs3
  update-inetd upstart ure usb-modeswitch usb-modeswitch-data usbutils util-linux uuid-runtime vlc-data wdiff whiptail whois wifi-radar winbind winetricks winpdb wireless-crda wireless-tools wvdial x-ttcidfont-conf x11-common x11-utils x11-xfs-utils x11-xkb-utils
  x11-xserver-utils x11proto-core-dev x11proto-fixes-dev x11proto-input-dev x11proto-kb-dev x11proto-render-dev x11proto-xext-dev x11proto-xinerama-dev xauth xbase-clients xdg-user-dirs xdg-user-dirs-gtk xdg-utils xfonts-utils xinit xkb-data xorg xorg-docs-core
  xorg-sgml-doctools xpdf xsane xsane-common xscreensaver-data xscreensaver-gl xserver-common xserver-xorg xserver-xorg-input-all xserver-xorg-input-evdev xserver-xorg-input-mouse xserver-xorg-input-synaptics xserver-xorg-input-vmmouse xserver-xorg-input-wacom
  xserver-xorg-video-all xserver-xorg-video-apm xserver-xorg-video-ark xserver-xorg-video-ati xserver-xorg-video-chips xserver-xorg-video-i128 xserver-xorg-video-mach64 xserver-xorg-video-neomagic xserver-xorg-video-nouveau xserver-xorg-video-openchrome
  xserver-xorg-video-qxl xserver-xorg-video-r128 xserver-xorg-video-radeon xserver-xorg-video-s3 xserver-xorg-video-s3virge xserver-xorg-video-siliconmotion xserver-xorg-video-sis xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident
  xserver-xorg-video-tseng xserver-xorg-video-vesa xserver-xorg-video-vmware xserver-xorg-video-voodoo xsltproc xterm xtrans-dev xul-ext-ubufox yelp-xsl zeitgeist zeitgeist-core zeitgeist-datahub zeitgeist-extension-fts zip
1191 upgraded, 0 newly installed, 0 to remove and 700 not upgraded.
Need to get 778 MB of archives.
After this operation, 109 MB disk space will be freed.
...
Get:1181 http://us.archive.ubuntu.com/ubuntu/ oneiric/main pbuilder all 0.199+nmu3ubuntu3 [325 kB]
Get:1182 http://us.archive.ubuntu.com/ubuntu/ oneiric/main python-brlapi amd64 4.2-8ubuntu5 [86.9 kB]
Get:1183 http://us.archive.ubuntu.com/ubuntu/ oneiric/universe python-gdata all 2.0.14-2 [458 kB]
Get:1184 http://us.archive.ubuntu.com/ubuntu/ oneiric/main python-louis amd64 2.3.0-2ubuntu1 [5,822 B]
Get:1185 http://us.archive.ubuntu.com/ubuntu/ oneiric/main python-magic amd64 5.04-5ubuntu3 [7,952 B]
Get:1186 http://us.archive.ubuntu.com/ubuntu/ oneiric/main python-piston-mini-client all 0.6+bzr48-0ubuntu1 [16.8 kB]
Get:1187 http://us.archive.ubuntu.com/ubuntu/ oneiric/main python-speechd all 0.7.1-6ubuntu1 [44.2 kB]
Get:1188 http://us.archive.ubuntu.com/ubuntu/ oneiric/universe python-wsgi-intercept all 0.4-0ubuntu2 [43.3 kB]
Get:1189 http://us.archive.ubuntu.com/ubuntu/ oneiric/universe quodlibet-plugins all 1:2.3-1 [74.2 kB]
Get:1190 http://us.archive.ubuntu.com/ubuntu/ oneiric/main sessioninstaller all 0.20+bzr120-0ubuntu2 [29.0 kB]
Get:1191 http://us.archive.ubuntu.com/ubuntu/ oneiric/main speech-dispatcher amd64 0.7.1-6ubuntu1 [471 kB]
Fetched 778 MB in 2h 45min 59s (78.1 kB/s)
E: Could not perform immediate configuration on 'util-linux'. Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)
~$

Sam_ (and-sam) said : #4

> man 5 apt.conf under APT::Immediate-Configure for details. (2)

Refer to 'Immediate-Configure'
http://manpages.ubuntu.com/manpages/oneiric/en/man5/apt.conf.5.html

Thanks for the suggestion about immediate configure. This did not solve the main problem, which is that dpkg is erroring.

~$ sudo apt-get -o APT::Immediate-Configure=false upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages have been kept back:
  acroread aisleriot alsa-utils apache2 apache2-mpm-worker apache2-utils apache2.2-bin apache2.2-common appmenu-gtk apport-gtk apt apt-transport-https apt-utils aptdaemon aptitude apturl apturl-common aspectj at-spi audacity audacity-data bamfdaemon banshee
  banshee-extension-soundmenu banshee-extension-ubuntuonemusicstore baobab bind9-host binutils blender bogofilter-bdb brasero brasero-cdrkit brasero-common brltty brltty-x11 ca-certificates cdrdao checkbox checkbox-gtk chromium-browser chromium-browser-l10n cmake
  cmake-curses-gui cmake-data compiz compiz-core compiz-gnome compiz-plugins compiz-plugins-extra compiz-plugins-main compizconfig-backend-gconf computer-janitor computer-janitor-gtk console-setup couchdb-bin cpp cpp-4.4 cpp-4.5 cups
...
Do you want to continue [Y/n]? Y
Extracting templates from packages: 100%
Preconfiguring packages ...
dpkg: error: configuration error: /etc/dpkg/dpkg.cfg.d/multiarch:1: unknown option 'foreign-architecture'
keyboard-configuration failed to preconfigure, with exit status 2
dpkg: error: configuration error: /etc/dpkg/dpkg.cfg.d/multiarch:1: unknown option 'foreign-architecture'
dpkg: error: configuration error: /etc/dpkg/dpkg.cfg.d/multiarch:1: unknown option 'foreign-architecture'
E: Sub-process /usr/bin/dpkg returned an error code (2)
~$

gregory (gregory-hainaut) said : #6

Your current dpkg version seem to not support the foreign-architecture option. In my opinion,
1/remove the file /etc/dpkg/dpkg.cfg.d/multiarch (save it somewhere).
2/Upgrade dpkg to the latest.
3/ Readd /etc/dpkg/dpkg.cfg.d/multiarch
4/ finish your upgrade

Steph (steph-8) said : #7

Unfortunately it says dpkg is the latest version.

gregory (gregory-hainaut) said : #8

Are you sure it is the latest of 11.10 and not the latest of 11.04. You can check dpkg version with this command
"dpkg -l | grep dpkg"

In any case for the moment remove multiarch stuff, do a full upgrade. You can still add multiarch later anyway.

Thank you very much for your replies, gregory and Steph!

I removed the multiarch configuration file.

I loaded up Synaptic, and noticed something strange last night - in the sources configuration, all of the checkboxes on the first tab were unchecked. It seemed like those were the primary repositories, so I checked them. It could be that they were unchecked during the first upgrade attempt, and incorrect versions of packages were installed?

The installed version of dpkg was something like "natty+1" which was somehow later than the official Oneiric version, which I believe is 1.16.0.3ubuntu5. In Synaptic, I downgraded dpkg, which worked because of the fixed configuration suggestion from gregory. I then ran update and upgrade, but that failed with the problem above, could not perform immediate upgrade on util-linux. I followed my findings above to force immediate on the upgrade of that package, and that seemed to work.

Then apt, synaptic, and aptitude would all crash during reading package lists by seg faulting in libc. I found this thread:
http://ubuntuforums.org/showthread.php?t=1129887

and found that
sudo apt-get check -o dir::cache=/tmp
worked, so I
cd /var/cache/apt
sudo rm *.bin*

and now apt is running again. I am running the upgrade again now. I suspect that it will still fail, but will update this question with results. Thank you again for the assistance so far.

Steph (steph-8) said : #10

How did you change the installed version of dpkg?

How I changed the installed version of dpkg:

In synaptic I searched for dpkg.
One of the columns in the search results indicates which version is currently installed, which was something like "natty+1".
I searched for the proper release version of dpkg somewhere on ubuntu.com, and it was not "natty+1".
Under the package menu, I selected "force version" and looked at the options available.
The version listed on the website was in the list, along with this "natty+1" version. I selected the version shown on the website.
Synaptic indicated in all caps that the version I chose was a downgrade, and I told it to proceed.
Synaptic then installed the proper version of dpkg, as far as I know.

I then ran sudo apt-get upgrade. The upgrade completed, I rebooted, but did not get unity. X welcomed me with the error:
"There is a problem with the configuration server. (/usr/lib/libgconf2-4/gconf-sanity-check-2 exited with status 32512)"

It then repeated the error once or twice more, loaded into a desktop, which seems like the older style gnome - no unity. I did not record the error message, but it told me I should select a different desktop on login. The system seems to be working otherwise.

I loaded up synaptic, did a reload, and a mark all upgrades. There was a large list of changes. It held back evolution, so I marked evolution-common and evolution-plugins for complete removal (I don't use evolution, I use Thunderbird, and they switched the default mail client to Thunderbird in this release as far as I know, so it seemed OK to finally remove evolution). It still held back wine and flash-plugin-nonfree, probably because I have newer versions of those from PPAs previously. Right now Synaptic is processing the long list of removals, installs, and upgrades.

Since I just completed an upgrade, that seems suspicious. But maybe this round it will sort everything out. I will update with more information later.

The Synaptic 'mark all upgrades' failed with

E: Internal Error, Could not early remove libaudio2

I found this thread talking about it:
https://bugs.launchpad.net/ubuntu/+source/apt/+bug/802901

and this seemed to do the trick:
dpkg --remove --force-depends libaudio2

then Synaptic said there were broken packages, so I ran a repair broken packages which completed.

Now I am running the 'mark all upgrades again'. More to follow.

Synaptic would not complete its updates, claiming it couldn't remove libaudio2 and another package, after I force removed it.

I specially asked Synaptic to remove that package, and it had to remove some other software from the system, including things like VLC, but no core system packages (thankfully). The remove succeeded, then I tried again with mark all updates.

It could not 'early remove' something else, and I repeated the process. After that, the update completed successfully, requiring a restart. Now that I have rebooted, I seem to have full Oneiric. The list of updates was short, and I was able to reinstall VLC and other things I need back.

Thanks for all the replies, Sam, gregory, and Steph!

SwitchDK (switchdk) said : #14

Hi Benjamin,

I'm curious to know if you by any chance have Redmine installed and if you are using
Ondřej Surý's archive (https://launchpad.net/~ondrej/+archive/redmine/+build/2804798). I have just noticed more Ubuntu users experiencing the same problem as you and at least one of them had the same version of dpkg-1.16.1~natty+1, which as I understand it (my apologies if I am incorrect) is part of Ondřej Surý's PPA.

Many thanks,
Peter Dam (SwitchDK)

Bingo. Yes I was using the ondrej PPA. Coincidentally, I was just now editing project notes in my local redmine. I would be very happy if my question led to a fix for the problem! Let me know if I can be of any further service.

SwitchDK (switchdk) said : #16

Many thanks for confirming that Benjamin.

I have been able to reproduce the problem by creating a clean installation of Ubuntu 11.04 and then adding Ondřej Surý's PPA by:

sudo apt-add-repository ppa:ondrej/redmine
sudo apt-get install dpkg dpkg-dev libdpkg-perl redmine

When I run the Update Manager and attempt upgrade to 11.10 it then fails with the same errors as you have reported.

To fix the problem I did the following:

sudo rm /etc/dpkg/dpkg.cfg.d/multiarch
sudo apt-get install dpkg=1.16.0.3ubuntu5
Ran the Update Manager again and then the upgrade commenced.

I will create a bug report to capture all the information you provided and also the fix.

Many thanks,
Peter Dam (SwitchDK)

SwitchDK (switchdk) said : #17

My apologies but I forgot to add a step in post #16:

To reproduce do the following:

sudo apt-add-repository ppa:ondrej/redmine
-->sudo apt-get update
sudo apt-get install dpkg dpkg-dev libdpkg-perl redmine

Mehman Jamalov (sensenku89) said : #18

Please, can you upgrade the source for Ubuntu 17.10?