Upgrade from Lucid 10.04 to Maverick 10.10 Fails

Asked by Rick B.

In trying to upgrade from 10.04 to 10.10, the installation fails when checking software channels. The error basically says that there are breaks, broken depends and unmet dependencies. Yet Package Manager shows that there are no broken packages and mostly everything is running OK except for the Suspend option which doesn't work in 10.04 on a good number of various laptops. I am using an IBM Thinkpad R51 laptop with 1.5 GHz and 512 MB RAM. I have never had a problem like this with any Ubuntu upgrade in the past. How can I get past this problem and upgrade to 10.10? Log files available upon request. If log files needed, please be specific about what file you want to look at. Thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu update-manager Edit question
Assignee:
No assignee Edit question
Solved by:
Rick B.
Solved:
Last query:
Last reply:
Revision history for this message
mycae (mycae) said :
#1

You are probably using non-standard packages, such as obtained from PPAs or third party sources; you will likely have to remove all of these before you can update. Try using the synaptic package manager, and filter based upon origin.

Revision history for this message
Rick B. (rbeltz48) said :
#2

So, are you telling me that this is now required in order to upgrade from 10.04 to 10.10? I never had to remove any third party packages to upgrade in the past going back to 8.10. Please explain. Thanks.

Revision history for this message
Sam_ (and-sam) said :
#3

> Please explain

Dependencies are dependencies are dependencies plus Murphys law.

> be specific about what file you want to look at

lsb_release -d
sudo apt-get update
sudo apt-get upgrade

http://www.ubuntu.com/desktop/get-ubuntu/upgrade

Revision history for this message
Manfred Hampl (m-hampl) said :
#4

You have not provided the exact error message that shows up, so we have to guess a bit.

There is a known problem that the 10.04 to 10.10 upgrade fails with the error message
"Could not determine the upgrade
An unresolvable problem occurred while calculating the upgrade:
E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
This can be caused by:
* Upgrading to a pre-release version of Ubuntu
* Running the current pre-release version of Ubuntu
* Unofficial software packages not provided by Ubuntu"

If that is your error message, and if you have the package xserver-xorg-video-nouveau installed, then removing that package can help (see bug 663158, bug 658458 and bug 658581)

If that is not your error message, and/or if that does not help please provide the output of the following commands:

lsb_release -d
sudo apt-get update
sudo apt-get upgrade

Revision history for this message
Rick B. (rbeltz48) said :
#5

Thanks for all those who replied about this problem. Thank you Manfred for the correct answer to this error.

The third party software and PPAs had nothing to do with the problem. It was the bugs which Manfred described above. I removed the xserver-xorg-video-nouveau package which I noticed is "experimental". The upgrade ran OK on both my IBM laptop and Dell desktop this morning. No hitches. It's really good to know that good support for Ubuntu can be found here at Launchpad, even more so than on the forums! Thanks again to everyone.

Revision history for this message
Rick B. (rbeltz48) said :
#6

One thing I forgot. The suspend option for my IBM Thinkpad R51 laptop still doesn't work with 10.10. It did not with 10.04 but did work fine with 9.10. Is a fix for this coming down soon? Thanks.