Update to UBUNTU 10.10 error

Asked by Bill Henry on 2010-12-06

I'm running UBUNTU 10.4 LTS concurrent with Windows 7 (64) on an HP Pavilion Elite Model: e9120y. Using Update Manager, I've attempted to update to UBUNTU 10.10 at least 6 times. It fails at "Setting New Software Channels", at the end, with the following error message:

W:Failed to fetch http://security.ubuntu.com/ubuntu/dists/maverick-security/Release.gpg Something wicked happened resolving 'security.ubuntu.com:http' (-5 - No address associated with hostname), E:Some index files failed to download, they have been ignored, or old ones used instead.

I don't know what to do next.

I downloaded the 10.10 ISO and burned it to a CD. Can I upgrade using it?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu update-manager Edit question
Assignee:
No assignee Edit question
Solved by:
Bill Henry
Solved:
2010-12-08
Last query:
2010-12-08
Last reply:
2010-12-06
karlrt (karlrt) said : #1

I think this is just a dns issue. Might be that your router isnt configured right, or you use a proxy, or you changes smth in /etc/hosts

See http://ubuntuforums.org/archive/index.php/t-1476136.html or https://answers.launchpad.net/ubuntu/+question/117265

Check how you are connected to the internet, and whats the dns-server (right click on the network-manager-applet -> status)

Bill Henry (bidihenry) said : #2

Problem solved. Thanks for all the input, I learned a lot about DNS, my router and resolv.conf. I ended up adding Google(8.8.8.8) as an additional 'nameserver' to my resolv.conf file. After that I was able to update to UBUNTU 10.10 without any trouble. After the upgrade I did have to change my resolv.conf file again, as it was over-written.