Karmic load/upgrade issues

Asked by Rick

I've tried installing from a 9.10 beta build I downloaded last week and from an in-place upgrade today after a 9.04 install with mixed results from both. On the 9.10 clean install, after the installer completed the computer would just hang on the restart command and the screen would flash the background image until I pressed the reset button. The system would not respond to a control-alt-delete command either. After the restart, the system would boot into Karmic but there were broken packages and incomplete installations. I also received errors about the firmware on my motherboard not being compatible during the booting with grub 2. I've never seen that error with GRUB and any version prior to 9.10. System specs will be at the bottom.

Thinking I had a possible bad image i opted to try an in-place distro upgrade after a clean 9.04 install. I updated 9.04 prior to attempting the upgrade. After the upgrade and a restart I initiated the upgrade. the system seemed to upgrade fine until the reboot. Upon reboot, I was presented with the GRUB menu and selected the latest kernel .31 I believe. The boot splash displayed then went to a blank screen with no hard drive activity. I thought maybe I had a hang so after a few minutes I restarted the machine. Upon restart I selected the prior kernel to see if it would boot. Same results. I entered recovery mode after the third reboot and ran a package check. Three packages were returned as needing upgrades to be compatible. I opted for the upgrades and continued a normal boot after successful installation. Once again the same results, a splash screen and the a blank screen with no hard drive activity.

 I'm beginning to think 9.10 isn't for my machine. Ubuntu 9.04 installs and updates without issues. I had no problems installing or upgrading any other beta release for 8.04/8.10/9.04 at all. I've tried setting the BIOS plug and play option on and off to see if this would help. It has not. The AMD cool adn quiet BIOS options are disabled and I have tried turning the power management options off as well. Any other ideas would be appreciated.

Here's the specs:

AMD Athlon 64 X2 4800+
ASUS A8N-SLI Deluxe Motherboard (latest firmware installed)
GForce 6800XT video card (PCI-e 512MB RAM on-board none shared from system)
Segate 250 GB Hard drive for Linux (IDE)
WD 320 Gb Hard drive for Win 7 (SATA)

Question information

English Edit question
Ubuntu update-manager-core Edit question
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Last query:
Last reply:
Revision history for this message
Rick (frkuout) said :

Forgot to add that I'm trying to use the AMD64 version. Currently have 9.04 AMD 64 installed.

Revision history for this message
actionparsnip (andrew-woodhead666) said :

You should know if it was a bad image as you should have checked it using MD5 summing to validate the ISO you have was good. Bad ISO will make a bad install. Have you tested the CD you burned with the CD self tester too?

Have you tried some bootoptions:

That may help too. You NEED to verify the downloads you get as this can knock a lot of problems on the head:

Revision history for this message
Rick (frkuout) said :

I'll check those but it doesn't answer the problems with the distro upgrade via the update manager. After upgrading to 9.10 on a known good 9.04 install the system would not boot past the start-up splash screen. I've never had to use any boot options in the past so I would expect that a minor release would not need them as well.

I checked the MD5Sum for the download and it checks good. Any other ideas please?

Revision history for this message
actionparsnip (andrew-woodhead666) said :

Very weird, If its a known good install using the official repos for upgrades the the debs downloaded are md5 checked too.

Maybe someone else can contribute.

Revision history for this message
Rick (frkuout) said :

I didn't think you could check the debs during an upgrade done with the update manager. Used the alt-f2 and ran updae-manager -d to get the distro update prompt for upgrade. Everything seemed normal until the reboot.

Revision history for this message
Rick (frkuout) said :

I just tried a fresh download of the i386 version. Same issue as before. Installation goes fine until the reboot prompt. After reboot is selected, the screen just flashes the background and the computer still does not respond.

I had Windows verify the CD after burning was complete to endure everything was good. I then checked the disk for errors upson booting into the install menu. The check came back with 1 file bad but it didn't specify which one. I thought it would not effect the install so I went ahead with it. This is very perplexing as no previous version of Ubuntu has given me issues.

I'm still see two errors flash momentarily during the CD boot. Something about a firmware bug and not being compatible with K-8 processor. I don't know if this is an issue with the GRUB 2 bootloader or maybet he installer. Again I've never seen that error with the previous versions.

Revision history for this message
Best marcobra (Marco Braida) (marcobra) said :

If you still have the install issue please try the release candidate of Ubuntu

Please download the ubuntu-9.10-rc-desktop-i386.iso image using torrent protocol
please read: https://answers.launchpad.net/ubuntu/+question/86603

then retry to install...

Hope this helps

Revision history for this message
Rick (frkuout) said :

That did it. I don't know what was in the beta that kept it form installing correctly but the RC worked like a champ! I used the AMD64 version and now I'm going to give Kubuntu i386 version a whirl.


Revision history for this message
Rick (frkuout) said :

Thanks marcobra (Marco Braida), that solved my question.